Results 1 to 3 of 3

Thread: Installation works(?!), but it doesn't startup on MBP. ucode16_mimo.fw problems

  1. #1
    Join Date

    Installation works(?!), but it doesn't startup on MBP. ucode16_mimo.fw problems

    1. I'm installing the current 2016.1 64-bit Kali. I have downloaded the ISO and burned it onto disc.

    2. I pop it into my Macbook Pro 15" and hold down the "c" key.

    3. Installation goes fine, but it does give me this prompt:

    "Some of your hardware needs non-free firmware files to operate. The firmware can be loaded from removable media, such as a USB stick or floppy.
    The missing firmware files are:b43/ucode16_mimo.fw b43/ucode16_mimo.fw b43-open/ucode16_mimo.fw
    If you have such media avalable now, insert it, and continue.
    Load missing firmware from removable media?

    I don't know where to download them from.
    And once I do, I will put them on a USB. But what format do I make the USB from Disk Utility?

    I've googled and searched and have founds bit and pieces of files but I don't even know if they are credible. The best hope I had was off this ubuntu thread, but downloading, unzipping, putting it onto the exfat formatted drive and popping it into the macbook at this prompt did not work, and it gave me the same screen as above after it spent some time looking for the missing files (presumably from the USB).

    If I select "no", it lets me continue, and the installation goes well. I take out the disk, and then it hangs on startup. The line seems like its the bluetooth hardware (broadcom).

    The funny thing is, its using the ethernet cable and not wifi right now. I don't even need the broadcom to be working before startup.

    If I can't find the necessary files to pop onto the USB, can I somehow start it up, and THEN install the necessary broadcom files?

    What makes this situation horrible is that I had previously installed the 32bit kali to macbooks older than this with less of a problem.

    Please Help. I'm sitting here stuck, and waiting for someone to save this situation.

  2. #2
    Join Date
    Ok. I'm still not making any real progress in having a single boot kali machine using my MBP5,3.

    But, as I can load it up with OS X, I have put virtual box and installed kali from there. It still won't recognize my wireless card (BCM4322).

    I'm considering making a custom kali iso image which would have the broadcom adapters, but im still not sure where to get them.

    Can anybody help so I can use the wifi card on my macbook.

    Or better yet, how I can make a custom image with the b43 drivers?
    Just starting. Will need some help. Thanks in advance.

  3. #3
    Hi Kalilama,

    First, you can't use your MacBook wifi card directly into Virtual Box, it works only with USB device, your embedded hardwares are already in use by OSX, that's why your guest Kali shows it as an ethernet card.

    About, installing Kali on your MacBook, don't use your wifi card during installation, this model seems to be not supported by embedded firmwares. You can add the missing firmware "ucode16_mimo.fw" later into /etc/firmware and reboot. If it's the right firmware, you'll be able to use your wifi card. Try with this one first :

    It's not really a Kali issue, but a classic Linux behaviour, they try to include the most famous firmwares, but they can't add all, we can already thanks us for the amazing work they give everyday to the community ! So you can look into Debian / Ubuntu forums if others users as the same issue.

Similar Threads

  1. Replies: 0
    Last Post: 2018-03-24, 17:04
  2. Replies: 0
    Last Post: 2017-04-05, 16:29
  3. TP-LINK TL-WN722N and OnePlus One sometimes works, often doesn't. At wits end!
    By nethunterissues in forum NetHunter General Questions
    Replies: 3
    Last Post: 2016-09-19, 15:13

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts