Results 1 to 5 of 5

Thread: cannot download "metasploit-framework" and "exploitdb" packages

  1. #1
    Join Date
    2016-Jul
    Posts
    3

    cannot download "metasploit-framework" and "exploitdb" packages

    I have a problem with both the VMWare and VirtualBox Kali Linux appliances available for download at the main site.

    I can't seem to download and install the following packages with either version of virtual machine:

    exploitdb
    metasploit-framework

    I have tried the usual "apt-get clean" and "apt-get upgrade" to no avail.
    I have set my "/etc/apt/sources.list" to the less busy "deb http://repo.kali.org/kali kali-rolling main non-free contrib" with no effect.

    I have got all the other packages to upgrade successfully by bypassing these two packages with:
    apt-mark hold exploitdb
    apt-mark hold metaspoit-framework

    Is anyone else experiencing this problem?

  2. #2
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    805
    I'm running Kali in a native install...just ran apt-get update && apt-get dist-upgrade. My /etc/apt/sources.list is set to the Kali default. Didn't have any problems installing these packages. Did you get any errors?

  3. #3
    Join Date
    2016-Jul
    Posts
    3
    Quote Originally Posted by grid View Post
    I'm running Kali in a native install...just ran apt-get update && apt-get dist-upgrade. My /etc/apt/sources.list is set to the Kali default. Didn't have any problems installing these packages. Did you get any errors?
    I don't get any errors, the two packages just never complete download (they keep starting over and over again attempting download).

    I can try uninstalling metaspolit-framework, and exploitdb, and see if that makes a difference or not.

  4. #4
    Join Date
    2016-Jul
    Posts
    3

    solved with network change

    Problem was solved with changing the virtual network adapter from "NAT" to "Bridged" ...

  5. #5
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    805
    Glad you got it fixed

Similar Threads

  1. Need advice on "Live" versus "Installed" custom builds
    By malakaldayook in forum Building Archive
    Replies: 3
    Last Post: 2017-10-03, 08:54
  2. Replies: 1
    Last Post: 2015-10-20, 13:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •