Results 1 to 8 of 8

Thread: how to change the display manager 'login screen' on kali 2016.1

  1. #1
    Join Date
    2016-Jul
    Posts
    26

    how to change the display manager 'login screen' on kali 2016.1

    i would like to have either a list or icons of local users in my kali 2016.1 installation, can anybody point me the right direction? i just find it annoying having to type in the username and password at the login screen. I know different display managers have a way of configuring them like lightdm but i am not sure where to go for the pre-installed one 'gdm3'

  2. #2
    Join Date
    2013-Sep
    Posts
    264
    You will find good explanations here :
    GDM @ debian.org
    Basically it looks like you have to have an entry like that in your /etc/gdm3/daemon.conf file
    Code:
     [daemon]
        # Enabling automatic login
        AutomaticLoginEnable=true
        AutomaticLogin=$USERNAME
    Instead of what you have (where AutomaticLoginEnable=false and no Automaticlogin variable exists)

  3. #3
    Join Date
    2016-Jul
    Posts
    26
    Quote Originally Posted by kcdtv View Post
    You will find good explanations here :
    GDM @ debian.org
    Basically it looks like you have to have an entry like that in your /etc/gdm3/daemon.conf file
    Code:
     [daemon]
        # Enabling automatic login
        AutomaticLoginEnable=true
        AutomaticLogin=$USERNAME
    Instead of what you have (where AutomaticLoginEnable=false and no Automaticlogin variable exists)
    @kcdtv thanks for your response! i actually did play around with that .conf file and wondered if that was it, although what you are suggesting above is to automate my login with whatever user i want, i actually would like to get an option as a drop down menu or perhaps pictures where i can just select the account i want to log in as and then just type in the password, i currently have 3 accounts on kali, any other thoughts?

  4. #4
    Join Date
    2013-Sep
    Posts
    264
    Ok, I misunderstood you, I epxlain you why.
    Until your message i didn't realized that kali doesn't have an avlalaible list of the users
    I thought it had.
    I checked my greeter.dconf-defaults in gm3 directory and was suprised taht the list of users should be anbled
    # These are the options for the greeter session that can be set
    # through GSettings. Any GSettings setting that is used by the
    # greeter session can be set here.

    # Note that you must configure the path used by dconf to store the
    # configuration, not the GSettings path.


    # Theming options
    # ===============
    # - Change the GTK+ theme
    # [org/gnome/desktop/interface]
    # gtk-theme='Adwaita'
    # - Use another background
    # [org/gnome/desktop/background]
    # picture-uri='file:///usr/share/themes/Adwaita/backgrounds/stripes.jpg'
    # picture-options='zoom'
    # - Or no background at all
    # [org/gnome/desktop/background]
    # picture-options='none'
    # primary-color='#000000'

    # Login manager options
    # =====================
    [org/gnome/login-screen]
    logo='/usr/share/icons/gnome/48x48/places/debian-swirl.png'
    fallback-logo='/usr/share/icons/gnome/48x48/places/debian-swirl.png'

    # - Disable user list
    # disable-user-list=true

    # - Disable restart buttons
    # disable-restart-buttons=true
    # - Show a login welcome message
    # banner-message-enable=true
    # banner-message-text='Welcome'
    It is "quoted" so it is not "active" and i should have the list enabled....
    That's weird.
    Let's see if we find a workaround I am gonna try some stuffs

  5. #5
    Join Date
    2016-Jul
    Posts
    26
    Quote Originally Posted by kcdtv View Post
    Ok, I misunderstood you, I epxlain you why.
    Until your message i didn't realized that kali doesn't have an avlalaible list of the users
    I thought it had.
    I checked my greeter.dconf-defaults in gm3 directory and was suprised taht the list of users should be anbled

    It is "quoted" so it is not "active" and i should have the list enabled....
    That's weird.
    Let's see if we find a workaround I am gonna try some stuffs
    Thanks again!! yea, i had tried unquoting it, but didnt work.. so i thought maybe there was a different file i needed to mess with, hope you find a solution, will wait for a response.

  6. #6
    Join Date
    2016-Jul
    Posts
    26
    installed kali 2.0 on a vm and has the same results, works on 1.0;
    kali.jpg

    and leaving the line as disable-user-list=true does what is suppose to do.

  7. #7
    Join Date
    2013-Sep
    Posts
    264
    thanks for the information, aty least we know taht it is specific to kali roling
    Last edited by kcdtv; 2016-08-04 at 15:20.

  8. #8
    Join Date
    2017-Nov
    Posts
    1

    Resolved

    Hi all,
    After hours checking this and before bug opening, I've found the trick :
    You have to look at /usr/share/gdm/dconf
    There's a file called 91-kali-settings in which you have to comment the line 'disable-user-list = true'

    Regards.
    Touffman

Similar Threads

  1. Unable to change Login-Screen
    By haelos in forum General Archive
    Replies: 5
    Last Post: 2016-08-26, 15:23
  2. Replies: 2
    Last Post: 2016-02-06, 18:11
  3. Can't change login screen or TX power
    By SuperYam in forum General Archive
    Replies: 1
    Last Post: 2015-09-13, 03:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •