Results 1 to 2 of 2

Thread: Set autosuspend=-1 for live usb boot

  1. #1
    Join Date
    2016-Aug
    Posts
    2

    Set autosuspend=-1 for live usb boot

    Hi guys,

    For the past week, i've been having issues with running kali on my asus ROG laptop. When trying to live boot (with or without persistency), it systematically fails around the "port power management may be unreliable" message. I've already posted about this issue in the thread concerning asus rog if you want more infos.

    Since i wanted to know if the problem was coming from my laptop or my usb stick, i tried plugging it into my old laptop -> it worked flawlessly on first try !!! Sadly this laptop is pretty old and half broken, so i'd still like to run kali ok my new one instead.
    So i thought, maybe now that i can access kali on my old laptop, i can modify it a bit so that it will work on my new one as well ? I'd like to set the autosuspend setting to -1, to disable the port power management, and hope that will help with booting on my asus rog.

    Sadly, i haven't found a way to set this, and keep it to -1 after a reboot. Everytime i reboot, it goes back to default value (2) and i fail to boot on my ROG. I'm not even sure if it would work with autosuspend on -1, but if someone can help me to set this at boot time, i could give it a try.

    Thanks for your time

  2. #2
    Join Date
    2015-Mar
    Posts
    48
    First try to add usbcore.autosuspend=-1 at the grub prompt and see if it works.

Similar Threads

  1. usbcore.autosuspend/no grub issue!
    By Gunshine in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-05-29, 18:57
  2. problem choosing the "Live (686-pae) boot from live USB....
    By d0zer1 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-04-17, 05:26

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •