About a week ago, I created a live, bootable Kali Linux USB drive. I did this by using the Mac Linux USB Loader’s “Create Live USB” function. My native OS is Mac OSX El Capitan, running on a mid-2015 Macbook Pro. The ISO image which I downloaded (64bit) was named kali-linux-2016.1-amd64.iso. Mac USB Loader created a bootable USB with a folder EFI (which has a sub-folder boot, which holds boot.efi, boot.iso, and bootX64.efi).

I successfully booted into Kali, running as root, but I noticed that my sessions weren’t being saved. I attempted to make my USB drive persistent by following several sets of instructions, including those from Kali’s website. Pasting those commands into the terminal gave me errors such as “<filename>: no such file or directory exists”. I was unable to make the partitions work.

Recently, I tried to use NullByte’s tutorial on making a persistent USB (search “Create (Bootable) Persistent Kali Linux USB With Ease). I booted into Kali and opened GParted. In the tutorial, the author said that he had two partitions, but I had three. They were as follows:

/dev/sda1 - fat32, labeled EFI, 200.00 MiB, 26.10 MiB used
/dev/sda2 - unknown, labeled Customer, 232.96 GiB, “—“ for used and remaining
/dev/sda3 - hfs+, labeled Recovery HD, 619.89 MiB, 536.39 used.

The move/resize operation was grayed out and not available for /dev/sda2.

I attempted to shrink /dev/sda1 from 200.00 MiB to 41MiB (41 was a fairly arbitrary number). I got another unallocated partition.
Then, I tried to create something on unallocated (by clicking “new”) which the system named “Primary Partition #1”, of type ext4 and size 159.00 MiB on “/dev/sda”. When I applied these operations (as per the tutorial), I got several error messages, saying that overlapping partitions would occur and that my OS might be compromised/not able to boot properly and that I should reboot before making further changes. I closed these, and it went to a screen saying that it was “applying pending operations” and that 0 out of 2 were complete. It stayed like this for a while, making no progress, and I eventually gave up.

I haven’t had any luck with other tutorials either. If anybody could tell me how to use GParted properly to resize the partition and then the terminal commands for making my USB persistent, I’d really appreciate it. I would prefer if it were encrypted.

Let me know if you need more system information/information about the error messages to answer this effectively. Thanks so much!