Results 1 to 10 of 10

Thread: Screen flickering after run apt-get upgrade and apt-get dist-upgrade

  1. #1
    Join Date

    Screen flickering after run apt-get upgrade and apt-get dist-upgrade

    Hi, I've got big problem with screen flickering after run upgrade commands. It's fresh installation Kali Linux 2.0 Rolling Edition on Dual Boot with Windows 10. It started a few weeks ago. I've tryed reinstall it today. Everything was fine after installation but after I run commands apt-get upgrade, apt-get dist-upgrade and then reboot, screen just start constantly flicker. It is really annoying me, I can't use it at all. I tryed search in internet forums but no answer. My laptop is only 2 years old, Toshiba satellite S70-b-10U. Windows 10 operating system, Graphic card AMD Radeon R9 M265X, 16 GB memory, Intel Core i7-4710HQ Processor (2.5 to 3.5 GHz with Turbo Boost). Bios is UEFI. I never had this problem before. I've got Kali Linux installed on my PC in Wmvare and no problem. But this is over my head now. Please if anybody can help...

  2. #2
    Join Date
    Are you able to do "apt-get update" and reboot with no issues? If so then we probably have the same problem. I'm still working on it. I've narrowed it down to apt-get dist-upgrade breaking only my persistent USB - VM works fine.

    Are you able to see anything in the logs for gnome?

  3. #3
    Join Date
    Yes I can reboot without issues after apt-get update. Thing is, everything is fine after installation, but after first time run apt-get update, get-upgrade, get dist-upgrade flickering start. I've got no problem on my PC in wmvare with upgrade and update commands, everything is fine, just in my Laptop on dual boot with win10.

    I'm new in Kali linux, I don't know how to get logs for gnome...

  4. #4
    Hi Peter/Kip_Hackman

    Been having issues that sound similar to what you two have seen, after upgrading from Kali Sana to Kali rolling:
    • System would boot as far as the login screen
    • Screen would become unresponsive and start flickering
    • Flickering would keep getting worse until the display became unreadable
    • Not able to access a console login via ctrl-alt-f1

    After much mucking about, re-installing (and sacrificing several goats), I managed to get things mainly sorted out.

    What worked for me:
    • Clean install of Kali rolling
    • Disconnect all cables from my card, so only 1 HDMI cable was going to one monitor
    • When the boot process reached the grub window, pressed e to edit the boot config, adding "radeon.modeset=0" to the end of the line containing "ro initrd=/install/initrd.gz quiet" and then pressed ctrl-x to resume booting. ("ro initrd=/install/initrd.gz quiet radeon.modeset=0")
    • This (as far as I understand things) disables dkms and uses the default graphics drives that ship with Kali rolling.
    • This enabled me to boot and login to the desktop successfully.
    • From there I added the correct repository for Kali rolling, ran apt-get update, apt-get upgrade and apt-get dist-upgrade and updated the kernel headers.
    • Rebooting after this, without adding "radeon,modeset=0" to the grub options, was not successful. Could boot if I added it, but that left me stuck on the default drivers.
    • Next I added "radeon.dpm=0" to the grub options, instead of "radeon,modeset=0". This resulted in a successful boot and login, and this time using correct (amdgpu?) drivers. DPM is dynamic power management and is used to control clock and voltage on the clock, see here for more details.
    • To add this option to the grub options permanently, edit GRUB_CMDLINE_LINUX_DEFAULT from ="quiet" in "/etc/default/grub" to ="quiet radeon.dpm=0" and run "update-grub"
    • After that things were working fine for me.
    • It might be possible to just add the radeon.dpm=0 instead of starting with radeon.modeset=0, but I haven't tested it, so I can't recommend it.

    Cause of the problem:
    • A large part seems to be the removal of the fglrx drivers from the Kali Rolling repositories.
    • In my case I had added the amd drives to Sana via this guide, but when I ran apt-get dist-upgrade it broke that install. (I may also have changed graphics card in between, don't really remember)
    • Also a lot of the details and tutorials available don't apply any more due to the changes in Kali rolling, and in the newer linux kernels.

    MSI Radeon R9 390

    Hope some of this helped, I tried a whole load of things before I got something that worked, so if this don't work for you, keep trying til it breaks and then start again.

    Posts and scripts from g0tmi1k and iojymbo were really helpful, so if either of them read this, just want to say thanks for sharing!


  5. #5
    Join Date
    Hi Tiger_skittles

    Well I tryed both your procedures but didn't work. But thanks I learned something new again. You are probably right, there is something wrong with repositories. I'm stucked at this point, I tryed numerous tutorials but none worked.

  6. #6
    Join Date
    Same problem here, but i cant login because of it. Cant enter my password right because of the flickering. Tried tigers tips above but unfortunately it didnt help. My card = ATI Mobility Radeon HD 4500 Series, after adding "radeon.modeset=0" I just got an error message and it started to flicker even more. Tried "modeset=0" and "radeon.dpm=0" got no errors but it didnt do anything, still struggling with it :/

  7. #7
    Join Date
    I ended up resolving this by installing the nvidia-settings, running it, and editing xorg.conf with the horiz and vert refresh values according to my monitor's specifications. Not sure why kali is the first distro I've encountered that was unable to sort that out on its own

  8. #8
    Join Date
    Guess I will have to reinstall kali and avoid upgrading in future, well until its safe to

  9. #9
    Join Date
    Hi, I didn't found solution to this trouble. I had to install Kali Linux dual boot on my PC with Nvidia graphic card. There is no screen flickering now. But my laptop had flickering with Ubuntu as well.

  10. #10
    i can not explain what the problem is or why this happens.. if you are interested in getting your system to boot again however, this is what worked for me...

    1. Shut Down System
    2. Restart System in (Advance Options for Kali)
    3. then pick (Recovery mode)
    4. will boot in to a terminal SSH like session..
    5. Enter Root Pass word when prompt.
    6. Once you have your "root@you:" type this code to reverse your previous update,upgrade,dist-upgrade

    @Code: apt-get clean && apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y

    This saved me from Fresh Install... got me back in GUI

Similar Threads

  1. Black screen after login after upgrade/dist-upgrade
    By pendragyn in forum TroubleShooting Archive
    Replies: 16
    Last Post: 2017-03-29, 10:13
  2. Kali 2016.2 messed up Desktop after after upgrade/dist-upgrade
    By SpectrE_Fth in forum TroubleShooting Archive
    Replies: 9
    Last Post: 2017-02-13, 10:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts