Results 1 to 19 of 19

Thread: apt-get cannot update after fresh install

  1. #1
    Join Date
    2016-Aug
    Posts
    3

    Exclamation apt-get cannot update after fresh install

    Hi,

    I've installed the Kali 2016.1 I downloaded today and went through the verification before installing. After the installation, I noticed that there were nothing except 2 commented lines (with keyword "cd-rom" at the front) in the
    Code:
    /etc/apt/sources.list
    file. Then, I added the following lines to the file:
    Code:
    deb http://http.kali.org/kali kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    # deb-src http://http.kali.org/kali kali-rolling main contrib non-free
    as stated in the general-use page. When I run:
    Code:
    apt-get update
    I keep getting the following error
    Code:
    E: Method http has died unexpectedly!
    E: sub-process http received a segmentation fault
    I'm pretty sure it is not an internet connection problem as I can access the internet through the browser. I tried to add the repository on another linux (ubuntu) machine and the update works fine. I'm not sure, but I suspect it has something to do with the "apt" package pre-installed. I couldn't access any network mirror while installing Kali, the return was "bad archive" no matter which mirror I choose. Could anyone tell me what I can do to fix this problem?

  2. #2
    Join Date
    2016-Aug
    Posts
    1
    same problem here -__-

  3. #3
    Join Date
    2016-Aug
    Posts
    1
    same problem... can anyone show me how to fix it ?

  4. #4
    I have the exact same problem flow as OP.

    Downloaded the ISO this morning, installed in VMware Workstation Pro.
    The install went mostly smoothly; however, it mentioned something about not being able to connect to the network mirrors and to check my connection, the bridged network seemed to be working as correctly, I ignored the message and proceeded.

    Please advise.

  5. #5
    Join Date
    2015-Jul
    Posts
    2
    Do you have an ip address (ifconfig)? Can you ping to outside IP addresses (ping 8.8.8.8)? Does name resolution work (ping google.com)?

    The mirrors are working just fine on this end.

  6. #6
    Join Date
    2016-Aug
    Posts
    1
    Quote Originally Posted by calmndo View Post
    same problem here -__-
    me too! i've had a clean and smooth installation and stuck at this stage for past 2 days. Any help will be truly appreciated

  7. #7
    Join Date
    2016-Aug
    Posts
    3
    Yes, I do. The internet is accessible, (by ping google.com).
    I'm sure the mirrors have no problem, as I can access them from my ubuntu machine.
    I suspect the problem lies in the "apt" pre-installed, as it is responsible for the network mirror setting in the installation process and "apt-get update", but I have no idea how to fix it. The "apt" used in Kali is of version 1.1.10, and that in Debian is 1.0.9.8.3 which uses different libraries (like libapt-4.12 ...). I tried to reinstall "apt", but I cannot find the "apt" used in Kali.

  8. #8
    Join Date
    2013-May
    Posts
    9
    apt and aptitude is just a front end for dkpg. Have you tried using dpkg to re-install the apt package?

    I've had a look on my box (which I last updated on Wednesday) and uname -a is returning: 4.6.0-kali1-amd64 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) x86_64 GNU/Linux

    The .deb apt packages I have installed are:

    apt_1.3~pre3_amd64.deb
    apt-utils_1.3~pre3_amd64.deb


    so you could try manually installing them using: $dpkg -i apt_1.3~pre3_amd64.deb

    To find out where your deb packages are all living, first run $updatedb then $locate *.deb

    Hope this helps
    Last edited by ScottishBen; 2016-08-19 at 13:43. Reason: Grammar

  9. #9
    Join Date
    2016-Aug
    Posts
    3
    Thanks ScottishBen, I just figured out how to do it

    I've finally got it working, the procedure is as follows:

    1. Go to apt's directory of Kali's repository directly using a browser. ( http://http.kali.org/pool/main/a/apt/ )

    2. Download libapt-pkg5.0_1.3~pre3_*.deb ( where * is your required architecture )

    3. Download apt_1.3~pre3_*.deb ( where * is your required architecture )

    4. Open a terminal, navigate to the directory of the downloaded files above

    5. Uninstall apt by apt-get remove apt, and record the packages to be removed

    6. Install libapt-pkg5.0_1.3~pre3 by dpkg -i libapt-pkg5.0_1.3~pre3_*.deb

    7. Install apt_1.3~pre3_*bby dpkg -i apt_1.3~pre3_*.deb

    8. Run apt-get update again, it should work by now.

    9. Install the packages removed in step 5.


  10. #10
    Join Date
    2013-May
    Posts
    9
    Learning was done, and there was much rejoicing

  11. #11
    Join Date
    2016-Aug
    Posts
    1
    Thanks buddy! I'm done. Your advice much appreciated.

  12. #12
    Join Date
    2016-Aug
    Posts
    1
    I had the same problem. My solution is to ignore what this site said (http://docs.kali.org/general-use/kal...t-repositories), and move on to this:
    deb http://ftp.hands.com/kali kali-rolling main contrib non-free

    I don't know what is Hands.com. As long as it works, then i'll take it :-)

    These solution didn't work for me:
    1. Reinstall apt, libapt
    2. Fresh install Kali Linux 2016
    3. Using Kali-Sana (it fixed the error, but I couldn't get any newer update)

  13. #13
    Join Date
    2013-May
    Posts
    9
    Quote Originally Posted by astacra View Post
    I had the same problem. My solution is to ignore what this site said (http://docs.kali.org/general-use/kal...t-repositories), and move on to this:
    deb http://ftp.hands.com/kali kali-rolling main contrib non-free

    I don't know what is Hands.com. As long as it works, then i'll take it :-)
    Glad it worked, and on the face of it hands.com seems legit (but not 100% sure), treating your update repos with a cavalier attitude could make you come unstuck.

  14. #14
    Join Date
    2016-Aug
    Posts
    1
    Apologies for resurrecting a week old thread on my first post here but thought I'd mention another solution which worked for me - seems my skills at deciphering ScottishBen's solution were sub-par.

    So....Or...

    1) Open Terminal
    2) leafpad /etc/apt/sources.list
    3) Make sure the following is in sources.list then save...
    deb http://repo.kali.org/kali kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    deb-src http://repo.kali.org/kali kali-rolling main contrib non-free
    4) Terminal: apt-get clean && apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y
    Last edited by OzWiz; 2016-08-29 at 01:30.

  15. #15
    Join Date
    2016-Jul
    Posts
    4
    In the kali-rolling, click Places on top left of the screen, Computer from drop down
    /etc/apt/sources.list

    make some change of the line to

    deb http://repo.kali.org/kali kali-rolling main non-free contrib

    deb-src http://repo.kali.org/kali kali-rolling main contrib non-free

    closed all folder and open terminal to type
    apt-get clean
    apt-get update
    apt-get dist-upgrade
    Last edited by Boontong72; 2016-08-26 at 23:03.

  16. #16
    Join Date
    2016-Aug
    Posts
    2
    THANK YOU SO MUCH!!!
    I've been working through every piece of information and tutorial i can find on this subject and nothing worked.
    This finally worked!

  17. #17
    Join Date
    2016-Aug
    Posts
    1
    I know if you try the command
    #apt-get clean
    it might help

  18. #18
    Join Date
    2016-Jan
    Posts
    12

    Exclamation Apt-get upgrade problem

    Hi, Sorry for crashing on this thread but I'm also experiencing issues while triying to upgrade since today, I followed all the steps mentioned and the issue persists:

    cat sources.list
    deb http://http.kali.org/kali kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    # deb-src http://http.kali.org/kali kali-rolling main contrib non-free


    apt-get update
    Hit:1 http://mirror2.hackingand.coffee/kali kali-rolling InRelease
    Reading package lists... Done



    apt-get upgrade

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
    libcurses-perl libcurses-ui-perl rcconf sysv-rc-conf
    Use 'apt autoremove' to remove them.
    The following packages will be upgraded:
    kali-desktop-common kali-desktop-gnome kali-desktop-live kali-linux kali-linux-full
    libabw-0.1-1 libclang-common-3.8-dev libglib2.0-0 libglib2.0-0:i386 libglib2.0-bin
    libglib2.0-data libglib2.0-dev libgnutls-openssl27 libgnutls30 libgnutls30:i386
    libgoffice-0.10-10 libgoffice-0.10-10-common libllvm3.8 libllvm3.8:i386 libpcre16-3 libpcre3
    libpcre3:i386 libpcre3-dev libpcre32-3 libpcrecpp0v5 libsodium18 python-faraday python-lxml
    python-pypdf2 python3-lxml ruby-oj
    31 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 46.2 MB of archives.
    After this operation, 1,261 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Err:1 http://http.kali.org/kali kali-rolling/main amd64 libpcre16-3 amd64 2:8.39-2
    404 Not Found
    Err:2 http://http.kali.org/kali kali-rolling/main amd64 libpcre32-3 amd64 2:8.39-2
    404 Not Found
    Err:3 http://http.kali.org/kali kali-rolling/main amd64 libpcrecpp0v5 amd64 2:8.39-2
    404 Not Found
    Err:4 http://http.kali.org/kali kali-rolling/main amd64 libpcre3-dev amd64 2:8.39-2
    404 Not Found
    Err:5 http://http.kali.org/kali kali-rolling/main i386 libpcre3 i386 2:8.39-2
    404 Not Found
    Err:6 http://http.kali.org/kali kali-rolling/main amd64 libpcre3 amd64 2:8.39-2
    404 Not Found
    Err:7 http://http.kali.org/kali kali-rolling/main amd64 libgnutls-openssl27 amd64 3.5.3-3
    404 Not Found
    Err:8 http://http.kali.org/kali kali-rolling/main i386 libgnutls30 i386 3.5.3-3
    404 Not Found
    Err:9 http://http.kali.org/kali kali-rolling/main amd64 libgnutls30 amd64 3.5.3-3
    404 Not Found
    Ign:10 http://http.kali.org/kali kali-rolling/main amd64 kali-desktop-common all 2016.2.12
    Ign:11 http://http.kali.org/kali kali-rolling/main amd64 kali-desktop-gnome all 2016.2.12
    Ign:12 http://http.kali.org/kali kali-rolling/main amd64 kali-desktop-live all 2016.2.12
    Err:13 http://http.kali.org/kali kali-rolling/main amd64 kali-linux amd64 2016.2.12
    404 Not Found
    Err:14 http://http.kali.org/kali kali-rolling/main amd64 python-faraday amd64 2.0.0-0kali3
    404 Not Found
    Err:15 http://http.kali.org/kali kali-rolling/main amd64 kali-linux-full amd64 2016.2.12
    404 Not Found
    Err:16 http://http.kali.org/kali kali-rolling/main amd64 libabw-0.1-1 amd64 0.1.1-3
    404 Not Found
    Err:17 http://http.kali.org/kali kali-rolling/main amd64 libclang-common-3.8-dev amd64 1:3.8.1-9
    404 Not Found
    Err:18 http://http.kali.org/kali kali-rolling/main i386 libllvm3.8 i386 1:3.8.1-9
    404 Not Found
    Err:19 http://http.kali.org/kali kali-rolling/main amd64 libllvm3.8 amd64 1:3.8.1-9
    404 Not Found
    Err:20 http://http.kali.org/kali kali-rolling/main amd64 libglib2.0-dev amd64 2.48.1-3
    404 Not Found
    Err:21 http://http.kali.org/kali kali-rolling/main amd64 libglib2.0-bin amd64 2.48.1-3
    404 Not Found
    Err:22 http://http.kali.org/kali kali-rolling/main i386 libglib2.0-0 i386 2.48.1-3
    404 Not Found
    Err:23 http://http.kali.org/kali kali-rolling/main amd64 libglib2.0-0 amd64 2.48.1-3
    404 Not Found
    Ign:24 http://http.kali.org/kali kali-rolling/main amd64 libglib2.0-data all 2.48.1-3
    Ign:25 http://http.kali.org/kali kali-rolling/main amd64 libgoffice-0.10-10-common all 0.10.32-1
    Err:26 http://http.kali.org/kali kali-rolling/main amd64 libgoffice-0.10-10 amd64 0.10.32-1
    404 Not Found
    Err:27 http://http.kali.org/kali kali-rolling/main amd64 libsodium18 amd64 1.0.11-1
    404 Not Found
    Err:28 http://http.kali.org/kali kali-rolling/main amd64 python-lxml amd64 3.6.4-1
    404 Not Found
    Ign:29 http://http.kali.org/kali kali-rolling/main amd64 python-pypdf2 all 1.26.0-1kali1
    Err:30 http://http.kali.org/kali kali-rolling/main amd64 python3-lxml amd64 3.6.4-1
    404 Not Found
    Err:31 http://http.kali.org/kali kali-rolling/main amd64 ruby-oj amd64 2.17.3-1
    404 Not Found
    Err:10 http://http.kali.org/kali kali-rolling/main i386 kali-desktop-common all 2016.2.12
    404 Not Found
    Err:11 http://http.kali.org/kali kali-rolling/main i386 kali-desktop-gnome all 2016.2.12
    404 Not Found
    Err:12 http://http.kali.org/kali kali-rolling/main i386 kali-desktop-live all 2016.2.12
    404 Not Found
    Err:24 http://http.kali.org/kali kali-rolling/main i386 libglib2.0-data all 2.48.1-3
    404 Not Found
    Err:25 http://http.kali.org/kali kali-rolling/main i386 libgoffice-0.10-10-common all 0.10.32-1
    404 Not Found
    Err:29 http://http.kali.org/kali kali-rolling/main i386 python-pypdf2 all 1.26.0-1kali1
    404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...39-2_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...39-2_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...39-2_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...39-2_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....39-2_i386.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...39-2_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....3-3_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...5.3-3_i386.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....3-3_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...6.2.12_all.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...6.2.12_all.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...6.2.12_all.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...2.12_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...ali3_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...2.12_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....1-3_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....1-9_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...8.1-9_i386.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....1-9_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....1-3_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....1-3_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...8.1-3_i386.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....1-3_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...48.1-3_all.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...0.32-1_all.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...32-1_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...11-1_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....4-1_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/...1kali1_all.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....4-1_amd64.deb 404 Not Found
    E: Failed to fetch http://http.kali.org/kali/pool/main/....3-1_amd64.deb 404 Not Found
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


    Any Ideas?

    Regards.

    Gn0m3

  19. #19
    Join Date
    2013-May
    Posts
    9
    So, first things first, can you visit http://http.kali.org/kali in the browser? What about clicking through the subdirs?

Similar Threads

  1. Can't install gnome-tweak tool on fresh kali install
    By Dave46 in forum General Archive
    Replies: 0
    Last Post: 2016-08-20, 19:57
  2. Can't login fresh install?
    By Jay1 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-10-10, 12:13
  3. Kali repos do not update on rpi2 fresh install
    By Grub in forum ARM Archive
    Replies: 3
    Last Post: 2015-08-04, 13:08
  4. Replies: 0
    Last Post: 2015-07-25, 08:28
  5. What To do after Fresh Install????
    By Savve in forum Installing Archive
    Replies: 2
    Last Post: 2014-11-24, 10:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •