Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Fixing 2 issues in VMWare on debian distribution (gcc error & Mon and Net don't work)

  1. #1
    Junior Member
    Join Date
    Aug 2016
    Posts
    2

    Post Fixing 2 issues in VMWare on debian distribution (gcc error & Mon and Net don't work)

    Hello community, this is my first post. In this post, I'll show you how to solve 2 problems in VMWare. I went over all the documents, read all the posts, and watched all the videos on the internet, and only a few of them were actually helpful. Therefore, I want to show you how I solve these problems.

    First, the common problem with gcc:
    VMware Kernel Module Updater (as superuser)_001.png

    This problem can occur if you have the newest version or an old version of gcc. To solve it, you'll have to follow these steps:

    First, you need to know which version of gcc you are actually using. For that, execute the next command::
    Terminal_003.jpg
    As you can see, I have the latest version: 6.1.1.1-1, but VMWare needs version 5.4.0. If you have a newer version like I do, you'll have to downgrade the gcc, otherwise you'll upgrade it to the 5.4.0 version.

    To upgrade, just run the next command:
    Code:
    sudo apt-get install gcc-5
    To downgrade, follow my steps (replace the "6" with your current version):
    Code:
    sudo apt-get remove gcc-6
    sudo apt-get remove --auto-remove gcc-6
    sudo apt-get purge gcc-6
    Then, install the gcc and g++ version needed:
    Code:
    sudo apt-get update
    sudo apt-get install g++-5
    sudo apt-get install gcc-5
    And just create a link to finish:
    Code:
    ln -s /usr/bin/gcc-5 /usr/bin/gcc
    ln -s /usr/bin/g++-5 /usr/bin/g++
    That's all. Simply run your VMWare and enjoy.

    Now if you have this problem:
    14012005_10153595979911784_1717133854_n.jpg
    That means you have a small incovenience with your VMNet and/or your VMMon. Don't you worry, these errors occur because the new kernel has new changes in C code and some sentences are different now.

    To solve it, just go to this location with cd command:
    Code:
    cd /usr/lib/vmware/modules/source
    Now untar vmmon.tar:
    Code:
    tar -xf vmmon.tar
    And edit the following file, replacing all "get_user_pages" to "get_user_pages_remote":
    Code:
    vi ./vmmon-only/linux/hostif.c
    Now you have to replace the original file with the edited one, but first you have to do a backup:
    Code:
    mv vmmon.tar vmmon.tar.bak
    tar -cf vmmon.tar vmmon-only
    Now you'll do the same thing in vmnet.tar, obviously editing a different file:

    untar vmnet.tar:
    Code:
    tar -xf vmnet.tar
    And edit the file. Remember to replace all "get_user_pages" with "get_user_pages_remote":
    Code:
    vi ./vmnet-only/userif.c
    Then backup and replace:
    Code:
    mv vmnet.tar vmnet.tar.bak
    tar -cf vmnet.tar vmnet-only
    And it's done. Now you have your VMWare ready to use:
    Home - VMware Workstation (as superuser)_005.jpg

    Thank you for taking the time to read this. Knowledge is free and you should document each issue you come across.

    "Very, very, very helpful links":
    http://askubuntu.com/questions/69064...n-ubuntu-15-10
    https://ubuntuforums.org/showthread.php?t=2284953

  2. #2
    Junior Member
    Join Date
    Aug 2016
    Posts
    1
    Thank you so much, i have been on this for months. Working

  3. #3
    Junior Member
    Join Date
    Aug 2016
    Posts
    1
    Hi, thanks for the info. I was able to get past the gcc part with your help, but now I'm getting an error during the VMware kernel module updater saying that I'm unable to start services

    ...
    2016-08-27T00:11:27.283-04:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2016-08-27T00:11:27.283-04:00| vthread-4| I125: Validating path "/lib/modules/4.6.0-kali1-amd64/build/include" for kernel release "4.6.0-kali1-amd64".
    2016-08-27T00:11:27.283-04:00| vthread-4| I125: Failed to find /lib/modules/4.6.0-kali1-amd64/build/include/linux/version.h
    2016-08-27T00:11:27.283-04:00| vthread-4| I125: /lib/modules/4.6.0-kali1-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2016-08-27T00:11:27.283-04:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2016-08-27T00:11:27.287-04:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.6.0-kali1-amd64".
    2016-08-27T00:11:27.287-04:00| vthread-4| I125: The header path "/lib/modules/4.6.0-kali1-amd64/build/include" for the kernel "4.6.0-kali1-amd64" is valid. Whoohoo!
    2016-08-27T00:11:27.288-04:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2016-08-27T00:11:27.288-04:00| vthread-4| I125: Validating path "/lib/modules/4.6.0-kali1-amd64/build/include" for kernel release "4.6.0-kali1-amd64".
    2016-08-27T00:11:27.288-04:00| vthread-4| I125: Failed to find /lib/modules/4.6.0-kali1-amd64/build/include/linux/version.h
    2016-08-27T00:11:27.288-04:00| vthread-4| I125: /lib/modules/4.6.0-kali1-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2016-08-27T00:11:27.288-04:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2016-08-27T00:11:27.293-04:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.6.0-kali1-amd64".
    2016-08-27T00:11:27.293-04:00| vthread-4| I125: The header path "/lib/modules/4.6.0-kali1-amd64/build/include" for the kernel "4.6.0-kali1-amd64" is valid. Whoohoo!
    2016-08-27T00:11:27.294-04:00| vthread-4| I125: Using temp dir "/tmp".
    2016-08-27T00:11:27.294-04:00| vthread-4| I125: Obtaining info using the running kernel.
    2016-08-27T00:11:27.294-04:00| vthread-4| I125: Setting header path for 4.6.0-kali1-amd64 to "/lib/modules/4.6.0-kali1-amd64/build/include".
    2016-08-27T00:11:27.294-04:00| vthread-4| I125: Validating path "/lib/modules/4.6.0-kali1-amd64/build/include" for kernel release "4.6.0-kali1-amd64".
    2016-08-27T00:11:27.294-04:00| vthread-4| I125: Failed to find /lib/modules/4.6.0-kali1-amd64/build/include/linux/version.h
    2016-08-27T00:11:27.294-04:00| vthread-4| I125: /lib/modules/4.6.0-kali1-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2016-08-27T00:11:27.294-04:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2016-08-27T00:11:27.300-04:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.6.0-kali1-amd64".
    2016-08-27T00:11:27.300-04:00| vthread-4| I125: The header path "/lib/modules/4.6.0-kali1-amd64/build/include" for the kernel "4.6.0-kali1-amd64" is valid. Whoohoo!
    2016-08-27T00:11:27.428-04:00| vthread-4| I125: found symbol version file /lib/modules/4.6.0-kali1-amd64/build/Module.symvers
    2016-08-27T00:11:27.428-04:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.6.0-kali1-amd64/build/Module.symvers.
    2016-08-27T00:11:27.445-04:00| vthread-4| I125: Read 18158 symbol versions
    2016-08-27T00:11:27.445-04:00| vthread-4| I125: Invoking modinfo on "vmmon".
    2016-08-27T00:11:27.447-04:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-08-27T00:11:27.447-04:00| vthread-4| I125: Invoking modinfo on "vmnet".
    2016-08-27T00:11:27.448-04:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-08-27T00:11:27.726-04:00| vthread-4| I125: Setting destination path for vmmon to "/lib/modules/4.6.0-kali1-amd64/misc/vmmon.ko".
    2016-08-27T00:11:27.726-04:00| vthread-4| I125: Extracting the vmmon source from "/usr/lib/vmware/modules/source/vmmon.tar".
    2016-08-27T00:11:27.732-04:00| vthread-4| I125: Successfully extracted the vmmon source.
    2016-08-27T00:11:27.732-04:00| vthread-4| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-awpmQj/vmmon-only auto-build HEADER_DIR=/lib/modules/4.6.0-kali1-amd64/build/include CC=/usr/bin/gcc IS_GCC_3=no"
    2016-08-27T00:11:29.358-04:00| vthread-4| W115: Failed to build vmmon. Failed to execute the build command.
    2016-08-27T00:11:29.359-04:00| vthread-4| I125: Setting destination path for vmnet to "/lib/modules/4.6.0-kali1-amd64/misc/vmnet.ko".
    2016-08-27T00:11:29.359-04:00| vthread-4| I125: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
    2016-08-27T00:11:29.365-04:00| vthread-4| I125: Successfully extracted the vmnet source.
    2016-08-27T00:11:29.365-04:00| vthread-4| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-awpmQj/vmnet-only auto-build HEADER_DIR=/lib/modules/4.6.0-kali1-amd64/build/include CC=/usr/bin/gcc IS_GCC_3=no"
    2016-08-27T00:11:30.770-04:00| vthread-4| W115: Failed to build vmnet. Failed to execute the build command.

  4. #4
    Junior Member
    Join Date
    Nov 2014
    Posts
    5
    Thanks for providing such a usefull info but i have a problem, Using kali 2016.2 and also drivers such as optimus, bumblebee etc that all uses gcc 6 therefore if i delete them ill have trouble using my gui Im trying to come up with a workaround without purge of gcc6. Any ideas ?

  5. #5
    Junior Member
    Join Date
    Sep 2016
    Posts
    1
    so i removed the gcc 6 but when i tried to install version 5 with this code:
    sudo apt-get update
    sudo apt-get install g++-5
    sudo apt-get install gcc-5

    i get the following error:"unable to locate package g++-5
    couldn't find any package by regex 'g++-5'"

    and
    "unable to locate package gcc-5"

    any solution to this?? i am new to linux so i just try to find my way around... thanks

  6. #6
    Junior Member
    Join Date
    Aug 2016
    Posts
    2

    Facing the same problem.

    hi, I follow every step. It worked on kali (uname -r 4.6.0,) but last day I updated my machine (uname -r 4.7.0 ) it's not working anymore. Giving same error as 'deweichen'


    2016-10-08T14:50:35.292+05:30| vthread-4| I125: Using user supplied compiler "/usr/bin/gcc-5".
    2016-10-08T14:50:35.295+05:30| vthread-4| I125: Got gcc version "5.4.1".
    2016-10-08T14:50:35.295+05:30| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: Validating path "/lib/modules/4.7.0-kali1-amd64/build/include" for kernel release "4.7.0-kali1-amd64".
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: Failed to find /lib/modules/4.7.0-kali1-amd64/build/include/linux/version.h
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: /lib/modules/4.7.0-kali1-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2016-10-08T14:50:36.599+05:30| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.7.0-kali1-amd64".
    2016-10-08T14:50:36.599+05:30| vthread-4| I125: The header path "/lib/modules/4.7.0-kali1-amd64/build/include" for the kernel "4.7.0-kali1-amd64" is valid. Whoohoo!
    2016-10-08T14:50:36.599+05:30| vthread-4| I125: Using temp dir "/tmp".
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: Obtaining info using the running kernel.
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: Setting header path for 4.7.0-kali1-amd64 to "/lib/modules/4.7.0-kali1-amd64/build/include".
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: Validating path "/lib/modules/4.7.0-kali1-amd64/build/include" for kernel release "4.7.0-kali1-amd64".
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: Failed to find /lib/modules/4.7.0-kali1-amd64/build/include/linux/version.h
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: /lib/modules/4.7.0-kali1-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2016-10-08T14:50:36.605+05:30| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.7.0-kali1-amd64".
    2016-10-08T14:50:36.605+05:30| vthread-4| I125: The header path "/lib/modules/4.7.0-kali1-amd64/build/include" for the kernel "4.7.0-kali1-amd64" is valid. Whoohoo!
    2016-10-08T14:50:36.720+05:30| vthread-4| I125: found symbol version file /lib/modules/4.7.0-kali1-amd64/build/Module.symvers
    2016-10-08T14:50:36.720+05:30| vthread-4| I125: Reading symbol versions from /lib/modules/4.7.0-kali1-amd64/build/Module.symvers.
    2016-10-08T14:50:36.737+05:30| vthread-4| I125: Read 18321 symbol versions
    2016-10-08T14:50:36.737+05:30| vthread-4| I125: Invoking modinfo on "vmmon".
    2016-10-08T14:50:36.739+05:30| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-08T14:50:36.739+05:30| vthread-4| I125: Invoking modinfo on "vmnet".
    2016-10-08T14:50:36.741+05:30| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-08T14:50:37.065+05:30| vthread-4| I125: Setting destination path for vmmon to "/lib/modules/4.7.0-kali1-amd64/misc/vmmon.ko".
    2016-10-08T14:50:37.065+05:30| vthread-4| I125: Extracting the vmmon source from "/usr/lib/vmware/modules/source/vmmon.tar".
    2016-10-08T14:50:37.071+05:30| vthread-4| I125: Successfully extracted the vmmon source.
    2016-10-08T14:50:37.072+05:30| vthread-4| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-mtDGeT/vmmon-only auto-build HEADER_DIR=/lib/modules/4.7.0-kali1-amd64/build/include CC=/usr/bin/gcc-5 IS_GCC_3=no"
    2016-10-08T14:50:39.157+05:30| vthread-4| I125: Successfully built vmmon. Module is currently at "/tmp/modconfig-mtDGeT/vmmon.o".
    2016-10-08T14:50:39.157+05:30| vthread-4| I125: Found the vmmon symvers file at "/tmp/modconfig-mtDGeT/vmmon-only/Module.symvers".
    2016-10-08T14:50:39.157+05:30| vthread-4| I125: Installing vmmon from /tmp/modconfig-mtDGeT/vmmon.o to /lib/modules/4.7.0-kali1-amd64/misc/vmmon.ko.
    2016-10-08T14:50:39.158+05:30| vthread-4| I125: Registering file "/lib/modules/4.7.0-kali1-amd64/misc/vmmon.ko".
    2016-10-08T14:50:39.467+05:30| vthread-4| I125: "/usr/lib/vmware-installer/2.1.0/vmware-installer" exited with status 0.
    2016-10-08T14:50:39.467+05:30| vthread-4| I125: Registering file "/usr/lib/vmware/symvers/vmmon-4.7.0-kali1-amd64".
    2016-10-08T14:50:39.756+05:30| vthread-4| I125: "/usr/lib/vmware-installer/2.1.0/vmware-installer" exited with status 0.
    2016-10-08T14:50:39.758+05:30| vthread-4| I125: Setting destination path for vmnet to "/lib/modules/4.7.0-kali1-amd64/misc/vmnet.ko".
    2016-10-08T14:50:39.758+05:30| vthread-4| I125: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
    2016-10-08T14:50:39.762+05:30| vthread-4| I125: Successfully extracted the vmnet source.
    2016-10-08T14:50:39.762+05:30| vthread-4| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-mtDGeT/vmnet-only auto-build HEADER_DIR=/lib/modules/4.7.0-kali1-amd64/build/include CC=/usr/bin/gcc-5 IS_GCC_3=no"
    2016-10-08T14:50:41.045+05:30| vthread-4| W115: Failed to build vmnet. Failed to execute the build command.

  7. #7
    Junior Member
    Join Date
    Aug 2016
    Posts
    2
    Hi everyone, My problem solved by simple updating workstation 12.1 to workstation 12.5.


    Quote Originally Posted by n00b_ View Post
    hi, I follow every step. It worked on kali (uname -r 4.6.0,) but last day I updated my machine (uname -r 4.7.0 ) it's not working anymore. Giving same error as 'deweichen'


    2016-10-08T14:50:35.292+05:30| vthread-4| I125: Using user supplied compiler "/usr/bin/gcc-5".
    2016-10-08T14:50:35.295+05:30| vthread-4| I125: Got gcc version "5.4.1".
    2016-10-08T14:50:35.295+05:30| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: Validating path "/lib/modules/4.7.0-kali1-amd64/build/include" for kernel release "4.7.0-kali1-amd64".
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: Failed to find /lib/modules/4.7.0-kali1-amd64/build/include/linux/version.h
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: /lib/modules/4.7.0-kali1-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2016-10-08T14:50:36.594+05:30| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2016-10-08T14:50:36.599+05:30| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.7.0-kali1-amd64".
    2016-10-08T14:50:36.599+05:30| vthread-4| I125: The header path "/lib/modules/4.7.0-kali1-amd64/build/include" for the kernel "4.7.0-kali1-amd64" is valid. Whoohoo!
    2016-10-08T14:50:36.599+05:30| vthread-4| I125: Using temp dir "/tmp".
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: Obtaining info using the running kernel.
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: Setting header path for 4.7.0-kali1-amd64 to "/lib/modules/4.7.0-kali1-amd64/build/include".
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: Validating path "/lib/modules/4.7.0-kali1-amd64/build/include" for kernel release "4.7.0-kali1-amd64".
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: Failed to find /lib/modules/4.7.0-kali1-amd64/build/include/linux/version.h
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: /lib/modules/4.7.0-kali1-amd64/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    2016-10-08T14:50:36.600+05:30| vthread-4| I125: using /usr/bin/gcc for preprocess check
    2016-10-08T14:50:36.605+05:30| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.7.0-kali1-amd64".
    2016-10-08T14:50:36.605+05:30| vthread-4| I125: The header path "/lib/modules/4.7.0-kali1-amd64/build/include" for the kernel "4.7.0-kali1-amd64" is valid. Whoohoo!
    2016-10-08T14:50:36.720+05:30| vthread-4| I125: found symbol version file /lib/modules/4.7.0-kali1-amd64/build/Module.symvers
    2016-10-08T14:50:36.720+05:30| vthread-4| I125: Reading symbol versions from /lib/modules/4.7.0-kali1-amd64/build/Module.symvers.
    2016-10-08T14:50:36.737+05:30| vthread-4| I125: Read 18321 symbol versions
    2016-10-08T14:50:36.737+05:30| vthread-4| I125: Invoking modinfo on "vmmon".
    2016-10-08T14:50:36.739+05:30| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-08T14:50:36.739+05:30| vthread-4| I125: Invoking modinfo on "vmnet".
    2016-10-08T14:50:36.741+05:30| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-08T14:50:37.065+05:30| vthread-4| I125: Setting destination path for vmmon to "/lib/modules/4.7.0-kali1-amd64/misc/vmmon.ko".
    2016-10-08T14:50:37.065+05:30| vthread-4| I125: Extracting the vmmon source from "/usr/lib/vmware/modules/source/vmmon.tar".
    2016-10-08T14:50:37.071+05:30| vthread-4| I125: Successfully extracted the vmmon source.
    2016-10-08T14:50:37.072+05:30| vthread-4| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-mtDGeT/vmmon-only auto-build HEADER_DIR=/lib/modules/4.7.0-kali1-amd64/build/include CC=/usr/bin/gcc-5 IS_GCC_3=no"
    2016-10-08T14:50:39.157+05:30| vthread-4| I125: Successfully built vmmon. Module is currently at "/tmp/modconfig-mtDGeT/vmmon.o".
    2016-10-08T14:50:39.157+05:30| vthread-4| I125: Found the vmmon symvers file at "/tmp/modconfig-mtDGeT/vmmon-only/Module.symvers".
    2016-10-08T14:50:39.157+05:30| vthread-4| I125: Installing vmmon from /tmp/modconfig-mtDGeT/vmmon.o to /lib/modules/4.7.0-kali1-amd64/misc/vmmon.ko.
    2016-10-08T14:50:39.158+05:30| vthread-4| I125: Registering file "/lib/modules/4.7.0-kali1-amd64/misc/vmmon.ko".
    2016-10-08T14:50:39.467+05:30| vthread-4| I125: "/usr/lib/vmware-installer/2.1.0/vmware-installer" exited with status 0.
    2016-10-08T14:50:39.467+05:30| vthread-4| I125: Registering file "/usr/lib/vmware/symvers/vmmon-4.7.0-kali1-amd64".
    2016-10-08T14:50:39.756+05:30| vthread-4| I125: "/usr/lib/vmware-installer/2.1.0/vmware-installer" exited with status 0.
    2016-10-08T14:50:39.758+05:30| vthread-4| I125: Setting destination path for vmnet to "/lib/modules/4.7.0-kali1-amd64/misc/vmnet.ko".
    2016-10-08T14:50:39.758+05:30| vthread-4| I125: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
    2016-10-08T14:50:39.762+05:30| vthread-4| I125: Successfully extracted the vmnet source.
    2016-10-08T14:50:39.762+05:30| vthread-4| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-mtDGeT/vmnet-only auto-build HEADER_DIR=/lib/modules/4.7.0-kali1-amd64/build/include CC=/usr/bin/gcc-5 IS_GCC_3=no"
    2016-10-08T14:50:41.045+05:30| vthread-4| W115: Failed to build vmnet. Failed to execute the build command.

  8. #8
    Junior Member
    Join Date
    Aug 2016
    Posts
    2
    Just upgrade your vmware.

    Are you sure that you have kali repositories in your source.list?

    Thanks to you.
    Last edited by maiki; 2016-10-18 at 10:50 AM. Reason: Merge posts

  9. #9
    Junior Member
    Join Date
    Oct 2016
    Posts
    1
    Quote Originally Posted by alexiacob View Post
    so i removed the gcc 6 but when i tried to install version 5 with this code:
    sudo apt-get update
    sudo apt-get install g++-5
    sudo apt-get install gcc-5

    i get the following error:"unable to locate package g++-5
    couldn't find any package by regex 'g++-5'"

    and
    "unable to locate package gcc-5"

    any solution to this?? i am new to linux so i just try to find my way around... thanks

    Hi alexiacob, I solved the problem after remove GCC-6 you need to add kali-dev to /etc/apt/sources.list

    cat > dev.sh << "EOF"
    echo "deb http://http.kali.org/kali kali-dev main contrib non-free" >> /etc/apt/sources.list
    echo "deb-src http://http.kali.org/kali kali-dev main contrib non-free" /etc/apt/sources.list
    apt-get update
    apt-get install g++-5 gcc-5
    ln -s /usr/bin/gcc-5 /usr/bin/gcc
    ln -s /usr/bin/g++-5 /usr/bin/g++
    EOF



    bash dev.sh
    vmware

    NOTE: remove kali-dev repositories after finish from /etc/apt/sources.list then run apt-get update .. enjoy

  10. #10
    Member
    Join Date
    Jul 2013
    Posts
    33
    In my experience, version 12.1.1 needed Get_User_Pages_Remote. In 12.5 this was no longer needed. I didn't have to downgrade gcc, I did the following:

    # VMware Bullshit
    DOWNDIR=$HOME/Downloads
    mkdir -p /lib/modules/`uname -r`/misc/

    # Download VMware Workstation, cd to that directory and extract everything
    cd $DOWNDIR
    chmod +x VMware-*
    sh VMware-* --console -x vmwarefix
    cd $DOWNDIR/vmwarefix/vmware-vmx/lib/modules/source/
    tar xf $DOWNDIR/vmwarefix/vmware-vmx/lib/modules/source/vmmon.tar
    tar xf $DOWNDIR/vmwarefix/vmware-vmx/lib/modules/source/vmnet.tar
    # Get_User_Pages_Remote no longer needed
    # sed -i s/get_user_pages/get_user_pages_remote/g $DOWNDIR/vmwarefix/vmware-vmx/lib/modules/source/vmmon-only/linux/hostif.c
    cd $DOWNDIR/vmwarefix/vmware-vmx/lib/modules/source/vmmon-only/ && make
    cp $DOWNDIR/vmwarefix/vmware-vmx/lib/modules/source/vmmon-only/vmmon.ko /lib/modules/`uname -r`/misc/
    # Get_User_Pages_Remote no longer needed
    # sed -i s/get_user_pages/get_user_pages_remote/g $DOWNDIR/vmwarefix/vmware-vmx/lib/modules/source/vmnet-only/userif.c
    cd $DOWNDIR/vmwarefix/vmware-vmx/lib/modules/source/vmnet-only/ && make
    cp $DOWNDIR/vmwarefix/vmware-vmx/lib/modules/source/vmnet-only/vmnet.ko /lib/modules/`uname -r`/misc/
    depmod -a
    /etc/init.d/vmware restart
    cd $DOWNDIR
    rm -rf vmwarefix

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •