Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Fixing 2 issues in VMWare on debian distribution (gcc error & Mon and Net don't work)

  1. #11
    Junior Member
    Join Date
    Nov 2016
    Posts
    1
    Thx buddy for sharing this

  2. #12
    Junior Member
    Join Date
    Nov 2016
    Posts
    1
    Thanks a lot i've been struggling this issue for awhile. Now is fixed.

  3. #13
    Junior Member
    Join Date
    Feb 2016
    Posts
    3
    I'm having this problem...any ideas? Screenshot_20170122_103810.jpg

    Ok so I fixed my previous problem (Im not sure when it will be printed by following these steps.
    $rm /usr/bin/gcc
    $rm /usr/bin/g++

    and then after I've already installed as jrondon described I used
    $ln -s /usr/bin/gcc-5 /usr/bin/gcc
    $ln -s /usr/bin/g++-5 /usr/bin/g++

    so basically i think I just changed the links to the gcc. Hope that helps
    Last edited by sickn3ss; 2017-01-22 at 10:08 AM.

  4. #14

    Unhappy Removed gcc 6 compiler But lost all other applications

    I wanted to install vmware workstation on my kali ROLLING .
    1. Issue with kernel header ( Fixed it using update & upgrade the kali repository )
    2. Issue with gcc compiler ( Fixed it using your solution , removed gcc 6 and installed gcc 5.4 )

    BUT now i have lost all my applications .
    please suggest some way to get back all my applications






    Quote Originally Posted by jrondon View Post
    Hello community, this is my first post. In this post, I'll show you how to solve 2 problems in VMWare. I went over all the documents, read all the posts, and watched all the videos on the internet, and only a few of them were actually helpful. Therefore, I want to show you how I solve these problems.

    First, the common problem with gcc:
    Attachment 1768

    This problem can occur if you have the newest version or an old version of gcc. To solve it, you'll have to follow these steps:

    First, you need to know which version of gcc you are actually using. For that, execute the next command::
    Attachment 1769
    As you can see, I have the latest version: 6.1.1.1-1, but VMWare needs version 5.4.0. If you have a newer version like I do, you'll have to downgrade the gcc, otherwise you'll upgrade it to the 5.4.0 version.

    To upgrade, just run the next command:
    Code:
    sudo apt-get install gcc-5
    To downgrade, follow my steps (replace the "6" with your current version):
    Code:
    sudo apt-get remove gcc-6
    sudo apt-get remove --auto-remove gcc-6
    sudo apt-get purge gcc-6
    Then, install the gcc and g++ version needed:
    Code:
    sudo apt-get update
    sudo apt-get install g++-5
    sudo apt-get install gcc-5
    And just create a link to finish:
    Code:
    ln -s /usr/bin/gcc-5 /usr/bin/gcc
    ln -s /usr/bin/g++-5 /usr/bin/g++
    That's all. Simply run your VMWare and enjoy.

    Now if you have this problem:
    Attachment 1771
    That means you have a small incovenience with your VMNet and/or your VMMon. Don't you worry, these errors occur because the new kernel has new changes in C code and some sentences are different now.

    To solve it, just go to this location with cd command:
    Code:
    cd /usr/lib/vmware/modules/source
    Now untar vmmon.tar:
    Code:
    tar -xf vmmon.tar
    And edit the following file, replacing all "get_user_pages" to "get_user_pages_remote":
    Code:
    vi ./vmmon-only/linux/hostif.c
    Now you have to replace the original file with the edited one, but first you have to do a backup:
    Code:
    mv vmmon.tar vmmon.tar.bak
    tar -cf vmmon.tar vmmon-only
    Now you'll do the same thing in vmnet.tar, obviously editing a different file:

    untar vmnet.tar:
    Code:
    tar -xf vmnet.tar
    And edit the file. Remember to replace all "get_user_pages" with "get_user_pages_remote":
    Code:
    vi ./vmnet-only/userif.c
    Then backup and replace:
    Code:
    mv vmnet.tar vmnet.tar.bak
    tar -cf vmnet.tar vmnet-only
    And it's done. Now you have your VMWare ready to use:
    Attachment 1770

    Thank you for taking the time to read this. Knowledge is free and you should document each issue you come across.

    "Very, very, very helpful links":
    http://askubuntu.com/questions/69064...n-ubuntu-15-10
    https://ubuntuforums.org/showthread.php?t=2284953

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •