Results 1 to 3 of 3

Thread: Answer to the Question? my device reads my external wifi card, but i have no power?

  1. #1
    Junior Member
    Join Date
    Aug 2016
    Posts
    9

    Answer to the Question? my device reads my external wifi card, but i have no power?

    ifconfig wlan1 up

    As in, (wlan1) is the name of your external wifi card attached to your device with the OTG cable.
    yours maybe listed as something else.
    Made post as so many seem to list same problem/issue.

  2. #2
    Junior Member
    Join Date
    Aug 2013
    Posts
    10
    Have the same issue, I solve it by manually setting txpower for wlan1:
    iwconfig wlan1 txpower 20

  3. #3
    Junior Member
    Join Date
    Aug 2016
    Posts
    9
    You guys, I think I figured out how to get around this issue using a Nexus 7. This way, you can use a regular OTG cable (not a Y-cable or even a hub). But you need to mess with the wake-lock settings on whatever android device you have.

    So after googling a ton of forum posts, from here, all the way to xda developers, I realized that at least for my wireless adapter, a TP-Link TL-WN722N, is having trouble getting the wireless card up and running.

    I verified that the wireless card is indeed detected, by typing "lsusb". I also verified the power management issue (because the Android version is Lollipop), by typing "dmesg" and reading it. Seems that the PowerManager service in the background is repeatedly cutting power to the OTG-connected adapter and not letting it start. Which is why it periodically shows up and disappears from "lsusb".

    What you want to do is download this freebie app from the Play Store called "Wake Lock", it has a light bulb icon. https://play.google.com/store/apps/d...arken.wl&hl=en
    Start up Wake Lock, and select the option on the bottom of the menu "FULL_WAKE_LOCK". That way it won't interfere with any of the power settings.

    Now, open a terminal, or make a custom command in the nethunter icon.

    Either you can manually type "airmon-ng start wlan1" or just write a custom command to make it work. The wifi adapter SHOULD light up! Now you should be able to use "wifite" or anything you want.

    If it doesn't work, or "lsusb" doesn't list anything, you can diagnose the issue with two other apps. "Root Checker Basic" to make sure you properly rooted your phone, and "USB Host Diagnostics" to make sure that USB Host mode is enabled. First try plugging in a thumb drive into the OTG connector to make sure that some of the things are working. For some reason, the "Root API Checklist" is always "N/A", but I don't need to see the results on that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •