Results 1 to 4 of 4

Thread: Issues running Xrdp on Raspberry Pi

  1. #1
    Join Date
    2016-Aug
    Posts
    3

    Issues running Xrdp on Raspberry Pi

    Hello,

    I'm having an issue with running xrdp on my raspberry pi3. I have performed the following steps.

    apt-get update && apt-get upgrade
    apt-get dist-upgrade
    apt-get install xrdp

    No issues so far.

    I can get xrdp with service xrdp start. Once logging in with remote desktop on a windows 7 machine, I end up at the login page. See Below.

    Each of the session settings, leads me to the same result, the login just locks up. Sometimes this allows me to try logging in again, with no luck.

    Some additional info:

    Using default login info

    I can also SSH in no problem.

    I have gotten xrdp to run no problem with ubuntu-mate and lubuntu. With Xubuntu I am seeing the same issue as Kali

    I have also swapped desktops from Xfce4 to Lxde and have gotten the same results.

    Any thoughts? or suggestions?

    Also I should note I am running Kali 2.1.2 for the Pi

    Xrdp.jpgXrdp.jpg
    Last edited by maiki; 2016-08-25 at 09:40. Reason: Merge posts

  2. #2
    Join Date
    2016-Aug
    Posts
    3
    Got it...

    Looks like I had a bad install of Lxde.... tired this again and logging in from windows 7 with no issues.

    Here is what I found for anyone else that would like help...This is everything that I did to get this working. Please chime in if there is a better method? Or if I have opened more services/ports that I should have?

    Also if anyone can give me some guidance on how to get XRDP to work with xfce4 that would be great. It is my understanding that Kali was designed to work in the Xfce4 environment and other desktops are not recommended. I was able to get Xrdp to work once using xfce4 by messing with the following files; startwm.sh, xrdp.ini, and sesman.ini. With in these files, I removed all of the testing and security protocols,I based my configuration off of the same files on a ubuntu distro. I also set all of the bpp settings from 32 to 16. This resulted in one successful login using xvnc session manager on RDP but quickly locked up and would not connect again.

    Just a bit on the background of this project for me...

    I am using my Pi 3 and Kali to test/diagnose wired and wireless networks that I deploy. This is more for speed, reliability, and to ensure wireless coverage is optimal.The purpose of RDP for me is GUI access for programs like WireShark, when needed. For most part I am booting the Pi and letting it run iperf to perform unbiased speed tests of the network which does not require a login.

    What I did:
    During the first boot...
    Change SSH Keys, change root password.
    apt-get update && apt-get upgrade
    apt-get dist-upgrade
    apt-get install -f
    apt-get kali-linux-full (optional)
    apt-get clear
    reboot

    apt-get remove xfce4 && apt-get autoremove
    apt-get isntall -f (to ensure I did not break anything)
    apt-get install lxde-core lxde kali-defaults kali-root-login desktop-base
    apt-get install xrdp

    To start xrdp
    Kali 2.1.2 seems to disable everything requiring a network service. Running service xrdp start does indeed start xrdp but this leads to a grey screen and RDP lock up. Session manager needs to be running as well for xrdp to work. I have not seen anyone mention this.

    service xrdp-sesman start
    service xrdp start

    Start windows remote desktop
    credentials is root and always ask
    connect

    select either sesman-xorgxrdp or session manager either or will work
    user: root
    password : toor or your own if changed
    Ok

    This should get you to your desktop.

    To enable on boot:
    Since Kali blocks xrdp you will need to update the rc.d directory.. I am assuming the commands below will work. Since this is not a requirement for me I am fine connecting via SSH and starting xrdp if needed. I may try this at one point and will update if it works or the steps needed to start at boot.

    update-rc.d xrdp enable
    update-rc.d xrdp-sesman enable

    Hope this helps someone else...
    Mjdx88

  3. #3
    Join Date
    2016-Sep
    Posts
    1
    Quote Originally Posted by mjdx88 View Post
    Got it...

    Looks like I had a bad install of Lxde.... tired this again and logging in from windows 7 with no issues.

    Here is what I found for anyone else that would like help...This is everything that I did to get this working. Please chime in if there is a better method? Or if I have opened more services/ports that I should have?

    Also if anyone can give me some guidance on how to get XRDP to work with xfce4 that would be great. It is my understanding that Kali was designed to work in the Xfce4 environment and other desktops are not recommended. I was able to get Xrdp to work once using xfce4 by messing with the following files; startwm.sh, xrdp.ini, and sesman.ini. With in these files, I removed all of the testing and security protocols,I based my configuration off of the same files on a ubuntu distro. I also set all of the bpp settings from 32 to 16. This resulted in one successful login using xvnc session manager on RDP but quickly locked up and would not connect again.

    Just a bit on the background of this project for me...

    I am using my Pi 3 and Kali to test/diagnose wired and wireless networks that I deploy. This is more for speed, reliability, and to ensure wireless coverage is optimal.The purpose of RDP for me is GUI access for programs like WireShark, when needed. For most part I am booting the Pi and letting it run iperf to perform unbiased speed tests of the network which does not require a login.

    What I did:
    During the first boot...
    Change SSH Keys, change root password.
    apt-get update && apt-get upgrade
    apt-get dist-upgrade
    apt-get install -f
    apt-get kali-linux-full (optional)
    apt-get clear
    reboot

    apt-get remove xfce4 && apt-get autoremove
    apt-get isntall -f (to ensure I did not break anything)
    apt-get install lxde-core lxde kali-defaults kali-root-login desktop-base
    apt-get install xrdp

    To start xrdp
    Kali 2.1.2 seems to disable everything requiring a network service. Running service xrdp start does indeed start xrdp but this leads to a grey screen and RDP lock up. Session manager needs to be running as well for xrdp to work. I have not seen anyone mention this.

    service xrdp-sesman start
    service xrdp start

    Start windows remote desktop
    credentials is root and always ask
    connect

    select either sesman-xorgxrdp or session manager either or will work
    user: root
    password : toor or your own if changed
    Ok

    This should get you to your desktop.

    To enable on boot:
    Since Kali blocks xrdp you will need to update the rc.d directory.. I am assuming the commands below will work. Since this is not a requirement for me I am fine connecting via SSH and starting xrdp if needed. I may try this at one point and will update if it works or the steps needed to start at boot.

    update-rc.d xrdp enable
    update-rc.d xrdp-sesman enable

    Hope this helps someone else...
    Mjdx88

    i have exact the same problem on my raspberry pi 2 with the newest kali linux (all up to date)
    If i now login from windows 10 default remote client on the user root then it crashes right away!
    i add a other user in kali linux, and then i got a blue screen....

    So maybe it is windows 10, o go try tomorrow windows 7

  4. #4
    Join Date
    2016-Aug
    Posts
    3
    Did you verify that your install of the lxde desktop was running and was a good install? Also make sure that xfce4 was completely removed.

    Could be windows 10, I have not tired that yet. My work computer is still windows 7 professional.

Similar Threads

  1. Best Wi-Fi adapters for a Raspberry Pi 2 running Kali
    By klapauciusXD in forum ARM Archive
    Replies: 0
    Last Post: 2017-09-18, 09:38
  2. getting XRDP to work on Kali (Raspberry Pi)
    By WEP in forum General Archive
    Replies: 1
    Last Post: 2015-10-29, 08:32
  3. Issues with using XRDP - Kali Linux
    By WEP in forum Installing Archive
    Replies: 1
    Last Post: 2015-03-13, 15:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •