Results 1 to 14 of 14

Thread: Delay 90 seconds on shutdown

  1. #1
    Join Date
    2016-Aug
    Posts
    2

    Delay 90 seconds on shutdown

    Hello,

    I have problem with Kali 2016.1 on VMware.

    When I shutdown Kali I have information like below:
    A stop job is running for User Manager for UID [...]
    A stop job is running for Session c1 of User Debian-gdm [...]


    I must wait 90 seconds everytime.

  2. #2
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    799
    Sounds like something in the background isn't shutting down. Have you tried top or ps -ef to see the processes?

  3. #3
    Join Date
    2013-Dec
    Location
    Krakow
    Posts
    67
    Edit the file /etc/systemd/system.conf and change these lines:

    #DefaultTimeoutStartSec=10s
    #DefaultTimeoutStopSec=10s

  4. #4
    Join Date
    2016-Aug
    Posts
    2
    Quote Originally Posted by Crash View Post
    Edit the file /etc/systemd/system.conf and change these lines:

    #DefaultTimeoutStartSec=10s
    #DefaultTimeoutStopSec=10s
    this is not a solution of the problem but his camuflage.

    I work with VMware, I noticed that the problem start when I install "open-vm-tools" and "fuse"
    Kali 2016.6 not work with vmware-tools properly.
    Last edited by maiki; 2016-08-27 at 08:49. Reason: Merge posts

  5. #5
    Join Date
    2013-Dec
    Location
    Krakow
    Posts
    67
    So, if you take a fast look in google, you can see that is not a specific Kali problem.
    When the responsible devels solve it, it will be applied in Kali.

  6. #6
    Join Date
    2016-Apr
    Posts
    2
    I know this may sound really dumb and I do not know the reason why it solves it but I found it on another thread for Arch Linux.

    The solution is to open shell and "shutdown now" then when the machine comes back on then do a "reboot" and the message goes away and future reboots do not hang anymore.

  7. #7
    Join Date
    2017-Sep
    Posts
    1

    Tested. Confirmed Kali 2017.2 vbox image

    Quote Originally Posted by IronMan View Post
    The solution is to open shell and "shutdown now" then when the machine comes back on then do a "reboot" and the message goes away and future reboots do not hang anymore.
    I just tested this with the latest Kali 2017.2 VirtualBox image. The behavior is consistent. i.e. It corrects the 90s shutdown.

    "this may sound really dumb" kind of has the same ring to it as,
    """
    The most exciting phrase to hear in science, the one that heralds new discoveries, is not “Eureka!” (I found it!) but “That’s funny …”
    — Isaac Asimov
    """ -fortune(Unix), 1987, according to quoteinvestigator.com

  8. #8
    Join Date
    2017-Dec
    Posts
    1
    I had this issue when installing Kali 2017.3 on VirtualBox, running on Mint.
    Reading through several articles and posts, I saw a list of several options - one more exotic then the other.
    I have no idea if this is reproducible for anybody, but it appeared I had my time-zone in Kali set differently then my host machine.
    Just to be able to check my journal and other logs, I corrected that.
    After rebooting yet another time, I suddenly came to the bservation that this "a stop job is running ..." had gone.
    Really, this is the only thing I changed other then sifting trough some logs and options before.
    Anyway - maybe this is of some help to anybody.
    Cheers.

  9. #9
    Quote Originally Posted by amzker View Post
    now this problem is fixed
    open terminal type
    "apt-get update"
    and then type
    apt-get upgrade
    simple this is fixed
    No, I'm sorry to say it's still there.

    Windows 10 Pro Host, Kali Linux 2017.3 Guest (fully updated as of 2 minutes ago) in VirtualBox 5.2.6. VirtualBox extensions and Guest Additions 'VBoxLinuxAdditions.run' version 5.2.7 installed.
    Used apt-get update, apt-get upgrade, and apt-get dist-upgrade to update.
    Exact same message as OP. I tried the "shutdown now", then "reboot" but the problem persists. It's no big deal, I guess, if you don't mind waiting two minutes.

    I looked through the logs but I'm not experienced enough to know what I'm looking for if it's not a glaring error like 'FAIL' or 'missing package' or something like that.

    Anyone have any tips to try?
    .

  10. #10
    Join Date
    2016-Dec
    Location
    Canada
    Posts
    196
    Quote Originally Posted by ThinkingMonkey View Post
    No, I'm sorry to say it's still there.

    Windows 10 Pro Host, Kali Linux 2017.3 Guest (fully updated as of 2 minutes ago) in VirtualBox 5.2.6. VirtualBox extensions and Guest Additions 'VBoxLinuxAdditions.run' version 5.2.7 installed.
    Used apt-get update, apt-get upgrade, and apt-get dist-upgrade to update.
    Exact same message as OP. I tried the "shutdown now", then "reboot" but the problem persists. It's no big deal, I guess, if you don't mind waiting two minutes.

    I looked through the logs but I'm not experienced enough to know what I'm looking for if it's not a glaring error like 'FAIL' or 'missing package' or something like that.

    Anyone have any tips to try?
    .
    Also not just virtual software. Occationally when I live boot fron a dvd this happens.

  11. #11
    Join Date
    2015-Jul
    Posts
    2
    Experiencing same behavior on my VMs.

  12. #12
    Join Date
    2018-Mar
    Posts
    1
    I am running Kali Linux 2018.1 on a Windows Home host machine using VirtualBox. I had the same issue and this is how I fixed it.

    Log in normally as you would in Kali and then, before shutting down, make sure to log out all users (click on the top-right corner and select the user, then log out).
    Only after that you shutdown. This made an instant shutdown for me and all subsequently normal shutdowns (without logging out) as well

  13. #13
    Join Date
    2018-Apr
    Posts
    1
    Thank you camba.. this resolved my issue on VirtualBox Kali 2018.1 (no update, upgrades)

  14. #14
    Join Date
    2015-Jul
    Posts
    2
    Camba's advice worked for me as well. Thank you.

Similar Threads

  1. Replies: 0
    Last Post: 2015-08-18, 16:48
  2. Please help! GRUB error and root delay problem
    By xorslideshow in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-07-28, 10:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •