Results 1 to 1 of 1

Thread: live persistence - flashing black screen after dist-upgrade on mbp early 2013 [video]

  1. #1
    Join Date

    live persistence - flashing black screen after dist-upgrade on mbp early 2013 [video]

    Hello everybody
    It's my first time trying out kali and my first time posting here

    My Setup
    My machine is an early 2013 MacBook Pro (retina)
    I placed the latest amd64 official kali linux image ( on a 32GB USB stick following the official instructions on docs.kali, that is with a simple dd command from OS X command line.
    Everything worked fine.
    Upon restart I'm presented with a "Windows" and "EFI Boot"
    EFI Boot doesn't work... but that's to be expected without the usual rEFInd on these machines
    The "Windows" boot worked like a charm.
    I was able to set up persistence, again following official documentation; wi-fi wasn't working but i just used an Atheros chip external adapter for the moment.

    The Problem
    That's when I decided to run
    apt-get update
    apt-get dist-upgrade
    Previous to dist-upgrade the system rebooted just fine
    After the upgrade, i get past the screen where i select "kali live persistence"
    and then, after a few seconds, the boot comes to a stop and the screen starts to turn on an off again and again and again, as you can see in the video:

    The last lines it displays are:
              Starting GNOME Display Manager . . .
    [ OK ] Started Network Manager Script Dispatcher Service.
    [ OK ] Started GNOME Display Manager.
              Starting Hostname Service . . .
    [ OK ] Reached target Graphical Interface.
              Starting Update UTMP about System Runlevel Changes . . .
    [ OK ] Started Update UTMP about System Runlevel Changes.
    [ OK ] Started Hostname Service.
    This is different from the other problems i've seen where it's usualy a steady black screen with blinking cursos or a flickering screen but successful bootup.
    I cannot get into a usable command line
    If I try ctrl+alt+f2 i get a terminal, but again it's going away very copule of seconds!!
    After 2 minutes I just barley managed to type in
    and this is the output
    anything longer than 5 letter would probably take half an hour

    The little I found out...
    is that if I boot into, say, live, without persistence, everything boots fine but again... that's to be expected.

    Does anybody have a clue on what's going on here?
    Attached Images Attached Images
    Last edited by Gywhard; 2016-08-30 at 01:50.

Similar Threads

  1. Black screen on Live USB with persistence and LUKS
    By host_280 in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2020-04-20, 01:06
  2. Black screen after login after upgrade/dist-upgrade
    By pendragyn in forum TroubleShooting Archive
    Replies: 16
    Last Post: 2017-03-29, 10:13

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts