Results 1 to 2 of 2

Thread: NVIDIA-CUDA-Toolkit $PATH and $LD_LIBRARY_PATH values.

  1. #1
    Join Date

    NVIDIA-CUDA-Toolkit $PATH and $LD_LIBRARY_PATH values.

    I've been struggling with this for several days now, so I finally resorted to creating an account and posting. This is my first post, so please let me know if I'm not following conventions/good posting practice/etc..

    I have been trying to get CUDA support for pyrit going, and I have tried several different tutorials. Currently I am the closest to it I have gotten so far but am running into a problem. NVIDIA-kernal-dkms is installed, glxinfo show direct rendering = yes, nouveau is not loaded, and I installed the nvidia-cuda-toolkit seemingly with no errors via apt-get. However when I try to build and install cpyrit, it says that "the CUDA compiler and headers required to build kernel were not found. Trying to continue anyway...". The paths added to $PATH and $LD_LIBRARY_PATH that are in every tutorial that I have found do not exist on my system, so I guess they were installed to different locations when I ran apt-get. Here is where synaptic says all my files were installed to:

    And here is my current values for $PATH and $LD_LIBRARY_PATH as I have added some based on the above listing:

    PC:~/Desktop/CudaPyrit/cpyrit-cuda-0.4.0# echo $PATH 
    PC:~/Desktop/CudaPyrit/cpyrit-cuda-0.4.0# echo $LD_LIBRARY_PATH
    Could someone help me figure out what needs to be added to the environment variables to get cpyrit to find the CUDA toolkit resources?

  2. #2
    Join Date
    Could someone who has it working share the contents of the /usr/local/cuda-7.5/bin and /usr/local/cuda-7.5/lib folders so I know what files need to be pointed to?

Similar Threads

  1. Fixed winexe and nvidia-cuda-toolkit 5.05> bin2c file conflict
    By jubei in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-11-28, 15:26

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts