Results 1 to 4 of 4

Thread: Hashcat give this error after last apt-get upgrade apt-get dist-upgrade

  1. #1
    Join Date

    Hashcat give this error after last apt-get upgrade apt-get dist-upgrade

    I use Kali 2016.1 upgraded to 2016.2 and I have Intel HD/Nvidia GPU so I need to use Bumblebee to make any use of my graphic cards.

    After last nights update I can no longer run hashcat, I get the error listed below.

    Normally I would run hashcat with the following command.

    optirun hahscat -m 0 -a 0 SomeHash SomeWordlist

    And it just run as it should.

    Now I get this....
    Doesn't matter if I don't restore session, same error

    hashcat (v3.10) starting in restore-mode...

    OpenCL Platform #1: NVIDIA Corporation
    - Device #1: GeForce GTX 965M, 1009/4037 MB allocatable, 8MCU

    OpenCL Platform #2: Mesa, skipped! No OpenCL compatible devices found

    WARN: nvmlDeviceGetFanSpeed() 3 Not Supported

    Hashes: 6886776 hashes; 6886776 unique digests, 1 unique salts
    Bitmaps: 23 bits, 8388608 entries, 0x007fffff mask, 33554432 bytes, 5/13 rotates
    Applicable Optimizers:
    * Zero-Byte
    * Precompute-Init
    * Precompute-Merkle-Demgard
    * Meet-In-The-Middle
    * Early-Skip
    * Not-Salted
    * Not-Iterated
    * Single-Salt
    * Brute-Force
    * Raw-Hash
    Watchdog: Temperature abort trigger set to 90c
    Watchdog: Temperature retain trigger set to 75c

    Initializing device kernels and memory...

    ERROR: clCreateContext(): CL_UNKNOWN_ERROR

    I have tried to point to my GPU but since it's an error in CL it don't work.

    Any clues here?
    Hashcat is way faster than aircrack-ng so I would really love to have this running again.

    If I reinstall the system it might run again but only until they decide to update something that breaks Bumblebee + CUDA integration....

    deviceQuery output

    CUDA Device Query (Runtime API) version (CUDART static linking)

    Detected 1 CUDA Capable device(s)

    Device 0: "GeForce GTX 965M"
    CUDA Driver Version / Runtime Version 8.0 / 7.5
    CUDA Capability Major/Minor version number: 5.2
    Total amount of global memory: 4038 MBytes (4233691136 bytes)
    ( 8) Multiprocessors, (128) CUDA Cores/MP: 1024 CUDA Cores
    GPU Max Clock rate: 1150 MHz (1.15 GHz)
    Memory Clock rate: 2505 Mhz
    Memory Bus Width: 128-bit
    L2 Cache Size: 1048576 bytes
    Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
    Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
    Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
    Total amount of constant memory: 65536 bytes
    Total amount of shared memory per block: 49152 bytes
    Total number of registers available per block: 65536
    Warp size: 32
    Maximum number of threads per multiprocessor: 2048
    Maximum number of threads per block: 1024
    Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
    Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
    Maximum memory pitch: 2147483647 bytes
    Texture alignment: 512 bytes
    Concurrent copy and kernel execution: Yes with 2 copy engine(s)
    Run time limit on kernels: No
    Integrated GPU sharing Host Memory: No
    Support host page-locked memory mapping: Yes
    Alignment requirement for Surfaces: Yes
    Device has ECC support: Disabled
    Device supports Unified Addressing (UVA): Yes
    Device PCI Domain ID / Bus ID / location ID: 0 / 1 / 0
    Compute Mode:
    < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

    deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 8.0, CUDA Runtime Version = 7.5, NumDevs = 1, Device0 = GeForce GTX 965M
    Result = PASS

    Last edited by BrokenArrow; 2016-09-16 at 04:28.

  2. #2
    Join Date
    The Pits
    Hello BA, I don't know anyone who can run cudahashcat under the latest Kali, can you just reinstall your previous version? I myself am not too smart but kl0n's text here maybe explains the problem:

  3. #3
    Join Date
    I solved the first problem running hashcat with this step.

    Installing Bumblebee
    Installing Cuda-Tools

    and after tha latest dist-upgrade I had to download the specific OpenCL for Nvidia and some more stuff regarding Cuda

    Now I can run hashcat with my discrete card again.

  4. #4
    Join Date
    hashcat v3.10
    check the installation of these packages:

    apt install nvidia-opencl-icd
    apt install libxnvctrl-dev
    apt install nvidia-opencl-dev
    apt install libgmp3-dev
    apt install libgmp10-doc
    apt install opencl-headers
    Last edited by x5ctf; 2016-10-15 at 11:59.

Similar Threads

  1. Kali Update && Upgrade && dist-upgrade Error
    By Dickz in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-09-12, 07:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts