Results 1 to 4 of 4

Thread: TP-LINK TL-WN722N and OnePlus One sometimes works, often doesn't. At wits end!

  1. #1

    Unhappy TP-LINK TL-WN722N and OnePlus One sometimes works, often doesn't. At wits end!

    Long time lurker, first time caller.

    Hi everyone I am wondering if anyone can give me some advice on this issue.

    I have read everything I can, looked for answers everywhere possible and frankly this is now driving me mad.

    So I turn to you guys to see if anyone knows what is up with this issue.

    I have Nethunter all up and running on my One Plus One (from here onwards I will shorten it to OPO). Everything is gravy.

    I bought a TP-LINK TL-WN722N. It is fully functional on other devices.

    Initially I had issues making it work with the OPO because apparently the OTG cable I was using was incompatible.

    I did some searching and apparently OPO's are erratic with most OTG cables except for the official one made by the people at One Plus.

    So I bought a One Plus OTG cable, plugged in the TP Link, airmon-ng'ed it and everything was working.

    Then I tried it again and it would not recognise the device at all and nothing was working.

    And then it didn't work again for many many tries.

    Then it worked once or twice. Now I can't get it to work at all.

    I remember reading somewhere it is important to start it with the adapter plugged in, to have wifi off and / or aeroplane mode on startup. I have tried every variation of this. I have spent hours and hours trying to work this out.

    I am now completely at my wits end and about to throw the thing out the window.

    Anyone got any tips or suggestions to try working this thing out?

    Thanks in advance.

  2. #2
    Which version of nethunter do you use ?
    Kernel Version ?
    Which Android OS ?

    Please post the "dmesg" output after you plugged in the TL-WN722N.


  3. #3
    Agreed, useful to post more detail on version used etc...

    However, thought I would share my most recent experiences. I've been using nethunter on OPO for the last 18 months or so, and have had many problems ever since upgrading to CM13 and nethunter 3. I tried reinstalling CM13 and nethunter many times from images downloaded onto the device using TWRP, and every time I went through this process, I ended up with slightly different results, some things working, some not, sometimes nethunter was the problem, sometimes my TP-Link (I have the same one as you, with a cheap OTG cable bought from amazon) sometimes CM was the problem.

    This weekend I decided to follow the original install intructions here:

    I built nethunter myself from git repo as per instructions, copied all versions back in to respective folders, and ran the install process. Yes, I lost all my data, pictures, etc... (yes I do have backups!) but what I do now have is a fully working CM with nethunter. mana works, kismet with GPS works, wifite works, so far... everything works!!! Still to test booting with drivedroid, but so far this looks really promising.

    Note to self... when things break in the future, go right back to square one! It really didn't take that long, I maybe spent a couple of hours on it. A couple of hours in one hit is way less painful than repeatedly trying various shortcuts with mixed results over days / weeks / months.

    I have yet to update to nethunter app version 3.1.5 as it requires uninstalling the previous version first, and quite frankly, I don't want to risk breaking what it currently working. If I pluck up the courage, I will post results back here.

    I hope this helps you solve your problem.

  4. #4
    How many OTG cables have you tried? I had this issue and it was just the cable.

Similar Threads

  1. TP link WN722N
    By sebfiesta in forum NetHunter General Questions
    Replies: 2
    Last Post: 2016-05-09, 09:23
  2. TP-LINK WN722N works great, TP-LINK WN822N does not.
    By Diluted in forum NetHunter General Questions
    Replies: 1
    Last Post: 2016-01-29, 23:55
  3. Kali and TL-WN722N nothing works :(
    By martel_420 in forum TroubleShooting Archive
    Replies: 13
    Last Post: 2015-10-27, 19:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts