Results 1 to 3 of 3

Thread: Kali 2016.2 Luks Persistent USB Only Boots Failsafe Options No Specific Error Suspect

  1. #1
    Join Date
    2016-Sep
    Posts
    4

    Kali 2016.2 Luks Persistent USB Only Boots Failsafe Options No Specific Error Suspect

    Hey everyone,

    I have been digging through forums and googling for hours... to include countless techno blaring youtube videos.

    So here is the following:

    Kali version (KDE/GNOME, Arhitecture): Kali 2016.2 iso from the kali.org Downloads.
    Kali installation (VM, HDD, USB): Followed the documentation from the website to the letter for creating a persistent usb with LUKS. I used a Kali Virtual Box to DD the image to the usb; then the terminal and followed all commands. Its a 32 gb SanDisk Ultra.
    Basic output of commands (ifconfig, iwconfig, lspci, lsusb, dmesg, etc.): Which of these commands would be most useful here- I will be happy to post them.
    An error message (if any): None.
    Links to the same problem (if any): I haven't found a similar circumstance
    Solutions tried and their result:


    After disabling secure boot (it will only boot to USB due to invalid bootloader signature) and booting to the USB I selected Encrypted Persistence option and got the usual black screen and scrolls. Gave my luks passphrase and got more scrolls. It terminated with "End Kernel Panic - Not Syncing exit code = 0x00000200"
    Solution: added nomodeset vga=normal to the linux line in EFI/BOOT/live.cfg on the usb.

    Rebooted and it got further. This time it stopped on some error EXT4 etc. (my apologies- if this is uncommon I will try again and get exct).
    Solution: copied and pasted the options from the failsafe command.

    To be clear the following is now my entire EFI/BOOT/live.cfg after modifications.

    ------------------------------------follows this line-----------------------------------------

    label live-amd64
    menu label ^Live (amd64)
    menu default
    linux /live/vmlinuz
    initrd /live/initrd.img
    append boot=live username=root hostname=kali

    label live-amd64-failsafe
    menu label ^Live (amd64 failsafe)
    linux /live/vmlinuz
    initrd /live/initrd.img
    append boot=live components memtest noapic noapm nodma nomce nolapic nomodeset nosmp nosplash vga=normal

    label live-forensic
    menu label Live (^forensic mode)
    linux /live/vmlinuz
    initrd /live/initrd.img
    append boot=live noconfig=sudo username=root hostname=kali noswap noautomount

    label live-persistence
    menu label ^Live USB Persistence (check kali.org/prst)
    linux /live/vmlinuz
    initrd /live/initrd.img
    append boot=live noconfig=sudo username=root hostname=kali persistence

    label live-encrypted-persistence
    menu label ^Live USB Encrypted Persistence (check kali.org/prst)
    linux /live/vmlinuz
    initrd /live/initrd.img
    append boot=live components memtest noapic noapm nodma nomce nolapic nomodeset nosmp nosplash vga=normal persistent=cryptsetup persistence-encryption=luks noconfig=sudo username=root hostname=kali persistence

    ##append boot=live persistent=cryptsetup persistence-encryption=luks noconfig=sudo username=root

    -------------------------------ends above this line--------------------------------------------------------------------------------

    Results: Kali boots into the persistent mode with LUKS at resolution of 800x600 and I can connect to Wifi.

    I could start elimination failsafe options from the 'append boot' line until I find the one that is the trouble maker. However, for sanity and time I was hoping I could get some advice on what log or error output to post here and work through it more directly.

    What I suspect:: From the dual booting days I remember an issue with Debian linux (Fedora worked great btw). Ubuntu and Mint etc. had some issues with integrated video card laptops and nvidia card combos. My laptop is a an intel video and nvidia 970m with not bios option to disable either one.

    Prior to blindly doing 'apt-get purge nvidia*' and installing proprietary driver etc. I remember some sort of optimus or bumble bee drivers allowing the OS to recognize the integrated system. To be more clear prior to trying random solutions I would like to narrow the problem down to the root cause. Then administer the proper treatment.

    Thanks in advance to a supportive community. I am ready to locate and post additional information as directed/needed with a little direction.


  2. #2
    Join Date
    2016-Sep
    Posts
    12
    geronimo,

    This was a difficult post to read fully, as you made it way more difficult than it needed to be. You'll need the following:

    • You'll need a universal USB installer
    http://www.pendrivelinux.com/univers...easy-as-1-2-3/
    • Your Kali ISO (whichever you prefer, but I'd suggest the top one)
    https://www.kali.org/downloads/
    • Of course, your MiniTool partition wizard
    www.partitionwizard.com

    Then follow these easy steps:

    • Put the ISO download of Kali onto the USB using the Universal USB Installer
    • Partition the USB
    → Create as Primary
    → File system: Ext4
    → Partition Label: persistence
    • Boot Kali into Live and run the following commands:

    fdisk –l
    mkdir -p /mnt/UUI
    mount /dev/sdb2 /mnt/UUI
    echo "/ union"> /mnt/UUI/persistence.conf
    umount /dev/sdb2 && reboot

    System will reboot, and you’ll be good to boot and enter USB live persistence

  3. #3
    Join Date
    2016-Sep
    Posts
    4
    Thank you.
    I was merely trying to be as detailed as possible- perhaps it was too detailed.

    At any rate after running http://www.pendrivelinux.com/univers...easy-as-1-2-3/ through virustotal and seeing 3 or 4 trojans detected I am hesitant to use it. Though I was tempted.

    Any further guidance? Are you sure this is the issue. I followed the official Kali guidance to a 'T'.

    Any further clarification on the reasoning would be great. I am a technical guy and need to know the "why's" if possible.

    Thanks

Similar Threads

  1. Make a Persistent USB That Boots without Prompting
    By scorpius in forum How-To Archive
    Replies: 0
    Last Post: 2016-08-11, 21:56
  2. Encrypted Persistent USB only boots on USB2.0 - NOT USB3.0
    By muffinman in forum Installing Archive
    Replies: 3
    Last Post: 2013-04-10, 22:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •