Results 1 to 3 of 3

Thread: OpenCL Issues

  1. #1
    Join Date

    Unhappy Kali & OpenCL are not friends,

    Hey all,

    other than blindly installing anything with a vague reference to Opencl or cuda i'm all out of ideas

    this never used to be a problem.

    So I guess the question is:

    Does anyone know how to satisfy the dependencies to have hashcat working correctly on Kali rolling ?

    I have a workstation that has two 1080's going to waste
    and a Dell Latitude e7270 (intel graphics)

    both have the openCL issues

    I consider hashcat a core part of my 'kitbag'

    anyway I'd love to see it working, or instead of rolling I'd like stable ? there are probably at least 5 ways to capture a hash in Kali ... cracking them should be a priority no ?

    if there is a specific way to set it up please show me, if I need to do anything tell me, please.

    [root:~/Desktop/hashcat-master]# ./hashcat --benchmark
    hashcat (master) starting in benchmark-mode...
    OpenCL Platform #1: NVIDIA Corporation
    - Device #1: GeForce GTX 1080, 2027/8110 MB allocatable, 20MCU
    - Device #2: GeForce GTX 1080, 2028/8113 MB allocatable, 20MCU
    ERROR: clCreateContext(): CL_UNKNOWN_ERROR
    Hashtype: MD4
    ERROR: clSetKernelArg(): CL_INVALID_KERNEL

    hashcat (v3.10-390-g180bdba) starting in benchmark-mode...
    OpenCL Platform #1: Mesa, skipped! No OpenCL compatible devices found
    ERROR: No devices found/left
    ERROR: opencl_ctx_devices_init() failed
    Started: Fri Oct  7 09:00:02 2016
    Stopped: Fri Oct  7 09:00:02 2016
    Last edited by poojinky; 2016-10-07 at 08:01.

  2. #2
    Join Date
    apt install nvidia-opencl-icd
    apt install libxnvctrl-dev
    apt install nvidia-opencl-dev
    apt install libgmp3-dev
    apt install libgmp10-doc
    apt install opencl-headers

  3. #3
    Join Date
    I just finished installing the drivers for Nvidia and had the same problem regarding "No OpenCL drivers" found, or some such thing. So, I did a bit of Googling, then decided to install what I thought would solve the problem, and - it did.

    I used Synaptic Package Manager (which I recommend using over the OEM package manager) to search for the term "opencl", then marked for installation "NVIDIA OpenCL installable client driver (ICD)", which also marked a bunch of other files for installation. I then ran hashcat and it worked... but it did mention I was short on one installation file - "libxnvctrl-dev". So after installing the above I ran "apt-get install libxnvctrl-dev". Bingo!

    I just ran hashcat on a hccap file and it peaked at 110,000 hits (calculations) a second! The best I got previously was about 4200 hits a second on 32-bit. All I have been able to say is: Wow. Over and over and over. Wow. Wow. Wow. I am flabbergasted. I went through my entire dictionary file collection in the 8-12 character optimized directory in about 6 minutes. Previously it would take hours.

    Hope this helps.


Similar Threads

  1. Pyrit OpenCL on AMD GPU python 2.7 error
    By BattlestarSC in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2017-04-29, 21:38
  2. Kali v2, Hashcat and OpenCL
    By James_Wood in forum General Archive
    Replies: 5
    Last Post: 2017-04-26, 01:24
  3. AMD APU OpenCl Error
    By thomasb9511 in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2013-09-24, 20:27
  4. [Help] Install Pyrit with OpenCL
    By Kraako in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2013-03-27, 21:46

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts