Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Cannot apt-get update. Err:1 kali-rolling InRelease

  1. #11
    Junior Member
    Join Date
    Nov 2015
    deb kali-rolling main contrib non-free
    # For source package access
    # deb-src kali-rolling main contrib non-free
    deb-src kali-rolling main contrib non-free

    copy and replace in sources.list

  2. #12
    Junior Member
    Join Date
    Oct 2016
    Your /etc/sources.list should be:

    deb kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    # deb-src kali-rolling main contrib non-free

    However if the above official source not working to you, you may use the official kali mirrors.
    1) Go to this link
    2) under "mirrors which handle this country" copy any one of the link (example in my case: )
    3) Open nano /etc/apt/sources.list and paste it at the bottom.
    4) Remove "/README" from the link and make it looks like this -> "deb kali-rolling main contrib non-free"
    5) Comment all previous sources except the mirror that you just pasted.
    6) and finally your Mirror sources.list should be like this: (Example of my kali mirror sources.list)

    #Kali Linux Rolling Official Repositories
    #deb kali-rolling main contrib non-free

    #Kali Linux Rolling Official Mirrors Repositories
    deb kali-rolling main contrib non-free

    7) Exit and write changes.
    8) Run apt-get clean && apt-get update and see if it works.
    9) If it still doesn't working, try to replace it with another mirror.

    Hope this helps anyone out there.

  3. #13
    Junior Member
    Join Date
    Nov 2014
    @mlrkumar suggestion worked fine.

  4. #14
    Junior Member
    Join Date
    Dec 2016

    Update nethunter

    Quote Originally Posted by jeret View Post
    hi i cannot seem to do an update in kali (nethunter)Kali GNU/Linux Rolling \n \l

    i keep getting this error:

    root@kali:~# apt-get update
    Err:1 kali-rolling InRelease
    Temporary failure resolving ''
    Reading package lists... Done
    W: Failed to fetch Temporary failure resolving ''
    W: Some index files failed to download. They have been ignored, or old ones used instead.

    My internet works fine, my DNS is set to google DNS and my GPG keyring is up to date.

    root@kali:~# kali-archive-keyring is already the newest version (2015.2).

    this is my source.list:

    deb kali-rolling main contrib non-free
    deb-src kali-rolling main contrib non-free

    my kali info:

    Linux kali 3.4.105-g766de8b #1 SMP PREEMPT Sun May 29 13:33:54 PDT 2016 armv7l GNU/Linux

    Distributor ID: Kali
    Description: Kali GNU/Linux Rolling
    Release: kali-rolling
    Codename: kali-rolling
    If you check the nethunter app there is a part that says metapackages. I'm sure this is the equivalent to update.

  5. #15
    Junior Member
    Join Date
    Apr 2017


    mrkumar - thanks for the tip. That took some serious sleuthing, I'm sure but you saved me a lot of time and effort. +1

    Quote Originally Posted by mlrkumar View Post
    Using putty connect to Nethunter and Run
    vi /etc/passwd,
    Change the line
    _apt:x:104:3004::/nonexistent:/bin/false to _apt:x:0:65534::/nonexistent:/bin/false
    Save and Run apt-get update ,It Works Check it ,
    Explanation: Changing GID 3004 to 65534 ,What is GID 3004 on your system?
    The fact that the _apt user is part of "nogroup" is actually the problem.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts