Results 1 to 8 of 8

Thread: [SOLVED] NetworkManager reverts spoofed MAC to permanent one or randomizes it

  1. #1
    Junior Member
    Join Date
    Oct 2016
    Location
    Capão Bonito - SP, Brazil
    Posts
    2

    Lightbulb [SOLVED] NetworkManager reverts spoofed MAC to permanent one or randomizes it

    I came across with this problem a few days ago after updating Kali — I use Kali Linux 2016.2 (64 bit), by the way. Before updating/upgrading the system through its repositories, macchanger was working like a charm. However, soon after the update, I tried to spoof my MAC address in order to bypass some MAC filtering I've set up in my own network, and everytime I attempted to do it (and there were several tries…), my MAC address was automatically reverted to, or its permanent burnt-in address, or a random one.
    At first, I was not sure about what could be possibly causing it, but after doing some tests, using different devices, tools and setups, I found out that the issue was being originated by NetworkManager, which I realized later being not an issue exactly, but just a different default configuration of the service than the one we were used to.
    The lastest versions of NetworkManager, 1.4.2, in this particular case, implement several configuration options for MAC spoofing/cloning, and when put in use, these options tend to override any configurations set by tools like macchanger and macchito, making them practically useless. It turns out that, in its newer versions (above 1.2, but more notably the versions above 1.4, which dispenses wpa_supplicant support for this purpose), NetworkManager default configurations are set to randomize your MAC address or revert it to the permanent one at the moment your interface scans the networks around you or attempt to connect into one of them. This new feature is very interesting for purposes of anonymity; for MAC spoofing, however, it can complicate the authentication process.

    Disabling this feature is very simple, you'll just need to change some NetworkManager's configurations. You can do this either by editing /etc/NetworkManager/NetworkManager.conf file or adding an additional .conf file to /etc/NetworkManager/conf.d directory (the .conf file can have any name). Though I highly recommend the second option, given that when updated, NetworkManager usually replaces its main .conf file, and if you choose the first option, your saved options may be overriten when the service gets these updates from time to time.

    Whatever option you choose, in the text editor, add the following lines:
    Code:
    [device]
    wifi.scan-rand-mac-address=no
    
    [connection]
    ethernet.cloned-mac-address=preserve
    wifi.cloned-mac-address=preserve
    Then save the file, and inside the terminal, restart NetworkManager by typing in:
    Code:
    service network-manager restart
    And it's done, the problem now should have been resolved.
    If you want to know more about how can you configure NetworkManager in its newer versions by yourself, I recommend reading the following article, it was the one that helped me into solving this:
    https://blogs.gnome.org/thaller/2016...manager-1-4-0/
    In addition, the GNOME Developer Center offers a reference manual for making changes in the newer versions of NetworkManager, you may find it very helpful as well:
    https://developer.gnome.org/NetworkM...ml#id-1.2.5.12




    th3_z3r0

  2. #2
    Junior Member
    Join Date
    Feb 2016
    Posts
    6
    Thanks mate. This fixed the issue for me

  3. #3
    Junior Member
    Join Date
    Aug 2015
    Posts
    4
    This solved my issue as well, no need to modify wpa_supplicant when I was unable to bring wlan0 up after macchanger

  4. #4
    Thank you so much!

  5. #5
    Junior Member
    Join Date
    Apr 2017
    Posts
    4
    I did exactly as you said in this post but it still doesn't work for me, using VM kali linux, bridged adapter connection with VMS. Did as you did point for point yet as soon as I change my mac address and restart network manager I can't connect to the internet or anything.

  6. #6
    Senior Member
    Join Date
    Jul 2013
    Posts
    805
    To Klinel

    There are several methods to handle this problem

    Read thru this thread

    https://forums.kali.org/showthread.p...ight=netmanmac


    Musket Teams

  7. #7
    Junior Member
    Join Date
    Apr 2017
    Posts
    4
    I can see that that thread is for a wifi fix, will it work the same with ether? will any of the steps be different (not experienced with this stuff)

  8. #8
    Junior Member
    Join Date
    Apr 2017
    Posts
    4
    Tested and it does not work for wired - only for wireless networks, as shown in image below.

    abc.jpg

    I'm very stuck, I've tried every "solve" on this forum.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •