Results 1 to 3 of 3

Thread: rtlwifi/rtl8723befw.bin-Wireless stop working, laptop needs to reboot to get work

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2016-Sep
    Posts
    22

    rtlwifi/rtl8723befw.bin-Wireless stop working, laptop needs to reboot to get work

    Hello to all,
    I m using Lenovo y50 with dual boot with win 10 and kali linux(64 bit). My hardware description are:

    1.Intel i7-4710HQ quad core.

    2.Nvidia GTX 860m.

    3. Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter.

    4.Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)-ETHERNET

    I m running kali linux latest edition 2016.2.During installation it shows:
    Some of your hardware needs non-free firmware files to operate.
    The missing firmware files are: rtlwifi/rtl8723befw.bin

    After successful installation my wi-fi stops working within a few minutes of booting and sometimes it works for hours and then stops working.

    The output of "lspci"
    0a:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5249 PCI Express Card Reader (rev 01)

    I have attached one snapshot also for my hardware details .

    PLEASE HELP!

    Thanks
    Attached Images Attached Images

  2. #2
    Join Date
    2016-Nov
    Location
    Vienna
    Posts
    2
    Hi!

    I have no solution for this, but new information:
    As the Sucuri WebSite Firewall rejects my posts, I have put it on pastern: http://pastebin.com/JitDBCDN

    The problem is regarding the PIC Mode of the kernel, lwlfinger, the author of the rtlwifi module told me, that his code is not requesting PIC Mode.

    Any idea?

  3. #3
    Join Date
    2016-Sep
    Posts
    22
    Hello grisutheguru,

    Thank for the reply. After waiting for a long time i felt helpless here but after a long time I was searching again for the problem I found my own thread (lol) and i appreciate your effort for helping me. In between i had made changes in source list which i found randomly that helped me for connecting to wifi on a condition of continuous browsing but its too get disconnected after a long pause. Than I found TP-LINK external adapter for solving my issue which is running fine now .

    The information which you have posted in previous thread i didn't get that as I don't know much about linux. I hope this issue might get fixed by the communities for realtek wifi adapters.
    looking forward for your reply.
    Thanks.

Similar Threads

  1. Wireless was working , reboot , now it doesnt.
    By Blackuser in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-10-31, 23:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •