Results 1 to 2 of 2

Thread: [w3af error] after update+upgrade

  1. #1
    Join Date

    Exclamation [w3af error] after update+upgrade

    • kali-linux-all *4.7;2016.3.1
    • Kali installation on HDD

    Yesterday did a sys update (update && upgrade), then appeared here such error:
    root@Kali:~# w3af
    It seems that your Python installation does not have all the modules required by the w3af framework. For more information about how to install and debug dependency issues please browse to
    Traceback (most recent call last):
      File "/usr/bin/w3af", line 151, in <module>
      File "/usr/bin/w3af", line 147, in _main
      File "/usr/bin/w3af", line 142, in main
      File "/usr/share/w3af/w3af/core/ui/console/", line 145, in sh
        self._context = rootMenu(name, self, self._w3af)
      File "/usr/share/w3af/w3af/core/ui/console/", line 70, in __init__
        'kb': kbMenu
      File "/usr/share/w3af/w3af/core/ui/console/", line 26, in mapDict
        fun(p, dct[p])
      File "/usr/share/w3af/w3af/core/ui/console/", line 110, in addChild
        name, self._console, self._w3af, self, *params)
      File "/usr/share/w3af/w3af/core/ui/console/", line 47, in __init__
        plugin = self._w3af.plugins.get_plugin_inst('attack', plugin_name)
      File "/usr/share/w3af/w3af/core/controllers/core_helpers/", line 247, in get_plugin_inst
        plugin_inst = factory('w3af.plugins.%s.%s' % (plugin_type, plugin_name))
      File "/usr/share/w3af/w3af/core/controllers/misc/", line 62, in factory
      File "/usr/share/w3af/w3af/plugins/attack/", line 37, in <module>
        from w3af.plugins.attack.db.sqlmap_wrapper import Target, SQLMapWrapper
      File "/usr/share/w3af/w3af/plugins/attack/db/", line 33, in <module>
        from w3af.core.controllers.daemons.proxy import Proxy
      File "/usr/share/w3af/w3af/core/controllers/daemons/proxy/", line 1, in <module>
        from .handler import ProxyHandler
      File "/usr/share/w3af/w3af/core/controllers/daemons/proxy/", line 25, in <module>
        from netlib.odict import ODictCaseless
    ImportError: No module named odict

    I tried to remove w3af, mitmproxy, python (all), sqlmap and reinstalled (install kali-linux-all) - problem persists.
    Last edited by Edelweiss; 2016-10-24 at 11:35.
    Atlas H168 Laptop
    Intel Core i7 6700HQ [SkyLake] [3.5 x 4]
    8 GB RAM 1600 DDR3L
    Nvidia GeForce 940M 2048 GDDR3
    Intel HD530 [SkyLake Graphics]

  2. #2
    Join Date
    Hi, I solved this problem today, it was due to the w3af installed in Kali doesn't support the new version python lib mitmproxy 0.18. What you have to do is downgrade it to 0.17.
    Firstly you may need install these things to make sure the old mitmproxy install correctly.
    apt-get install libpq-dev python-dev libxml2-dev libxslt1-dev libldap2-dev libsasl2-dev libffi-dev libtiff5-dev libjpeg62-turbo-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk
    After install complete then you can downgrade it!
    pip install mitmproxy==0.17
    And you can check up the version now use by
    pip show mitmproxy
    If everything goes fine then you could open w3af.
    Last edited by zesicus; 2016-10-29 at 04:08.

Similar Threads

  1. Kali Update && Upgrade && dist-upgrade Error
    By Dickz in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-09-12, 07:11
  2. W3AF fails to load after update/upgrade
    By HackR2D2 in forum Installing Archive
    Replies: 5
    Last Post: 2014-11-10, 04:14
  3. Replies: 12
    Last Post: 2014-03-14, 22:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts