Results 1 to 9 of 9

Thread: Kali BROKEN after full update

  1. #1
    Join Date
    2016-Oct
    Posts
    2

    Question Kali BROKEN after full update

    Hello, i recently installed kali linux and after instaling it i wanted to install google chrome, but i wasn't been able to because libapp(something)1 was missing and installing it caused a error.
    I started to mess arround trying to fix this, but i cloudn't.
    After trying to apt-get update && apt-get upgrade && apt-get dist-upgrade && (and few other things) it started updating and after a hour or so i was knocked out to login screen, after logging in i saw: blue desktop background, no icons and trying to launch any app kick me out to login screen.
    Can someone help me with this please???

  2. #2
    Join Date
    2016-Sep
    Posts
    4
    thats because you need to add a non root user otherwise you wont be able to run chrome . You dont want to do it with you root account trust me . Thats the big downside of kali , everything runs as root

  3. #3
    Join Date
    2016-Oct
    Posts
    1
    True alex9393, running any browser as root is a major bad idea. This is why I don't add a root user when I install kali. If you press enter when the install asks for a root password, it will then prompt you for RealName, userName, etc. This user will have sudo rights and with that you can change the password of user root (passwd root) and then you have a nonRoot user and a root user. Presto! You can easily add a nonRoot user with "adduser $USERNAME" too... but that user will not be a sudoer.

  4. #4
    Join Date
    2016-Oct
    Posts
    2
    i was thinking, that i already added non-root user (after installation process)

    AND launching any app (example: terminal) kicks me out to login screen

    (and sorry if my english sucks)
    Last edited by maiki; 2016-11-02 at 09:22. Reason: Merge posts

  5. #5
    Join Date
    2016-Nov
    Posts
    2
    I am having the same issue. If I use the Kali VMWare build (which I did ensure the checksum matched after download) or install via ISO and run apt-get update && apt-get upgrade eventually I get to a point in installing the packages where the login screen shows and sometimes I can login and if I move the mouse it just goes back to the login screen constantly. After retrying this a few times I can sometimes get to the Desktop where it is blue but the icons do not show up and if I try to launch anything it kicks me out to the login screen. After trashing my VM and trying this a few times it seems pretty consistent. Guess I will wait until the next build/release but very frustrating.

    EDIT: Just a side note I am not logged in as root. Just tried again for the 4th time and same thing over and over. :-\

    -raedeus
    Last edited by maiki; 2016-11-04 at 08:53. Reason: Merge posts

  6. #6
    Join Date
    2016-Nov
    Posts
    1
    Me too I got the same issue after upgrade !! Can anyone help??

  7. #7
    Join Date
    2016-Dec
    Location
    Morocco
    Posts
    1
    Boot in the recovery mode and remove chrome, `apt-get remove "chrome or whatever you typed here"`, configure the network connection then `apt-get update` `apt-get upgrade` .
    I think it's gonna work

  8. #8
    Join Date
    2013-Jul
    Posts
    841
    To Napert

    MTeams has experienced the same problem with ALL their 2016R2 HardDrive installs.

    For now we only update we never upgrade.

    Musket Teams

  9. #9
    Join Date
    2017-Mar
    Posts
    2

    Successfully Upgrading Kali Rolling 2016.2

    something similar happened with me while I was trying to update and then upgrade Kali Rolling 2016.2, the version with pre-installed tools (not the 'lite' version). I was kicked into the login screen and upon login there was nothing except for the blue background and the top bar with no image content.
    I had to reinstall Kali at that point of time but I guess there is an alternative too.

    1. When at login screen, try Alt+Ctrl+F3. You'll now be in the terminal interface where you're to enter your login credentials.
    2. Make sure you're connected to ethernet or to wifi by typing the command 'iwconfig' and confirming the ESSID.
    3. Considering that the installation was interrupted, enter 'dpkg --configure -a' to resume the installation.
    4. Now, let it complete and reboot.
    5. Congrats! You must be into your upgraded Kali. If not, consider reinstalling Kali and follow the steps 1 and 2. Then update and upgrade using commands 'sudo apt-get update && sudo apt-get upgrade'.
    6. Also, if after you want to, you can 'sudo apt-get dist-upgrade' after step 5.

    I am pretty new to linux apart from having screwed my Windows desktop more than once while installing ubuntu years ago.

    Comment. I'll try to be of help.

Similar Threads

  1. Replies: 6
    Last Post: 2017-09-14, 22:57
  2. Update issue - broken package
    By natv in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-09-23, 17:35
  3. Replies: 5
    Last Post: 2015-08-31, 04:51
  4. w3af broken after update on Kali 1.0.7
    By mbeaven in forum General Archive
    Replies: 3
    Last Post: 2014-08-17, 12:33

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •