Results 1 to 5 of 5

Thread: Hardware Compatibility Issues

  1. #1
    Join Date
    2016-Nov
    Posts
    5

    Hardware Compatibility Issues

    I have been messing around trying to get my new laptop to install Kali Linux properly. Kali Linux 2016.2 (rolling i believe its called). I always fully update each installation attempt.

    ASUS FZ50VW-NS51:

    Intel Core i5-6300HQ 2.3 GHz
    8 GB DDR4
    GeForce GTX 960M with 2 GB GDDR5
    Intel HM170 Express Chipset
    Intel 802.11ac wireless NIC
    128 GB Samsung m.2 SSD and 1 TB HDD which I removed for testing purposes

    So here is the problem it is not a dedicated graphics card, technically I believe it is configured in an NVIDIA optimus arrangement in which the Intel built in graphics card and the NVIDIA card work in tandem to save battery life.
    HTML Code:
    http://www.nvidia.com/object/optimus_technology.html
    So problems I have encountered. Installation goes perfectly with no errors, upon booting into the operating system. I attempt to login as root, it accepts my credentials and the GNOME desktop does not appear it just freezes at a blank grey screen.

    I have tried using a live bootable USB version of Kali and it does the same thing. I have also tried utilizing a live disk of Kali but with the XFCE interface instead of GNOME, both gave me the same issue.

    The other problem is my system fan sounds like a helicopter is taking off as soon as Kali loads. This is probably because optimus setups run very poorly on Linux (thanks NVIDIA...).

    I have tried using lm-sensors and fancontrol but to no resolution. This may be user error on my side though.

    I am a Windows administrator, so I am rather tech savy. I had a previous Kali box I used for pentesting but alas it was old and only had a dual core with no NVIDIA graphics card. My computer skills are strong but my Linux Fu is not perfect. So any advice would be appreciated. At this point I have given up and marked the new laptop as a very expensive business paper weight.

  2. #2
    Join Date
    2016-Nov
    Posts
    5
    Sorry I forgot to mention that I do have access to tty (teletype) using CTRL + ALT + F2,3,4,etc. So that is how I update the system and tried installing lm-sensors and fan control. I just can't utilize the main GNOME interface. To me it really seems like an issue with graphics drivers just because of the Intel built in graphics card and the NVIDIA card being stuck in that optimus configuration.

    However I have tried updating my NVIDIA drivers using
    http://docs.kali.org/general-use/ins...-on-kali-linux
    but it did nothing but make the gnome interface break even worse. I now get the "something went wrong error" displayed upon bootup. So I basically can't access GNOME or TTY after going through that process. So I reinstalled Kali and tried again, to the same result.

    This could be me just fumbling around and installing the drivers incorrectly though. Let me know if anybody has any ideas, I can post screen pictures (not screenshots as I can't launch GNOME).

  3. #3
    Join Date
    2016-Oct
    Posts
    15
    Hi Sunstandard IQ,

    Awesome handle ! I first encountered a slightly similar issue with the desktop interface not loading, can I just confirm that your issue is different from http://serverfault.com/questions/708...ot-boot-in-gui - I believe the chkconfig package is no longer in use but still worth a look I think.

    Moving on, do you have any errors in the xorg log? You can find this at /var/log/xorg.0.log.

    Tommo

  4. #4
    Join Date
    2016-Nov
    Posts
    5
    Much appreciated for your help. I will give it a look today after work. I will post back anything I find.

    Thank you

    EDIT 1:
    It seems I was able to bypass my problem temporarily and boot into the GNOME GUI. I was able to turn ACPI off from the GRUB loader using this guide.

    http://askubuntu.com/questions/16003...i-when-booting

    EDIT 2:
    Apparently I have two main Xorg logs. I have attached the files in a zip file.

    EDIT 3:
    I got it sorted out. It just took a lot of digging through. ACPI was a dead end because only way it helped was completely shutting off all ACPI, not even "acpi=ht" could get the GNOME GUI to boot. So basically my laptop was barely functioning with ACPI off because after learning more about ACPI, I learned its pretty vital for most laptops. The fix was to simply abandon utilizing my NVIDIA GPU for now and completely run off the Intel APU. Perhaps I will dig into further in the future. I simply removed any NVIDIA drivers I had installed and removed the 3rd party Nouveau drivers. Kali then recognized the built in Intel graphics.
    Attached Files Attached Files
    Last edited by Substandard IQ; 2016-11-11 at 15:03. Reason: Merge posts

  5. #5
    Join Date
    2016-Oct
    Posts
    15
    Hey,

    More than welcome and I'm pleased to hear you got things sort of working. That being said, it would still be nice to utilize the Nvidia card. I'm using Kali on a Pi and a fairly spec'd laptop although it only has a single Intel GPU so I've not had much hands on with Nvidia (or ATI / AMD). With everything working so far, have you tried installing the latest proprietary Nvidia drivers then switching back to the Nvidia card? I've not done this myself yet but a friend of mine had success with the guide at https://www.blackmoreops.com/2014/03...er-kali-linux/ although he installed using a GTX 970 on a desktop system.

    I'm supposed to be help somebody install Kali on their laptop during the week which has both an Intel and Nvidia chip - I'll keep a close eye on the process and see if there is anything in it that can help you with this last little bit

Similar Threads

  1. Kali + Hardware Compatibility Issues?
    By mbpmbpmbp in forum General Archive
    Replies: 2
    Last Post: 2015-12-05, 01:41
  2. Question regarding hardware compatibility
    By zlavic in forum General Archive
    Replies: 0
    Last Post: 2015-07-19, 10:55
  3. Hardware compatibility list
    By Ghost_Rider in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2014-05-12, 13:42

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •