I have a 32 bit installation of kali linux on a virtual machine from an arch linux host. I read the doc page for VirtualBox on docs.kali.org and ran

apt install virtualbox-guest-x11
to install guest utils. I then shut down the virtual machine and created a shared folder by running

vboxmanage sharedfolder add kali --name kali --hostpath ~/Virtualbox\ Shared\ Folders/kali --automount
on the host to create a shared folder. I then booted into the virtual machine and did not see any folders in /media besides cdrom directories. So I ran

mount -t vboxsf kali /media/kali
to manually mount it. But I was told there was no such shared folder.

Am I installing the guest utils right? I tried to install it through the virtualbox guest iso disk from virtualbox and running that, but I was told I needed to install linux-headers. When I tried

apt install linux-headers-`uname -r`
to install them I was told there was no such package.

Here is my /etc/apt/sources.list
deb http://http.kali.org/kali kali-rolling main contrib non-free
# For source package access, uncomment the following line
# deb-src http://http.kali.org/kali kali-rolling main contrib non-free
Here is the vboxadd-install.log from when I tried to install guest additions from the iso
/tmp/vbox.0/Makefile.include.header:97: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.  Stop.