Results 1 to 3 of 3

Thread: How to start Android tools like adb and fastboot?

  1. #1
    Join Date

    [SOLVED] How to start Android tools like adb and fastboot?

    Hey guys,

    I installed Kali last week to play with it. It runs pretty well, it feels very solid. And it is Debian :-) My last OS was Linux Mint (Nadja). I had the Android SDK installed lately, using adb and fastboot as root straight out of their folder. Now with Kali they won't start. Nowhere.

    I tried most I could think of: I updated and upgraded, I went into the platform-tools directory tried starting them from there, I tried with and without ./ as root and not as root... Nothing happend, it's always a No such file or directory error.
    Somewhere, I read that both .bashrc file(s) can fulfil my wettest dreams but after I put this line at the end, nothing happens:

    export PATH=${PATH}:/usr/share/android-sdk/tools:/usr/share/android-sdk/platform-tools
    This is actually the path where adb hangs around.

    Here's something funny:
    root@host:/usr/share/android-sdk/platform-tools# adb
    bash: /usr/share/android-sdk/platform-tools/adb: No such file or directory
    root@host:/usr/share/android-sdk/platform-tools# ls
    aapt  aidl  dexdump  fastboot  llvm-rs-cc  renderscript
    adb   api   dx       lib       NOTICE.txt
    What do I have to do?
    I can't start adb from the folder neither as user nor as root. I'm sure I missed something...
    Last edited by super_cat; 2013-04-27 at 16:15. Reason: solved

  2. #2
    Join Date
    Ah, meanwhile I figured it out. It wasn't my fault, here ist the Bug an a solution by glavcho in the bugtracker. Simply put this in the Terminal:

    dpkg --add-architecture i386
    apt-get update
    apt-get install ia32-libs
    apt-get install lib32ncurses5
    adb does work then. However, I encountered an error while pushing a custom ROM to my Nexus 7. It won't push when I was in the bootloader/fastboot mode, the error message was, that there is no such device. Since fastboot devices showed it, I booted in the TeamWin Recovery Project mod. Then I could adb push <zip> /sdcard/ - install it and boot the system.

    Maybe this helps someone else too

  3. #3
    Join Date
    LOL ran into same problem. lmk whats up?

Similar Threads

  1. [Nethunter] Unable to Start Bluetooth Service/Tools
    By LoveU in forum NetHunter General Questions
    Replies: 0
    Last Post: 2019-09-15, 21:47
  2. Replies: 0
    Last Post: 2014-09-15, 08:53

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts