Hello all,

I installed a fresh 3.0 build onto my nexus 6p, and have been playing with it helping hone my security skillz. I was curious about the badUSB so I started playing with it.

First I noticed that it would take forever and freeze my win 10 victim computer, and finally after about 2-3 minutes everything would function as it should (meaning a network adapter pops up).

Next I thought wow that was easy and tried to hit google to see if I had internet connection with it, and this is where I ran into problems.

I'm not able to hit any web pages although the victim computer says it's got network access. I then started to investigate what the issue might be.

I looked at the badusb.log, and got this:

HTML Code:
iptables v1.4.20
Ok so I'm not sure what's supposed to be in the log file.

Next I started looking for the config file for badUSB, and noticed that there are two scripts for it:

HTML Code:
So the question then becomes is there a difference in those two and the marshmallow version?

Also I installed chroot (the only metapackage I have is the 'kali-linux-nethuner') from the nethunter apk, and it's up to date on version 3.15.3.

Any help would be greatly appreciated,