Results 1 to 6 of 6

Thread: Raspberry Pi 3 problem with TL-WN722n WiFi Adapter (Atheros AR9271)

  1. #1
    Junior Member
    Join Date
    Nov 2016
    Posts
    2

    Question Raspberry Pi 3 problem with TL-WN722n WiFi Adapter (Atheros AR9271)

    Hello

    I'm trying to use my wifi adapter with TP Link TL-WN722n (Atheros AR9271) with freshly installed Kali (kali-2.1.2-rpi) on Rpi 3.
    What I did :

    apt-get update
    apt-get upgrade
    apt-get install firmware-atheros

    checked ifconfig & iwconfig, shows no wireless :

    Code:
    root@kali:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    lsusb shows adapter :

    Code:
    root@kali:~# lsusb
    Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    logs have following entries :
    Code:
    [    3.681027] usb 1-1.5: new high-speed USB device number 4 using dwc_otg
    [    3.829544] usb 1-1.5: New USB device found, idVendor=0cf3, idProduct=9271
    [    3.842395] usb 1-1.5: New USB device strings: Mfr=16, Product=32, SerialNumber=48
    [    3.857865] usb 1-1.5: Product: USB2.0 WLAN
    [    3.866252] usb 1-1.5: Manufacturer: ATHEROS
    [    3.874740] usb 1-1.5: SerialNumber: 12345
    tried doing modprobe

    Code:
    root@kali:/lib/modules# modprobe ath9k_htc
    modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.1.19-v7+/modules.dep.bin'
    modprobe: FATAL: Module ath9k_htc not found in directory /lib/modules/4.1.19-v7+
    /lib/modules/ only contains 4.1.19 directory

    Code:
    root@kali:/# ls -ls /lib/modules/
    total 4
    4 drwxr-xr-x 3 root root 4096 Dec  3 17:17 4.1.19

    OS (via uname) :
    Linux kali 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux

    Any advice or help would be highly appreciated !
    Last edited by kachevan.op; 2016-12-04 at 11:45 AM.

  2. #2
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    118
    Hi kachevan.op,

    The TP Link TL-WN722n should work out of the box, no need to install additional firmware.
    I just did a fresh install and plugged it in. It got picked up straight away and I could connect to my local WiFi.
    Why don't you try again without installing the firmware package?

    Hope hat helps,
    Re4son
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  3. #3
    Junior Member
    Join Date
    Nov 2016
    Posts
    2
    Quote Originally Posted by re4son View Post
    Hi kachevan.op,

    The TP Link TL-WN722n should work out of the box, no need to install additional firmware.
    I just did a fresh install and plugged it in. It got picked up straight away and I could connect to my local WiFi.
    Why don't you try again without installing the firmware package?

    Hope hat helps,
    Re4son
    Thanks for the reply !
    Just tried, this is from newly installed image (no updates, nothing):

    Code:
    root@kali:~# iwconfig 
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    root@kali:~# lsusb 
    Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    root@kali:~# uname -r
    4.1.19-v7+

    Can this be a problem with the image ?
    I've noticed on your website that you use kali-2.0.1-rpi2.img I use kali-2.1.2-rpi.img

    Also could you kindly say what is your linux version, does it have -v7+ ?

    So embarrassing :

    I've just realised I've being using wrong image all the time !
    Used kali-2.1.2-rpi instead of kali-2.1.2-rpi2...

    I will have to try the correct image.

    With the correct image everything is working just fine.

    Dear mods can you please delete this thread ?
    Last edited by sickn3ss; 2016-12-04 at 01:00 PM.

  4. #4
    Junior Member
    Join Date
    Oct 2017
    Posts
    1
    Even I am using Kali 2.1.2 rpi2 on raspberry pi 3 but the adapter is not working.

  5. #5
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    118
    I'd update to Kali 2017.2 before going any further.
    Do you know which HW version of TL-WN722n you are using? The above threat was dealing with version 1 (Atheros) but you might have the other one using a Realtek chipset. That one's known to cause a little grief.
    These links might help to identify the version:
    https://wikidevi.com/wiki/TP-LINK_TL-WN722N
    https://wikidevi.com/wiki/TP-LINK_TL-WN722N_v2
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  6. #6
    Junior Member
    Join Date
    Oct 2017
    Posts
    2
    Same problem for me with the unofficial Kali 2017.2 Re4son kernel

    root@kali:~# uname -r
    4.9.41-Re4son-v7+

    root@kali:~# ^C
    root@kali:~# lsusb
    Bus 001 Device 005: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
    Bus 001 Device 004: ID 04f2:0116 Chicony Electronics Co., Ltd KU-2971/KU-0325 Keyboard
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    dmesg

    2.682786] usb 1-1.4: new high-speed USB device number 5 using dwc_otg
    [ 2.843241] usb 1-1.4: New USB device found, idVendor=0cf3, idProduct=9271
    [ 2.844470] usb 1-1.4: New USB device strings: Mfr=16, Product=32, SerialNumber=48
    [ 2.846830] usb 1-1.4: Product: USB2.0 WLAN
    [ 2.847995] usb 1-1.4: Manufacturer: ATHEROS
    [ 2.849113] usb 1-1.4: SerialNumber: 12345
    [ 2.929993] brcmfmac: loading out-of-tree module taints kernel.
    [ 2.929995] brcmfmac: loading out-of-tree module taints kernel.
    [ 2.943654] usbcore: registered new interface driver brcmfmac
    [ 3.186134] usb 1-1.4: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
    [ 3.188353] usb 1-1.4: Direct firmware load for ath9k_htc/htc_9271-1.4.0.fw failed with error -2
    [ 3.190693] usb 1-1.4: ath9k_htc: Firmware htc_9271.fw requested
    [ 3.191989] usb 1-1.4: Direct firmware load for htc_9271.fw failed with error -2
    [ 3.194146] usbcore: registered new interface driver ath9k_htc
    [ 3.195335] usb 1-1.4: no suitable firmware found!
    [ 3.196433] usb 1-1.4: ath9k_htc: Failed to get firmware htc_9271.fw
    [ 3.198148] usb 1-1.4: ath9k_htc: USB layer deinitialized

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •