Results 1 to 3 of 3

Thread: Getting mitmf to function in kali-linux R2

  1. #1
    Join Date
    2013-Jul
    Posts
    841

    Getting mitmf to function in kali-linux R2

    First install mitmf

    Get an internet connection open a terminal window and type

    apt-get install mitmf

    After installation the help file will work BUT:

    If you run it against a target in kali-linux rolling R2 you will get a mitmf screen loaded with attrib, unable to load and line errors.

    Currently there seems to be a problem with mitmf and Twisted 16.3.0

    You need to downgrade to Twisted 15.5.0

    Get an internet connection

    Open a terminal window and type:

    pip uninstall Twisted

    Follow prompts and once uninstalled

    Enter

    pip install Twisted==15.5.0

    mitmf will now function

    You will be prompted to upgrade thru

    pip install --upgrade Twisted

    DO NOT do this as it will simply return the distribution to the newer version which does not work and you will be back to an error filled mitmf screen.

    You will also be prompted to upgrade pip but MTeams thought that was a Bridge too far and left it alone.

    Musket Team Labs
    Last edited by mmusket33; 2016-12-11 at 10:59.

  2. #2
    Join Date
    2013-Jul
    Posts
    841
    The above operations DO NOT work when using a persistent usb install of kali-linux R2.

    Musket Teams

  3. #3
    Join Date
    2015-Aug
    Posts
    16
    I just wanted to add my .02 here because it's so nice to see that sergio-proxy got the 'Steve Austin' upgrade.....

    I had issues with the instructions above at 'pip uninstall Twisted' (version 16.6.0) there were error messages about 'outside environment /usr'.

    There was some fruitless internet searching about properly removing global pip modules but at the end of the day I just moved the '/usr/lib/python2.7/dist-packages/twisted' folder and '/usr/lib/python2.7/dist-packages/Twisted-16.6.0.egg-info' file to a backup folder of my creation at '/root/TwistedBU'

    I confirmed uninstall with 'pip show twisted' and followed up with 'pip install Twisted==15.5.0'

    After this things worked perfectly, so I of course didn't stop there.

    I uninstalled twisted 15.5.0 with 'pip uninstall Twisted' (I had no problems here) and restored the 16.6.0 files. I was concerned there may be other dependencies or that a future upgrade might cause issues so decided to install from .git with the virtual environment.

    I then removed mitmf with 'apt-get remove mitmf'

    From here I followed the instructions on the .git page...
    https://github.com/byt3bl33d3r/MITMf/wiki/Installation
    ...and once again wound up with a perfectly working version at '/root/MITMf/mitmf.py'.

    Having to be inside the folder annoyed me and having the folder in the wrong location upset my OCD so time to break things again.

    I moved the '/root/MITMf' folder to '/usr/local/lib/' so that it would be in the 'right place' and sim linked mitmf.py to '/usr/local/bin/mitmf' with 'ln -s /usr/local/lib/MITMf/mitmf.py /usr/local/bin/mitmf'

    And finally, so I wouldn't have to change folder locations, I edited mitmf.py with

    'os.chdir('/usr/local/lib/MITMf')' right after 'The derp is strong....' line.

    Now my OCD is happy, my local installs are all in the same place, and wherever I go I'm in the middle....

    root@host:/mitmf -i .......

    Admittedly this is probably a little hacky, but so am I. Open thanks to all who did such a nice job with this framework.

Similar Threads

  1. Replies: 4
    Last Post: 2017-05-19, 13:49
  2. Power options and close lid function
    By voovode in forum General Archive
    Replies: 0
    Last Post: 2013-03-27, 16:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •