Hi there !
If I close my laptop lid or just press the power button, the system go to sleep. However if after the system is asleep i try to open the lid again or press the power button again, I got a total black screen (not even backlight).
I tried the Ctrl + Alt + F1 to enter the TTY : the screen is switch on but i got a corrupted image. (like colorful straight vertical line all over the screen).
I tried using the pm-suspend utility without much success.
The system is still functionning while I got the black screen (the caps lock led still work).

I am working on a Asus UX306UA with the lastest Kali 64bits, installed in dual boot with Ubuntu. My Kali installation is encrypted.

Moreover, from the xorg's logs file in /var/logs/Xorg.1.log there is strange error from the gnome-shell application. So I suspect gdm3 to be the source of the problem. The errors looks like the following and seems to occur when the system is waking up from sleep :
Dec 17 16:46:23 Bluffi org.gnome.Shell.desktop[1183]: (gnome-shell:1183): St-CRITICAL **: st_widget_get_theme_node called on the widget [0x1204fe40 Gjs_DashItemContainer.dash-item-container] which is not in the stage.
I already updated all the package from Kali repositories.

The uname -a command returns :
Linux Bluffi 4.6.0-kali1-amd64 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) x86_64 GNU/Linux
The lsb_release -a command returns:
No LSB modules are available
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: kali-rolling
Codename: kali-rolling
The command lspci | grep VGA returns :
00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)

Thanks :/