Results 1 to 3 of 3

Thread: dpkg returned error code 1 - unpack failed

  1. #1
    Join Date
    2016-Dec
    Posts
    1

    Exclamation dpkg returned error code 1 - unpack failed

    Hello,

    I am new to Linux, at this point I have successfully installed Nethunter 3.15 on my Nexus 7.
    Actually I am facing a problem when executing apt-get upgrade --> base-files_1%3a2016.2.2_armhf.deb --> unable to unpack
    I tried already everything I found on the forum - forced install, purge remove, nothing worked, I am even not able to remove the file Nethunter says package is essential and not able to remove...... I am somehow stucked and really need help

    Thanks for providing suggesting how to proceed

    Chimera

    Code:
    Kali GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    root@kali:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... The following packages were automatically installed and are no longer required:
    * libcanberra-gtk3-0 libcanberra-gtk3-module libegl1-mesa-drivers libelfg0
    * libopenvg1-mesa libperl4-corelibs-perl python-support ruby-yajl
    Use 'apt-get autoremove' to remove them.
    Done
    The following packages have been kept back:
    * adwaita-icon-theme apache2 apache2-bin apache2-data apache2-utils apt
    * zlib1g-dev
    561 upgraded, 0 newly installed, 0 to remove and 369 not upgraded.
    Need to get 0 B/288 MB of archives.
    After this operation, 50.1 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    cat: /sys/bus/usb/devices/*:*/bInterfaceClass: No such file or directory
    cat: /sys/bus/usb/devices/*:*/bInterfaceSubClass: No such file or directory
    cat: /sys/bus/usb/devices/*:*/bInterfaceProtocol: No such file or directory
    supported-versions: WARNING! Unknown distribution: kali
    debian found in ID_LIKE, treating as Debian
    supported-versions: WARNING: Unknown Debian release: 2.0
    dpkg: error processing archive /var/cache/apt/archives/base-files_1%3a2016.2.2_armhf.deb (--unpack): subprocess rm command for cleanup was killed by signal (Segmentation fault)
    Errors were encountered while processing:
    /var/cache/apt/archives/base-files_1%3a2016.2.2_armhf.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@kali:~#

  2. #2
    Join Date
    2016-Nov
    Posts
    3
    /var/cache/apt/archives/base-files_1%3a2016.2.2_armhf.deb

    This package name is libgcc1.
    This is the reason for libgcc1 package working on background.

    You must try "apt-get install libgcc1 -y" to solve this error.

    İf you install a package, that package is stops and reinstalls that package.
    İf that package is stop, upgrade is be successfully.

    Try and tell me. "Is it working ?"

  3. #3
    Join Date
    2016-Jul
    Posts
    4

    Cool support-versions:WARNING! Unknown Debian release:2.0

    Quote Originally Posted by chimera123 View Post
    Hello,

    I am new to Linux, at this point I have successfully installed Nethunter 3.15 on my Nexus 7.
    Actually I am facing a problem when executing apt-get upgrade --> base-files_1%3a2016.2.2_armhf.deb --> unable to unpack
    I tried already everything I found on the forum - forced install, purge remove, nothing worked, I am even not able to remove the file Nethunter says package is essential and not able to remove...... I am somehow stucked and really need help

    Thanks for providing suggesting how to proceed

    Chimera

    Code:
    Kali GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    root@kali:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... The following packages were automatically installed and are no longer required:
    * libcanberra-gtk3-0 libcanberra-gtk3-module libegl1-mesa-drivers libelfg0
    * libopenvg1-mesa libperl4-corelibs-perl python-support ruby-yajl
    Use 'apt-get autoremove' to remove them.
    Done
    The following packages have been kept back:
    * adwaita-icon-theme apache2 apache2-bin apache2-data apache2-utils apt
    * zlib1g-dev
    561 upgraded, 0 newly installed, 0 to remove and 369 not upgraded.
    Need to get 0 B/288 MB of archives.
    After this operation, 50.1 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    cat: /sys/bus/usb/devices/*:*/bInterfaceClass: No such file or directory
    cat: /sys/bus/usb/devices/*:*/bInterfaceSubClass: No such file or directory
    cat: /sys/bus/usb/devices/*:*/bInterfaceProtocol: No such file or directory
    debian found in ID_LIKE, treating as Debian
    supported-versions: WARNING: Unknown Debian release: 2.0
    dpkg: error processing archive /var/cache/apt/archives/base-files_1%3a2016.2.2_armhf.deb (--unpack): subprocess rm command for cleanup was killed by signal (Segmentation fault)
    Errors were encountered while processing:
    /var/cache/apt/archives/base-files_1%3a2016.2.2_armhf.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@kali:~#

    The command is:

    # wget https://http.kali.org/kali/pool/main...2018.1_all.deb


    #dpkg -i kali-archive-keyring_2018.1_all.deb

    #apt update && apt upgrade

    Hope it helps

Similar Threads

  1. dpkg returned an error code (1)
    By discipuloosho in forum NetHunter General Questions
    Replies: 1
    Last Post: 2016-03-01, 21:26
  2. Sub-process /usr/bin/dpkg returned an error code (1)
    By iceman_3233 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-03-04, 19:10
  3. Sub-process /usr/bin/dpkg returned an error code (1)
    By gio__gio in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-07-21, 08:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •