Results 1 to 3 of 3

Thread: Black screen when booting Kali Live USB on Mac

  1. #1
    Join Date
    2017-Jan
    Posts
    1

    Black screen when booting Kali Live USB on Mac

    hey guys, I have a 2015 MacBook Pro 13 inch taht im trying to use with a Kali live usb that ive made using the dd command. I have followed all the instructions given by Kali's official documentation on how to make a usb in Mac OSX, but when i try to boot off of the USB, I get a black screen! I tried editing syslinux.cfg from vesamenu.cfg to menu.cfg, but i still get the same result. What do you guys think I should do to make it work and load at least the boot menu?

  2. #2
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    1,012
    There must be no EFI boot files in your bootable USB. Do you see any directory with /EFI/BOOT folder?

  3. #3
    I am having the same issue. What's odd is the very first time I tried booting into Kali Live using rEFInd, it worked. Booted into Live Kali no problem. However, when I restarted and tried booting back into Kali Live off of my USB stick, rEFInd hit me with "Not Found while loading legacy loader", and if I tried booting using "syslinux.efi", my MacBook would just boot to a black screen, and freeze.

    Using MacBook Pro (Retina, 13-inch, Early 2015) on OS X "Sierra" 10.12.2 (16C67) and a Samsung MUF-16BA/AM USB drive.

Similar Threads

  1. Kali booting into black screen
    By Mikey in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-02-03, 17:05
  2. Replies: 0
    Last Post: 2014-07-23, 13:46

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •