Results 1 to 3 of 3

Thread: Pyrit errors after Dist-Upgrade Fix

  1. #1
    Join Date
    2016-Feb
    Posts
    14

    Pyrit errors after Dist-Upgrade Fix

    I experienced the following error after upgrading my Kali distribution when I tried to run Pyrit:

    Code:
    Traceback (most recent call last):
      File "/usr/bin/pyrit", line 6, in <module>
        pyrit_cli.Pyrit_CLI().initFromArgv()
      File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 115, in initFromArgv
        func(self, **options)
      File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 163, in new_f
        f(*args, **kwds)
      File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 447, in analyze
        parser = self._getParser(capturefile)
      File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 179, in _getParser
        parser.parse_pcapdevice(dev)
      File "/usr/lib/python2.7/dist-packages/cpyrit/pckttools.py", line 601, in parse_pcapdevice
        self.parse_packet(pckt)
      File "/usr/lib/python2.7/dist-packages/cpyrit/pckttools.py", line 614, in parse_packet
        if dot11_pckt.isFlagSet('type', 'Control'):
      File "/usr/lib/python2.7/dist-packages/cpyrit/pckttools.py", line 66, in isFlagSet
        return (1 << field.names.index([value])) & self.__getattr__(name) != 0
    AttributeError: 'BitEnumField' object has no attribute 'names'
    I was able to fix this issue by uninstalling Scapy 2.3.3 that was included in the upgrade and downgrading to Scapy 2.3.2.

    You can download Scapy 2.3.2 at https://github.com/secdev/scapy/archive/v2.3.2.zip. Unpack and run the following in a terminal window in the same directory you unpacked the files in (that contains the file setup.py):

    Code:
    sudo python setup.py install
    After doing this Pyrit ran fine.

    Hope this helps.

    G3Cube

  2. #2
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    758
    Thanks for posting the fix Was having this trouble with Pyrit, too.

  3. #3
    Join Date
    2016-Dec
    Posts
    1

    Downgrade worked. Now how to undo it?

    Your suggestion to downgrade Scapy, worked. It immediately fixed the problem with Pyrit.
    Thanks!

    But now that Pyrit has been updated.... how would I undo the Scapy downgrade?
    (And again allow automatic updates from this day forward.)



    Quote Originally Posted by G3Cube View Post
    I experienced the following error after upgrading my Kali distribution when I tried to run Pyrit:

    Code:
    Traceback (most recent call last):
      File "/usr/bin/pyrit", line 6, in <module>
        pyrit_cli.Pyrit_CLI().initFromArgv()
      File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 115, in initFromArgv
        func(self, **options)
      File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 163, in new_f
        f(*args, **kwds)
      File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 447, in analyze
        parser = self._getParser(capturefile)
      File "/usr/lib/python2.7/dist-packages/pyrit_cli.py", line 179, in _getParser
        parser.parse_pcapdevice(dev)
      File "/usr/lib/python2.7/dist-packages/cpyrit/pckttools.py", line 601, in parse_pcapdevice
        self.parse_packet(pckt)
      File "/usr/lib/python2.7/dist-packages/cpyrit/pckttools.py", line 614, in parse_packet
        if dot11_pckt.isFlagSet('type', 'Control'):
      File "/usr/lib/python2.7/dist-packages/cpyrit/pckttools.py", line 66, in isFlagSet
        return (1 << field.names.index([value])) & self.__getattr__(name) != 0
    AttributeError: 'BitEnumField' object has no attribute 'names'
    I was able to fix this issue by uninstalling Scapy 2.3.3 that was included in the upgrade and downgrading to Scapy 2.3.2.

    You can download Scapy 2.3.2 at https://github.com/secdev/scapy/archive/v2.3.2.zip. Unpack and run the following in a terminal window in the same directory you unpacked the files in (that contains the file setup.py):

    Code:
    sudo python setup.py install
    After doing this Pyrit ran fine.

    Hope this helps.

    G3Cube

Similar Threads

  1. cant login 4.12.0-kali1-amd64 after dist-upgrade with errors
    By latam in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-09-15, 22:33
  2. Replies: 5
    Last Post: 2016-09-30, 14:19
  3. apt-get dist-upgrade errors
    By bryceantony in forum TroubleShooting Archive
    Replies: 7
    Last Post: 2016-03-10, 23:44
  4. Replies: 0
    Last Post: 2015-08-22, 09:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •