Results 1 to 2 of 2

Thread: cannot use airmon-ng ( no interface ) and no wlan0 in ifconfig, only eth0 and lo

  1. #1
    Join Date
    2017-Jan
    Posts
    1

    cannot use airmon-ng ( no interface ) and no wlan0 in ifconfig, only eth0 and lo

    so i tried installing kali linux on 2 different laptop , using VMware and VirtualBox , still no luck , when i type iwconfig it says : [ lo : no wireless extension , eth0 : no wireless connection ] but i am connected !(with wireless)

    in all of them , there is no wlan0 when i type ifconfig, only eth0 and lo , even tho i am connected to the internet using kali linux
    and also there is no interface in airmon-ng

    i tried installing wireless compat
    , after installing it i did get wlan0 and wlan1 in the ifconfig, but they seemed like some fake thing , considering i couldnt find any wireless around using airmon-ng , it almost felt like all this wireless compat did was give me some fake names in ifconfigbut nothing real



    i also tried my laptop's own wireless chipset and also tried tplink 722N as some people suggested , non of which helped and i still cannot use airmon-ng

    tried using bridge instead of NAT , still no luck , tried adding my wireless adapter (722N) in the USB section of virtualbox too and still didnt work


    i have to say that i am connected to the internet using my laptop's wireless even when using kali , but i cannot see any wlan0 or interface , its almost like i have no wireless connection but i'm somehow connected to the internet


    help please

  2. #2
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    1,012
    Virtual machines only show the output of virtual interface and not your actual hardware. You can configure them from the built-in options in virtual machines(settings<USB).

    I'm sorry my information didn't help much. I don't use virtual machines but they are plenty of threads how to run airmon-ng in VMware if you search.

    Compat wireless were made to provide wireless support for older kernel version. Compat wireless are no longer developed. Their latest version has new name called backports. You have latest kernel version so you don't need either of them.

Similar Threads

  1. ifconfig shows wlan0 but airmon-ng won't start it
    By rpilover in forum General Archive
    Replies: 5
    Last Post: 2014-01-24, 02:10
  2. Replies: 8
    Last Post: 2013-10-28, 23:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •