Results 1 to 6 of 6

Thread: Monitor Mode Issue With Virtualbox

  1. #1
    Join Date

    Monitor Mode Issue With Virtualbox


    I have installed virtualbox with Kali 2016.2, the system powers up great but when I attempted to use Xerosploit there was no IP addresses being discovered. I then attempted to sniff using ettercap but had the exact same results, nothing showing apart from my virtualbox IP. I then tried to enter monitor mode using the command airmon-ng start wlan0 (I killed the processes that needed to be) but the same negative results occurred. This is the exact result I get when I attempt to enter monitor mode.

    root@kali:~# airmon-ng start wlan0
    ls: cannot access '/sys/class/ieee80211/': No such file or directory
    PHY	Interface	Driver		Chipset
    My network card is a Killer 1535. At first I presumed that the issue was occurring because my network card was not compatible, or missing the correct needed drivers. So I decided to plug in my USB Alfa Network 802.11n, I know that this USB network card is compatible with Kali because I have used it in the past. Through this I have discovered that is issue must be with the fact that I am running Kali through virtualbox, but from my understanding USB network cards work fine with virtualbox.

    I am confused as to why this is happening, I would greatly appreciate any help and information.


  2. #2
    Are you sure you enabled the 'Killer 1535' by clicking the little blue usb icon at the bottom right of the vbox window? Make sure it's not greyed out. Does it show up in dmesg?

  3. #3
    Join Date
    My Killer 1535 in my network card and my Alfa network 802.11n is the USB. When I checked the bottom right of the screen both the network and USB are activated and not greyed out.

    I managed to get monitor mode enabled using my USB by going to devices at the top of the Kali screen, opeining USB and picking the device. But when I activate my USB my Killer network card goes down on my main OS and Kali virtualbox. I have no internet access at all but can enter monitor mode. Although I can now enter monitor mode with the USB, I can not sniff or pick up any hosts in ettercap. Also, when I run xerosploit I can not pick up any IP's attached to my network when I know there is a few attatched, I only pick up the IP of my virtualbox. This same issue occurs whether I use my Killer network card or the USB?!

    Do you or anyone have any ideas to why this issue may be occuring...any help and advice is greatly appreaciated!

  4. #4
    Now I see, the Killer is an internal PCI or PCI-E wifi card.

    1. Virtualbox will not be able to use it with monitor mode. Only USB cards work in that case.

    2. You can use the internal card with ettercap, but you musr switch the card to bridged mode so it will get an ip address that is on your home network.

  5. #5
    Join Date
    Thank you for the reply and help. I managed to get my USB wifi working but I am not having trouble with ettercap. When I perform ARP poisoning, my victim loses their connection to the Internet and I do not have a clue why?

  6. #6
    What is the command line that you used?

Similar Threads

  1. Alfa AWUS036ACH on kali 2017.1 monitor mode issue
    By superbosu in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2017-08-30, 03:19
  2. D-Link DWA-182 Rev C1 does not enable monitor mode in VirtualBox
    By rowaraujo in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-11-12, 22:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts