Results 1 to 3 of 3

Thread: Nexus 5 - HID never worked

  1. #1
    Junior Member
    Join Date
    Aug 2016

    Nexus 5 - HID never worked

    Hi - any idea where to start troubleshooting ?

    Cant use any of the HID features, i tried with/without USB debugging, with/without MTP.

  2. #2
    On my Nexus 6 I had to enable Y-cable Charging to get it to work. If open NetHunter and on the home page under HID Interfaces you see something like "No HID devices detected" try going into Kali Services and enable the Y-cable charging. Then back on the home screen you hopefully will see devices under HID Interfaces. I see: /dev/hidg0 and /dev/hidg1, your's may differ. If that worked you should be good to go. I've only tested with USB debugging enable but I don't believe that will matter. To test, connect to you puter, open notepad or similar, on your Nexus open Duckhunter HID and run the Hello World preset. If it's working you'll see it writing what's coded in that script. Hope that helps.

    UPDATE: Forgot to mention, if the steps I described didn't work you may not have the proper kernel flashed. Get the appropriate kernel image for your device from the rolling release and flash that with TWRP then try again.
    Last edited by maiki; 2017-01-24 at 10:01 AM. Reason: Merge posts

  3. #3
    Junior Member
    Join Date
    Nov 2015
    can you see your interfaces in dev? try the below in kali cmd

    ls /dev/hid*

    you should see something like:


    if you don't see any interfaces try the below command in androidsu cmd

    setprop sys.usb.config hid

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts