Results 1 to 2 of 2

Thread: OnePlus One install issues

  1. #1
    Join Date

    OnePlus One install issues

    I have searched and I see I am creating another duplicate thread, which I am loathe to do, but I am hoping I can get the proper process and edit this post to turn it into a sticky with the correct process for installing on an OPO (or at least a cautionary tale of what not to do..).

    I wiped my (previously rooted/unlocked) phone, installed CM13.0-20161220, Open GApps arm 6.0-mini-20170115, SuperSU v2.79-201612051815. Booted up, did initial config.

    Installed MultiROM manager and let it install TWRP version 3.0.2-02016-04-17 p1, and the kernel 6.0.x with kexec-hardboot patch.

    Using TWRP I added a secondary ROM, using CM13.0-20161220, Open GApps, SuperSU again, booted up, did initial log in.

    Following the instructions from I downloaded

    I also got from the nightlys

    Immediately this seems wrong to me, that the image is lollipop, but the image/kernel are Marshmallow. Is this my issue, that I am being ridiculous trying to use these together, and if so, is there a nethunter release for Marshmallow, or do I need to build it?

    When I attempt using the above combination of files.. Attempting to install on top of the CM13.0 ROM results in "Repacking image failed. Aborting..." towards the end. I see this is part of the AnyKernel2 installer. Trying to boot at this point doesn't work, and it's stuck in a boot loop. Is this where the statement "you are trying to install an image for the wrong Android version idiot!" goes?

    Reflashing the CM13.0 image over the top gets it booting again. I have tried again, installing the nethunter image over the top, followed by either the minimal or full kalifs images, and then installing the kernel, then the update.

    This gets the phone into a bootable/usable state, but then I am having issues with NetHunter app, and the Chroot manager, which finds the chroot, but is unable to update, nor find my terminal app etc. Attempting to install the APKs manually just results in "app not installed".

    I can manually use the terminal app to su/bootkali, and after turning off the PATH verification, can successfully apt-get update and dist-upgrade etc, but this still doesn't fix the issue of "error launching intent install android terminal" etc.

    That's the issue I am stuck on, and I can't seem to work out how to uninstall/reinstall the terminal or term-nh to fix this.

  2. #2
    Join Date
    Notice how you downloaded the wrong image. It says Lollipop in it, while the kernel you're using is Marshmallow. That's why you have a boot loop.

Similar Threads

  1. OnePlus 6/6t install
    By Vlad Chocolate in forum Installing NetHunter
    Replies: 1
    Last Post: 2022-07-23, 14:26
  2. Oneplus 7 pro install
    By sgraham045 in forum Installing NetHunter
    Replies: 3
    Last Post: 2022-05-12, 20:53
  3. installation issues for oneplus 7 pro
    By aero_dreams in forum Installing NetHunter
    Replies: 1
    Last Post: 2020-04-12, 21:00
  4. WN722N issues on OnePlus 3T
    By Zeroclick in forum NetHunter General Questions
    Replies: 0
    Last Post: 2020-04-07, 09:26
  5. Replies: 1
    Last Post: 2015-01-01, 19:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts