Results 1 to 4 of 4

Thread: Select package version with apt get installation

  1. #1
    Junior Member
    Join Date
    Nov 2016
    Posts
    22

    Select package version with apt get installation

    As in the title I'll need to download and install a package via "apt-get install" command but need to specify the version, here's the question:
    I need to install the Nvidia cuda toolkit package.
    If I issue "apt-get install Nvidia toolkit" it install the last version of this package(version 8)....I need the 6.5... There's a way to specify the version I want when performing apt-get command ?..... I've tried "apt-get install Nvidia toolkit-6.5" but nothing .....Any suggestions about it?
    P.s. I'm a newbie so be patience, all this stuffs is needed for letting me run cpyrit with Cuda support
    Thanks!

  2. #2
    Junior Member
    Join Date
    Jan 2017
    Posts
    2
    Quote Originally Posted by itanon View Post
    As in the title I'll need to download and install a package via "apt-get install" command but need to specify the version, here's the question:
    I need to install the Nvidia cuda toolkit package.
    If I issue "apt-get install Nvidia toolkit" it install the last version of this package(version 8)....I need the 6.5... There's a way to specify the version I want when performing apt-get command ?..... I've tried "apt-get install Nvidia toolkit-6.5" but nothing .....Any suggestions about it?
    P.s. I'm a newbie so be patience, all this stuffs is needed for letting me run cpyrit with Cuda support
    Thanks!
    apt search nvidia

  3. #3
    Junior Member
    Join Date
    Nov 2016
    Posts
    22
    Quote Originally Posted by makkwong View Post
    apt search nvidia
    Thanks I'll try this way

  4. #4
    Junior Member
    Join Date
    Oct 2013
    Posts
    9
    Code:
    root@kali:~# uname -a
    Linux kali 4.6.0-kali1-amd64 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) x86_64 GNU/Linux
    root@kali:~#
    Code:
    root@kali:~# lspci -v | egrep -i 'vga|3d|nvidia' | grep -i 'nvidia'
    01:00.0 VGA compatible controller: NVIDIA Corporation G96GLM [Quadro FX 770M] (rev a1) (prog-if 00 [VGA controller])
    root@kali:~#
    Code:
    root@kali:~# apt search nvidia
    Sorting... Done
    Full Text Search... Done
    firmware-misc-nonfree/now 20160712-0kali1 all [installed,local]
      Binary firmware for various drivers in the Linux kernel
    
    libvdpau1/now 1.1.1-3 amd64 [installed,local]
      Video Decode and Presentation API for Unix (libraries)
    
    pyrit/now 0.4.0-7 amd64 [installed,local]
      GPGPU-driven WPA/WPA2-PSK key cracker
    
    truecrack/now 3.0-1kali0 amd64 [installed,local]
      Bruteforce password cracker for TrueCrypt volumes.
    
    vdpau-driver-all/now 1.1.1-3 amd64 [installed,local]
      Video Decode and Presentation API for Unix (driver metapackage)
    
    xserver-xorg-video-nouveau/now 1:1.0.12-2 amd64 [installed,local]
      X.Org X server -- Nouveau display driver
    
    root@kali:~#
    which one should I install?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •