Results 1 to 3 of 3

Thread: G2LDR.mbr Missing or Corrupt Error code: 0xc000007b

  1. #1
    Join Date

    G2LDR.mbr Missing or Corrupt Error code: 0xc000007b

    Hello, recently my HDD with my Kali installation on it decided to die so now I have my new HDD, I went to install Kali Linux.
    I followed my usual process of created a bootable USB/CD and booting from it to install. However, this time I was unable to do that. I created a bootable USB but when I went to boot from it, the screen stayed black, After about 20 minutes, I rebooted back into Windows and checked the ISO making sure it wasn't corrupt. That is when I noticed the ISO contains different files to the ISO I used to have.

    I saw a 'setup.exe' file on the USB drive so I tried running that and it came up with the Debian-Installer. I followed the process until I had to reboot. After rebooting I chose the boot option to continue installation. The screen stayed black for about a minute then a screen popped up saying "Windows failed to start". According to that screen, the g2ldr.mbr file is missing or corrupt. I have checked it the file is present on the HDD in the root of the C drive along with the other win32 files created by the installer.

    I have tried many different solutions but none have worked. I have tried disabling secure boot and enabling legacy mode but it displays the exact same error. I also tried the same ISO on my other PC and it worked fine so I know the error is with my PC. I saw that it could be the Windows Boot Record thing so I used a Windows 10 (the OS I have) disc to fix the MBR and things but the same errors appears when trying to install Kali.

    I don't know what else to try because I have never seen a Kali Linux ISO that contains these files before... They have always contained EFI/BOOT files but they seem to be gone now?

    Is there a new process required to install?

    EDIT: I managed to get this to boot from USB but after the installation, I saw my HDD had been partitioned how it needed to be but no files were written to the drive...

    Attached Images Attached Images
    Last edited by JoshG456; 2017-01-22 at 22:20.

  2. #2
    Join Date
    Managed to fix this and get it all working now so this can be closed/removed.

  3. #3
    Join Date
    Quote Originally Posted by JoshG456 View Post
    Managed to fix this and get it all working now so this can be closed/removed.
    Mind telling others how did you fix it?Threads are never removed and closed because they can be helpful for others.

Similar Threads

  1. Replies: 0
    Last Post: 2017-10-20, 01:42
  2. Error starting Live USB - XZ-compressed data is corrupt
    By hackin88 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2015-06-04, 15:29
  3. invalid or corrupt kernel image error.
    By kaganco in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2014-05-26, 12:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts