Results 1 to 3 of 3

Thread: Error: pkgacquire::run (13: keine berechtigung ) ndiswrapper driver-install

  1. #1
    Join Date

    Angry Error: pkgacquire::run (13: keine berechtigung ) ndiswrapper driver-install


    a few days ago, I've become an old Notebook for free because it wasn't used since years and i wanted to try some stuff with Kali-Linux without using my "official" PC with Windows 10.

    This old Notebook is a Fujitsu Siemens Amilo Xa 2528. The WLAN-card, that was installed there, when it was purchased (WLAN-Card SIS163U; i googled so far, because i couldn't find out by using the commandline after installing Kali 2016.2) is not supported by linux and the only existing drivers are for Windows XP (i have them on a stick).

    So after looking for a solution with google for a while, i tried to use ndiswrapper to install the XP-driver. (So far, the Notebook has no Internet, i download everything on my "official" PC and transfer it with a stick).
    I downloaded the following modules:
    dkms; ndiswrapper-utils-1.9; ndiswrapper-common; ndisgtk; ndiswrapper-dkms; gksu

    While dkms and gksu where allready installed, the installation of the rest ends with : pkgacquire::run (13: keine berechtigung ) and that _apt user has no rights for doing this.
    When i try to reinstall the packages it says, that there are allready installed.

    When i try to install the driver with ndisgtk, it says, 1 fitting hardware was found, but the installation aborts with the information: ndiswrapper-module couldn't be found.
    And the WLAN-card is still not working.

    Has somebody an idea, what goes wrong there?

    I would also by another WLAN-Card, but i would prefer to fix the problem with ndiswrapper (it isn't the money, but I'm simply pised off by trying it for hours, and it would be much more sattisfying to make it work)

  2. #2
    Join Date
    Can you upload the output of rfkill list all?

  3. #3
    Join Date
    Linux-Pakete.jpgThe output of rfkill list all is simply nothing (tested it with rfkill list all >> fkill.txt as root, result is an empty txt-file).
    Since the start of the Thread i come to the following reasons (maybe):
    part of the install-log of ndiswrapper is an kernel-error, which seems to mean, that there is no Kernel-header for the 4.6-Kernel.

    Here is the output from the installation:

    root@Marcus-Kali:/media/marcus/UltraFlat/Fujitsu Treiber Problem/ndiswrapper# apt-get install '/media/marcus/UltraFlat/Fujitsu Treiber Problem/ndiswrapper/ndiswrapper-dkms_1.59-2_all.deb'
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Hinweis: »ndiswrapper-dkms« wird an Stelle von »/media/marcus/UltraFlat/Fujitsu Treiber Problem/ndiswrapper/ndiswrapper-dkms_1.59-2_all.deb« gewählt.
    Die folgenden NEUEN Pakete werden installiert:
    0 aktualisiert, 1 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    Es müssen noch 0 B von 156 kB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 752 kB Plattenplatz zusätzlich benutzt.
    Holen:1 /media/marcus/UltraFlat/Fujitsu Treiber Problem/ndiswrapper/ndiswrapper-dkms_1.59-2_all.deb ndiswrapper-dkms all 1.59-2 [156 kB]
    Vormals nicht ausgewähltes Paket ndiswrapper-dkms wird gewählt.
    (Lese Datenbank ... 303699 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von .../ndiswrapper-dkms_1.59-2_all.deb ...
    Entpacken von ndiswrapper-dkms (1.59-2) ...
    ndiswrapper-dkms (1.59-2) wird eingerichtet ...
    Loading new ndiswrapper-1.59 DKMS files...
    First Installation: checking all kernels...
    Building only for 4.6.0-kali1-amd64
    Module build for the currently running kernel was skipped since the
    kernel source for this kernel does not seem to be installed.
    N: Can't drop privileges for downloading as file '/media/marcus/UltraFlat/Fujitsu Treiber Problem/ndiswrapper/ndiswrapper-dkms_1.59-2_all.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Keine Berechtigung)

    Since I have no Internet on the Laptop, I tried to download all packages with it's dependencies (i have an screenshot of all installed packages as attachment), but the problem is still the same.

Similar Threads

  1. Error when i clean install driver for my usb RTL8812BU
    By Dotitoz in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2021-12-30, 16:38
  2. Replies: 3
    Last Post: 2017-09-08, 08:27
  3. Error: trying to install driver for DWA-131 Wireless-N Nano USB Adapter
    By Crashtime in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-07-04, 00:52
  4. ndiswrapper install error
    By dupek in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2014-09-23, 03:53
  5. gettin following error when trying to install rt3290sta driver
    By kcsahu90 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2014-03-24, 12:45

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts