Results 1 to 5 of 5

Thread: 404 errors when installing metapackages

  1. #1
    Junior Member
    Join Date
    Jan 2016
    Posts
    5

    404 errors when installing metapackages

    Dear Kali community,

    I'm using Kali Nethunter 3.15 on my Nexus 6 (Android 7.0).
    When trying to add a metapackage (kali-linux-web), I get a lot of 404 errors.
    E.g. W: Failed to fetch http://security.kali.org/dists/sana/...armhf/Packages 404 Not Found

    My sources.list reads:
    deb http://http.kali.org/kali sana main non-free contrib
    deb-src http://http.kali.org/kali sana main non-free contrib
    deb http://security.kali.org/kali sana/updates main non-free contrib
    deb-src http://security.kali.org/kali sana/updates main non-free contrib

    and I even added:
    deb http://http.kali.org/kali kali-rolling main non-free contrib
    deb http://http.kali.org/kali kali main non-free contrib
    deb http://security.kali.org/kali-security kali/updates main non-free contrib

    What am I doing wrong?

    Many thanks and best regards
    Muhackl

  2. #2
    Junior Member
    Join Date
    Jan 2017
    Posts
    3
    Change the source to the Rolling Kali distro and it will update.

  3. #3
    Junior Member
    Join Date
    Jan 2016
    Posts
    5
    Do you mean
    deb http://http.kali.org/kali kali-rolling main non-free contrib
    If yes - please see my post above - I already added it but had no success.

  4. #4
    Junior Member
    Join Date
    Jan 2017
    Posts
    3
    Did you try to run apt-get update then apt-get upgrade from the kali terminal?

  5. #5
    Junior Member
    Join Date
    Jan 2017
    Posts
    5
    Quote Originally Posted by muhackl666 View Post
    Dear Kali community,

    I'm using Kali Nethunter 3.15 on my Nexus 6 (Android 7.0).
    When trying to add a metapackage (kali-linux-web), I get a lot of 404 errors.
    E.g. W: Failed to fetch http://security.kali.org/dists/sana/...armhf/Packages 404 Not Found

    My sources.list reads:
    deb http://http.kali.org/kali sana main non-free contrib
    deb-src http://http.kali.org/kali sana main non-free contrib
    deb http://security.kali.org/kali sana/updates main non-free contrib
    deb-src http://security.kali.org/kali sana/updates main non-free contrib

    and I even added:
    deb http://http.kali.org/kali kali-rolling main non-free contrib
    deb http://http.kali.org/kali kali main non-free contrib
    deb http://security.kali.org/kali-security kali/updates main non-free contrib

    What am I doing wrong?

    Many thanks and best regards
    Muhackl
    1. Change you repos to the offical kali rolling dists.
    2. Run apt-get upgrade
    3. Run apt-get update
    4. Thus is what people forget: run apt-get dist- upgrade

    Done!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •