Results 1 to 2 of 2

Thread: Kali Pi /lib/modules/(uname -r)/build no such file or directory

  1. #1
    Junior Member
    Join Date
    Jan 2017

    Kali Pi /lib/modules/(uname -r)/build no such file or directory

    I am trying to install a device driver for a wifi dongle on a raspberry pi 3

    I want to compile it but i am not able to since the make command says there is no build folder (i indeed cannot access that folder)

    I have tried installing the kernel files (or whatever this is called i dont know much about linux, just getting started) with:

    apt-get install linux-headers-(uname -r)
    I also tried:

    apt-get install linux-generic
    both commands either dont find a package or say the package is dependent or obsolete

    I hope this enough information if i missed anything just ask I will provide it

    Any help is apprechiated


  2. #2
    Junior Member
    Join Date
    Mar 2017

    Same problem on Asus chromebook

    Same thing on Asus chromebook (veyron image). upgrade and dist-upgrade don't solve the problem. cleaning apt cache don't help either, I am running out of ideas and had no luck on google :-(

    what kali says exactly:
    root@kali:~# apt-get install linux-headers-$(uname -r)
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-headers-3.14.0
    E: Couldn't find any package by glob 'linux-headers-3.14.0'
    E: Couldn't find any package by regex 'linux-headers-3.14.0'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts