Results 1 to 3 of 3

Thread: apt-get upgrade causing problems with udev and other kernels on RPi 3

  1. #1
    Join Date

    apt-get upgrade causing problems with udev and other kernels on RPi 3

    I have attempted to install Kali Linux on my new RPi 3 eight times, following different procedures, but in the end I always need to perform the upgrade and it always results in problems booting the Pi afterwards, causing there to be no inputs on the login screen and a freeze after a few moments.

    The hardware involved:
    - Samsung EVO 32 gb class 10 micro SD - I've also used a Sandisk Ultra 32 micro SD
    - Raspberry Pi 3
    - Raspberry Pi 7'' Touchscreen
    - Canakit supplied power supply
    - Anker Powercore 20100 5V 4.8a power bank (if I had to move to be in front of my computer to read instructions)

    This is the procedure I go through every time:
    0) If I'm redoing this procedure, I use SD Formatter, Full Erase, no format size adjustment.
    1) Using WinDisk32Imager, I use the kali-2.1.2-rpi2 image that is provided from Offensive Security and burn the image onto the micro SD.
    2) Login and change the passwd.
    3) nano /etc/network/interfaces and add:
    auto wlan0
    face wlan0 inet dhcp
    4) This is where I have deviated to try several things to get around having to do the upgrade, as that seems to be problematic
    apt-get update
    apt-get install gparted
    apt-get upgrade
    For clarity, I did use gparted before the upgrade
    apt-get clean && apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y
    5) If I skip the upgrade I do:
    apt-get install kali-linux-full
    Looking at the sources.list, everything checks out, except that non-free and contrib have their places switched in the documentation from Kali Linux's website:
    deb kali-rolling main non-free contrib
    deb-src kali-rolling main non-free contrib
    I have not tried older versions, but I thought that this release might be more RPi 3 friendly.
    I have also not tried burning the micro SD image using the dd command in a Linux distro via Virtualbox, but I tried it and had an error getting the Virtualbox to work with the SD card reader.

    To be clear, this is the first time I've worked with any kind of Linux and, while having to do this eight times and failing has taught me a little bit, I thought I might source this out to the community because this is getting frustrating and I'd like to start learning about security soon.
    Last edited by maiki; 2017-02-03 at 09:05. Reason: Remove YouTube link

  2. #2
    Join Date
    Hello, did you got any error message that could help us diagnose the issue, after the upgrade, could you maybe look at the empty space on the sd card, just in case

  3. #3
    Join Date
    I have recorded the boot process. I will recreate the error again and take some pictures of the results of upgrading.

    This is the command I use to do the upgrades:
    This is what is returned to me at the end of the upgrade process:
    These are a few snapshots of what is happening when the packages try to install:
    I wish I knew how to provide more information, but I'm lost as to where to look to diagnose this problem and why it occurs, so any helpful tips about how to bring up information that will give us a more in-depth look at what's happening will be greatly appreciated.
    Last edited by maiki; 2017-02-04 at 09:40. Reason: Merge posts

Similar Threads

  1. apt-get dist-upgrade produces multiple boot kernels
    By paulixtroy in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-03-04, 12:11
  2. NetworkManager causing problems ?
    By Travis9090 in forum General Archive
    Replies: 0
    Last Post: 2014-06-06, 07:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts