Results 1 to 4 of 4

Thread: airmon did work until I updated :-(

  1. #1
    Join Date
    2013-Dec
    Posts
    2

    airmon did work until I updated :-(

    installed kali-linux-2016.2-i386.iso to harddrive
    tried a few apps like reaver
    all good

    updated kali (from settings->details->check updates)
    tried a few apps like reaver & wifiite
    all fail :-( wash and wifite can see aps, but can't associate with them (suspect problem transmitting packets - but can receive promiscuously?)

    boot 2016.2 from usb
    everything works again.

    clearly updating kali broken things.

    the wifi nic is an atheros ar242x/ar542x pcie using ath5k driver.

    is there any suggestions on what and how to rollback? eg did ath5k get updated since 2016.2?

  2. #2
    Join Date
    2013-Feb
    Posts
    225
    Sorry, but without proper debugging info, this post is not actionable. Updating Kali hasn't broken anything for me.

  3. #3
    Join Date
    2017-Jan
    Posts
    5
    Hi steelbytes
    i've the same problem, and some days ago i've posted this post
    Code:
    hi guys, i've a problem, with my wifi card...
    
    running airodumpo-ng on wlan0mon, i see all networks captable, but there is no one client (maybe iy see itself )...before upgrading was working fine... can you help me please?
    
    i show more :
    Code:
    cat /etc/*{release,version}
    DISTRIB_ID=Kali
    DISTRIB_RELEASE=kali-rolling
    DISTRIB_CODENAME=kali-rolling
    DISTRIB_DESCRIPTION="Kali GNU/Linux Rolling"
    PRETTY_NAME="Kali GNU/Linux Rolling"
    NAME="Kali GNU/Linux"
    ID=kali
    VERSION="2016.1"
    VERSION_ID="2016.1"
    ID_LIKE=debian
    ANSI_COLOR="1;31"
    HOME_URL="http://www.kali.org/"
    SUPPORT_URL="http://forums.kali.org/"
    BUG_REPORT_URL="http://bugs.kali.org/"
    Kali Linux Rolling
    cat: /etc/subversion: È una directory
    Code:
    lspci | grep Ather
    02:00.0 Ethernet controller: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
    Code:
    root@Asgard:~# dmesg | grep ath5k
    [ 11.829852] ath5k 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
    [ 11.830029] ath5k 0000:02:00.0: registered as 'phy0'
    [ 12.396437] ath5k: phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
    [ 236.003411] ath5k: ath5k_hw_get_isr: ISR: 0x00000080 IMR: 0x00000000
    [15988.004967] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [23068.005332] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [24268.005022] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [26428.004913] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [26908.004633] ath5k: ath5k_hw_get_isr: ISR: 0x00000080 IMR: 0x00000000
    [31828.004523] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [32428.004737] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [35068.005301] ath5k: ath5k_hw_get_isr: ISR: 0x00000080 IMR: 0x00000000
    [36268.001901] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [36628.005114] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [36988.003952] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [38428.004650] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [41788.003324] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [42028.004905] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [42148.005186] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [42628.004856] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [49588.005008] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [50788.004766] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [51629.884057] ath5k: ath5k_hw_get_isr: ISR: 0x00000001 IMR: 0x00000000
    [53068.004539] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [54991.400078] ath5k: ath5k_hw_get_isr: ISR: 0x00000004 IMR: 0x00000000
    [59548.004532] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [60868.004943] ath5k: ath5k_hw_get_isr: ISR: 0x00000080 IMR: 0x00000000
    [63028.005078] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    [68788.004855] ath5k: ath5k_hw_get_isr: ISR: 0x00000080 IMR: 0x00000000
    [70588.005256] ath5k: ath5k_hw_get_isr: ISR: 0x00000400 IMR: 0x00000000
    i've alot of time to remove module ath5k and reinstall it with a lot of option, but nothing change.
    
    
    Code:
    root@Asgard:~# iwconfig
    wlan0 IEEE 802.11bg ESSID:"HighWay"
    Mode:Managed Frequency:2.462 GHz Access Point: C4:EA:1D:BC:5F:A7
    Bit Rate=54 Mb/s Tx-Power=20 dBm
    Retry short limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff
    Link Quality=51/70 Signal level=-59 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:113 Invalid misc:1597 Missed beacon:0
    
    lo no wireless extensions.
    
    eth0 no wireless extensions.
    Code:
    root@Asgard:~# ifconfig
    
    
    wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 192.168.1.125 netmask 255.255.255.0 broadcast 192.168.1.255
    inet6 fe80::223:4eff:fe56:a781 prefixlen 64 scopeid 0x20<link>
    ether 00:23:4e:56:a7:81 txqueuelen 1000 (Ethernet)
    RX packets 167618 bytes 186191338 (177.5 MiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 95444 bytes 11563273 (11.0 MiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
    Code:
    root@Asgard:~# airmon-ng check kill
    
    Killing these processes:
    
    PID Name
    2058 wpa_supplicant
    
    root@Asgard:~# airmon-ng start wlan0
    
    
    PHY Interface Driver Chipset
    
    phy0 wlan0 ath5k Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
    
    (mac80211 monitor mode vif enabled for [phy0]wlan0 on [phy0]wlan0mon)
    (mac80211 station mode vif disabled for [phy0]wlan0)
    
    root@Asgard:~# airodump-ng wlan0mon
    
    CH 5 ][ Elapsed: 2 mins ][ 2017-01-26 17:47
    
    BSSID PWR Beacons #Data, #/s CH MB ENC CIPHER AUTH ESSID
    
    C4:EA:1D:BC:5F:A7 -63 317 1 0 11 54e WPA2 CCMP PSK HighWay
    32:91:8F:44:1C:9E -69 207 0 0 1 54e. WPA2 CCMP MGT WOW FI - FASTWEB
    30:91:8F:44:1C:9D -68 217 0 0 1 54e WPA2 CCMP PSK TNCAP441C9D
    F0:84:2F:C9:60:86 -71 231 0 0 9 54e WPA2 CCMP MGT WOW FI - FASTWEB
    F0:84:2F:C9:60:83 -71 235 0 0 9 54e WPA2 CCMP PSK FASTWEB-1-K1RcVvAkG4nR
    C4:EA:1D:69:06:31 -81 108 0 0 1 54e WPA2 CCMP PSK FASTWEB-1-690631
    C6:EA:1D:69:06:32 -84 88 0 0 1 54e. WPA2 CCMP MGT WOW FI - FASTWEB
    F8:35D:EB:07:31 -89 36 0 0 11 54e. WPA CCMP PSK GOinternet_EB0734
    00:F4:6F:08:20:E7 -89 69 0 0 1 54e. WPA2 CCMP PSK AndroidHotspot7953
    DC:0B:1A:3B:BD:5B -92 4 0 0 1 54e WPA2 CCMP PSK Telecom-71687253
    
    BSSID STATION PWR Rate Lost Frames Probe
    
    C4:EA:1D:BC:5F:A7 00:23:4E:56:A7:81 -1 1e- 0 0 4
    
    root@Asgard:~#
    after 2 minutes my iphone connected to the same network don't has been found. and i can't believe that all round there i no one client.. ..
    
    (the only client that's appeare, is my pc connected to my network, and the result si very strange after airmon-ng check kill)
    
    what i've to try?
    
    thanks a lot
    but unfortunately without any answer.. .. i'm thinking as you there is any problem in kali2, and driver ath5k... i've read a lot but i haven't found a solution.

    i hope someone can help us

  4. #4
    Join Date
    2016-Nov
    Location
    Outer space
    Posts
    74
    This problem happened to me too sometimes... my theory is after a kernel update, sometimes, the firmware packages are not updated at the same time. If you wait a couple of days usually the updates finally arrive and everything start working again. That's what happened to me

Similar Threads

  1. Replies: 0
    Last Post: 2015-05-11, 17:13
  2. Replies: 0
    Last Post: 2015-05-07, 15:03
  3. updated 1.0.4 ISO becomes 1.0.5?
    By Quest in forum Building Archive
    Replies: 0
    Last Post: 2013-08-30, 13:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •