Hi, i've been googling for months, but still no solution, here's my situation and problem and what i've tried:

1. I have Nexus 7 2012 tablet
2. I flashed nethunter onto it using multirom (there's only 1 nethunter for 2012 version, so i used that).
3. everything seem to working fine, i set the Kali nethunter as primary ROM and deleted secondary one.
4. I have over 10 wifi adapters, most compatible and used ones I have are:
Alfa AWUS036N (or NH or NHR, think i have all 3)
- I've read that those are most compatible with Kali, both adapters work perfectly fine on Kali installed on laptop. I also have BackTrack5 on old laptop and they work perfectly fine there too.
5. So when i connect either adapter via OTG cable to my Nexus 7 tablet and do the following:
- run terminal > Kali
- i type in lsubs and get:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
- If i disconnect the adapter, then both Bus 002 disappears, while the first one remains (why both disappear, isn't the middle one my card?? why does last entry disappear?)

So anyway, here's the problem, when i run airmon-ng with or without plugging the card in, I get only:
phy0 p2p0 ?????? unable to detect for sdio 0x02d0:0x4330
phy0 wlan0 ?????? unable to detect for sdio 0x02d0:0x4330

regardless if i unplug or plug in the wireless cards, results are always same, while using lsusb I see the cards just fine, so because of that, I can't put the card in monitor mode.
I have literally googled for months and found nothing useful, some say the entire kali is broken and suggested to use some nightly grouper, but i have no idea what it is, where to get it or how to install it. I'm not a linux user, i've been using Kali from the BackTrack times, but only to mess around with networks.

NOTE - I'm using a non y-cable, It's a OTG cable and the LIGHT on the adapter turns ON, so that indicates that it gets enough power, yes?

I have seen some people saying drivers are missing, but even BackTrack3 had drivers for those adapters, so why did they get removed? I think those people are wrong, but some say "blah blah blah i blahhed here and then installed driver apt-get and blah blah and it worked" but sorry, i don't understand those people, too confusing to read out what they did exactly.

I also read that turning off the wireless optimization helps, but it's already off on mine, did not work.

Some also say something like "blah blah copy your driver from chroot folder to your firmware folder blah blah and it works" but that doesn't tell me anything either, i have no idea what this means or what is chroot folder or firmware folder, there are no specific steps.

Can someone please explain this issue and if there's a known fix that actually works? Thanks.