Results 1 to 22 of 22

Thread: Kali 2016.2 dualboot with Win10...

  1. #1
    Join Date
    2017-Feb
    Posts
    7

    Unhappy Kali 2016.2 dualboot with Win10...

    Hello everyone.

    I've tried almost everything and I cannot make it work... so I have to post here and I hope it's the correct place.

    My build:
    Asus X553M

    So here is what I did until now.
    -Made a bootable USB with Kali inside
    http://docs.kali.org/downloading/kal...ve-usb-install
    -Followed this guide to instal Kali
    http://docs.kali.org/installation/ka...d-disk-install
    -Now the troubles begins... As many users I don't boot on Grub nor Kali, I still boot on Win10. The problem is like many, I cannot boot on the Kali I just installed, it doesn't appear on the Windows Boot menu (I think it shouldn't appear). But as there is no Grub menu I cannot boot on it as Win doesn't allow it (just guessing here).
    -Here are more infos on what I already did before installing Kali:
    ON BIOS it says: CSM enabled, SECURE BOOT disabled
    Created a 25 Go partition from my DATA Disk (It was unalocated).

    -Next steps are the one I tried without succes to make it boot, but I just couldn't:
    -I've tried this at first, but no success at all
    https://forums.kali.org/showthread.p...With-Windows-7
    -Boot Repair installed on another USB stick, pressed the repair button, said everything was repaired, but when I restarted as it was asked, it froze. When restarted Win10 was there and no Grub nor any change at all.

    Here are the pastebin from Boot Repair Disk:
    Before I clickek on repair button:
    http://paste.ubuntu.com/24036727/
    After it said everything was repaired:
    http://paste.ubuntu.com/24036750/



    ------------------------------

    I have no skill in programation or linux systems. But after reading the last log from Boot repair, it says there is something wrong with SDA7 (where Kali is installed).


    Thanks everyone for your time

  2. #2
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Boot repair doesn't work in UEFI.
    You can re-install grub by booting into kali live USB. Here is the list of commands you need to enter. I updated the list, i know you have already tried them once with missing command.
    Code:
    sudo mount /dev/sda7 /mnt
    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /sys /mnt/sys
    sudo mount /dev/sda1 /mnt/boot/efi
    sudo chroot /mnt
    grub-install /dev/sda
    update-grub
    exit
    sudo umount /mnt/dev
    sudo umount /mnt/proc
    sudo umount /mnt/sys
    sudo umount /mnt
    Replace * in sudo mount /dev/sda* /mnt with your linux partition assigned value.
    Replace ** in sudo mount /dev/sda** /mnt/boot/efi with your EFI partition assigned value.
    Use fdisk -l to list all partitions with their /dev/sda assigned number.
    Last edited by _defalt; 2017-02-22 at 13:24.

  3. #3
    Join Date
    2017-Feb
    Posts
    7
    Hi tried but it says this:
    mount: mount point /mnt/boot/efi does not exist

    That s what I have when I do the fdisk -l:
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 16BAB683-925B-471E-BEE9-5A46869F45F6

    Device Start End Sectors Size Type
    /dev/sda1 2048 534527 532480 260M EFI System
    /dev/sda2 534528 567295 32768 16M Microsoft reserved
    /dev/sda3 567296 389689343 389122048 185.6G Microsoft basic data
    /dev/sda4 389689344 390711295 1021952 499M Windows recovery environment
    /dev/sda5 390711296 926074879 535363584 255.3G Microsoft basic data
    /dev/sda6 926074880 926076927 2048 1M BIOS boot
    /dev/sda7 926076928 968626175 42549248 20.3G Linux filesystem
    /dev/sda8 968626176 976771071 8144896 3.9G Linux swap

    Disk /dev/sdb: 30 GiB, 32224837632 bytes, 62939136 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x00000000

    Device Boot Start End Sectors Size Id Type
    /dev/sdb1 * 2048 10477567 10475520 5G c W95 FAT32 (LBA)
    /dev/sdb2 10477568 62924799 52447232 25G 83 Linux

  4. #4
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    I edited the commands to make them fit with your partitions. Try them again.

  5. #5
    Join Date
    2017-Feb
    Posts
    7
    Hi, nop it's not working. It's exactly what I tried before.
    Here I took a pic. Sorry I appear on the reflect...

    http://imgur.com/a/1kTDr

  6. #6
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Replace mount /dev/sda1 /mnt/boot/efi with mount /dev/sda1 /mnt/boot.

    If the above step doesn't work then there is a very rare chance that the directory name maybe case sensitive. In this case write EFI instead of efi.

    If either of the above steps don't work then in a separate terminal enter mount /dev/sda1 /mnt. Then open file manager>go to other locations>Computer>mnt>Your EFI partition must have been mounted here. Show the screenshot or output of the contents inside it.

    Have you installed kali in Legacy BIOS?(Big no for this)

    You can try all these solution because I really don't want that you will have to wait for reply so I wrote all of the options at once.
    Last edited by _defalt; 2017-02-24 at 02:32.

  7. #7
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Meanwhile, I'm testing a solution for resolving lvmetad warning you are getting after update-grub. You know you can skip this command. I did and it does not cause any harm.

  8. #8
    Join Date
    2017-Feb
    Posts
    7
    Actually, I don't have any option in setup BIOS to select the legacy BIOS not the UEFI ...

    Are you sure it-s
    mount /dev/sda2 /mnt

    and not
    mount /dev/sda1 /mnt

    -----------------------------------
    ON this computer>
    -Computer
    -OS
    -DATA
    ----------------------------
    Computer>
    files are
    0 (text file and empty)
    initrd.img
    initrd.img.old
    vmlinuz
    vmlinuz.old
    Folders are>
    bin
    boot
    dev
    etc
    home
    lib
    lib64
    media
    mnt
    opt
    proc
    root
    run
    sbin
    srv
    sys
    tmp
    usr
    var
    ------------------------------------------------
    on computer/mnt
    no files>
    Folders are>
    EFI
    grub
    -------------------------------------------------

    PS: it didn-t work with EFI in capitals
    PS2: should I try to disable CSM ?
    PS3: here is a pic of what I have with gparted, that way you can also check the labels, etc.
    i'll post in 1h... 10kb/s connection...
    http://imgur.com/LHGVFB7
    Last edited by tomume; 2017-02-23 at 23:13.

  9. #9
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    It is /dev/sda1, I didn't notice. My mistake I wrote it incorrect.

  10. #10
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    I don't understand why your EFI partition is not being mounted. When I run first five commands in kali live USB they are all successfully mounted.

    Once I tried to mount my EFI partition alone without mounting any other partition. Then only It gave me error that mount point /mnt/boot/efi does not exist. It was because there was no directory in mnt folder. But if there is a partition(say /dev/sda7) already mounted in /mnt and you want to mount another partition(say /dev/sda1) it creates separate directory to mount another partition. That's why in the 5th command it is written mount /dev/sda1 /mnt/boot/efi. It basically tells the OS to mount this partition in /mnt/boot/efi. The folder boot and the sub-folder efi is automatically created.

    Same things are meant for /mnt/dev, /mnt/proc and /mnt/sys.

    Run those commands again and if that mount error comes again just create a new folder boot in /mnt and a sub-folder efi in /mnt/boot. Then mount /dev/sda1 again. That's not a big thing.
    Last edited by _defalt; 2017-02-24 at 12:20.

  11. #11
    Join Date
    2017-Feb
    Posts
    7
    Hi, I created a folder with some pics.
    http://imgur.com/a/0qehN
    Don't know if it can help you as I'm going short on ideas.
    -Maybe it's because I installed from transcend and not UEFI transcend? ( Transcend is my USB key)
    -Maybe it's because I live boot from persistent Kali?

    Anyway there is something sure I'm doing wrong and I cannot figure it.out.


    I'll download again Kali and install it on my USB again to see if it changes something...

  12. #12
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    It doesn't matter which USB you are choosing. Points to remember while installing kali are Keep Legacy BIOS and Secure BOOT disabled. The bootable USB must have efi boot files to be recognized by UEFI and UEFI should be of latest version to prevent boot problems. Outdated UEFI and BIOS version cause installer to freeze.

    One thing I forgot to tell you. If grub is present(or corrupted) in /EFI/kali( /dev/sda1 directory) then you won't be able to re-install grub by installing kali again. It will show an error cannot create dummy of grub something like that. So it'll be of no use.

    Either run those commands again or check in EFI if grub is there. Mount /dev/sda1 by booting into kali-live and enter mount /dev/sda1 /mnt. Go to /mnt/EFI. I'm sure there is one in /mnt/EFI/kali:grubx64.efi

  13. #13
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Is it still showing mount point does not exist? The weird thing I found in your screenshot is that there is a grub folder adjacent to EFI.

  14. #14
    Join Date
    2017-Feb
    Posts
    7
    I'll erase everything and try again from scratch to see if it changes anything.
    Maybe there is a weird grub folder because I ran boot repair.
    The thing is that I cannot disable nor enable legacy BIOS because I don't have this option in BIOS. I checked yesterday it's the last version (214) for my motherboard. I'll try this this afternoon.

    What should I use to create the bootable USB stick? Which would you use?
    Last edited by tomume; 2017-02-24 at 16:18.

  15. #15
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Don't mess up with your EFI partition. It contains bootloader of Windows 10 and OEM recovery along with the Boot Configuration Data of Windows 10. It also boots signed firmware to update UEFI. If anything goes wrong you will lose access to windows 10 and system recovery.
    Don't pay attention to Legacy BIOS. Consider it nothing.

    Use rufus to create bootable USB.

  16. #16
    Join Date
    2017-Feb
    Posts
    7
    I did it ! at last...
    I cheated a little bit...

    So, I'll post my solution, it can always be usefull for someone else.

    1) Go here and download the Kali weekly build: kali-linux-2017-W08-amd64 (this is the one I used).
    http://cdimage.kali.org/kali-weekly/

    2) Create a bootable USB disk with rufus. I used rufus-2.12p.
    a) MBR for BIOS AND UEFI. FAT32. Default. FreeDOS.
    b) select your disk image. When rufus asks you to download the files say YES. Then click to start.

    3) Create partition as many tutorials are available. You'll need at least 20GB of free disk space and unallocated.

    4) When the computer start press F2 or ESC (or delete and go to boot overide) to boot on your USB key.
    (I got 2 options for my USB KEY, one UEFI Transcend and the other one Transcend. Go to UEFI and press enter[if doesn't work, wipe your USB key and check for error and try again or by another USB Key])

    5) Select Instal Graphic (may be on second page or advanced options). Then follow instructions and install Kali auto on biggest free space (it should be the the partition created in point 3. Check it to be sure).

    6) Follow instructions, reboot and on next boot you should see the GRUB boot menu.

    Congrats you finally did it...

    PS: Obviously you have to be in UEFI mode in BIOS, to have SECURE BOOT disabled and CSM mode enabled.

    I just have to understand now how to boot first on W10.

    Thanks for your patience defalt
    Last edited by maiki; 2017-02-27 at 11:21. Reason: Foul Language

  17. #17
    Join Date
    2017-Apr
    Posts
    3
    hi, i am having the same problems as tomume . In particular when i do

    sudo mount /dev/sda7 /mnt
    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /sys /mnt/sys
    sudo mount /dev/sda1 /mnt/boot/efi
    sudo chroot /mnt
    grub-install /dev/sda
    update-grub
    exit
    sudo umount /mnt/dev
    sudo umount /mnt/proc
    sudo umount /mnt/sys
    sudo umount /mnt

    i get the lvmetad warning .
    Do you know how the other guys did ?

  18. #18
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Quote Originally Posted by toko View Post
    hi, i am having the same problems as tomume . In particular when i do

    sudo mount /dev/sda7 /mnt
    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /sys /mnt/sys
    sudo mount /dev/sda1 /mnt/boot/efi
    sudo chroot /mnt
    grub-install /dev/sda
    update-grub
    exit
    sudo umount /mnt/dev
    sudo umount /mnt/proc
    sudo umount /mnt/sys
    sudo umount /mnt

    i get the lvmetad warning .
    Do you know how the other guys did ?
    skip update-grub command

  19. #19
    Join Date
    2017-May
    Posts
    1
    This worked for me. I dual booted win10 with kali 39 hours ago. And in the grub menu there was just kali linux no win10. And these commands made it work. Thanks
    Quote Originally Posted by _defalt View Post
    Boot repair doesn't work in UEFI.
    You can re-install grub by booting into kali live USB. Here is the list of commands you need to enter. I updated the list, i know you have already tried them once with missing command.
    Code:
    sudo mount /dev/sda7 /mnt
    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /sys /mnt/sys
    sudo mount /dev/sda1 /mnt/boot/efi
    sudo chroot /mnt
    grub-install /dev/sda
    update-grub
    exit
    sudo umount /mnt/dev
    sudo umount /mnt/proc
    sudo umount /mnt/sys
    sudo umount /mnt
    Replace * in sudo mount /dev/sda* /mnt with your linux partition assigned value.
    Replace ** in sudo mount /dev/sda** /mnt/boot/efi with your EFI partition assigned value.
    Use fdisk -l to list all partitions with their /dev/sda assigned number.

  20. #20
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Quote Originally Posted by topgun View Post
    This worked for me. I dual booted win10 with kali 39 hours ago. And in the grub menu there was just kali linux no win10. And these commands made it work. Thanks
    By which version of kali you did this process? 2017.1?

  21. #21
    Join Date
    2017-Jun
    Posts
    2
    Just curios if you ever got Kali to work for you? If so I am having the same problems, how did you get it to work? Could use some help

  22. #22
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Quote Originally Posted by Jack210 View Post
    Just curios if you ever got Kali to work for you? If so I am having the same problems, how did you get it to work? Could use some help
    He used this method: https://forums.kali.org/showthread.p...ith-Windows-10

Similar Threads

  1. Problems installing Win10 dualboot on laptop
    By Bernd_L in forum Installing Archive
    Replies: 2
    Last Post: 2017-03-24, 12:42
  2. I installed Kali as a dual boot with Win10, and cant change back to Win10
    By itsdeviant in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-01-08, 19:27

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •