Results 1 to 2 of 2

Thread: getting full kali is a pain

  1. #1
    Join Date

    getting full kali is a pain

    Hey guys,

    I'm currently trying to install Kali linux Full on a raspberry pi3 and I got stuck at some point.

    I folowed this sequence to get it done:

    1. Write kali linux arm 2.1.2 into a 32gb sd card.
    2. Plugged into rpi.
    3. Run apt-get update
    4. Run apt-get install gparted
    5. Expanded the disk size with gparted.
    6. Run apt-get install kali-linux-full.

    Here comes the problem, after a few hours of waiting at this step, where the packages are being "selected, unpacking", i'm getting a bunch of "dpkg: error processing archive" and the system goes into read-only mode. No extra tools are installed, just the original ones.

    I've tried to change the repositories, tried with sana/the new ones and both. No success
    I've tried to run the apt-get upgrade first, no success.
    Tried to change the sd card to a 16gb one, no success.
    Tried to write the 0.6-rpi3 image on the sd card, same issue.

    The problem is that I am not getting the full set of tools, just the basic ones. What am I doing wrong, it's already 4 days of struggling to get it work, tried bunch of things, changes sd cards and so on.

    Thanks a lot in advance.

  2. #2
    Join Date
    after you expanded the partition, did you reboot?

    Looking in dmesg to see why it goes into read only mode would help a ton in troubleshooting what's going on there.

Similar Threads

  1. Kali ARM using FULL SD CARD
    By Quicksilver123 in forum Installing Archive
    Replies: 0
    Last Post: 2016-10-29, 00:59
  2. Replies: 1
    Last Post: 2014-01-10, 21:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts