HII, everyone.

I'm using kali linux, from around 1year, and acknowledge its power to recognize all connected hardware automatically.

But, when I tried to use my external wifi card i.e. tp-link wn823n, with my kali installation on my pc, it did'nt recognise it by default.

I tried using ifconfig and iwconfig and got the following output, which is nothing.

root@BlueberryIT:~# ifconfig
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:30:18:a0:ae:93  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 28  bytes 1812 (1.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 28  bytes 1812 (1.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

root@BlueberryIT:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.
as you can see there is no wifi interface detected.

Then the lsusb command gives following output:

harsh@BlueberryIT:~$ lsusb
Bus 005 Device 005: ID 05c6:f00e Qualcomm, Inc. 
Bus 005 Device 003: ID 2357:0109  
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Here, device 003 is the device wn823n, and its not showing any information.

The dmesg command returns the following information about the device:

root@BlueberryIT:~# dmesg
[    0.000000] microcode: microcode updated early to revision 0xa4, date = 2010-10-02
[    0.000000] Linux version 4.6.0-kali1-amd64 ([email protected]) (gcc version 5.4.0 20160609 (Debian 5.4.0-6) ) #1 SMP Debian 4.6.4-1kali1 (2016-07-21)
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.6.0-kali1-amd64 root=/dev/sda2 ro initrd=/install/gtk/initrd.gz quiet
[    0.000000] x86/fpu: Legacy x87 FPU detected.
[    0.000000] x86/fpu: Using 'eager' FPU context switches.


[    1.880776] hid-generic 0003:046D:C05A.0001: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:1d.0-1/input0
[    1.965217] usb 4-3: New USB device found, idVendor=2357, idProduct=0109
[    1.965226] usb 4-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    1.965231] usb 4-3: Product: 802.11n NIC 
[    1.965235] usb 4-3: Manufacturer: Realtek 
[    1.965239] usb 4-3: SerialNumber: 00e04c000001
[    2.376785] md: bind<sda3>
[    2.378882] md: raid0 personality registered for level 0
[    2.379341] md/raid0:md0: md_size is 2095104 sectors.
[    2.379345] md: RAID0 configuration for md0 - 1 zone
[    2.379347] md: zone0=[sda3]
[    2.379353]       zone-offset=         0KB, device-offset=         0KB, size=   1047552KB
finally,I searched for it's drivers on official site and downloaded this driver:

when i tried to build the make file i got the following error:

harsh@BlueberryIT:~/Desktop/TL-WN823N(EU)_V2_160315_Linux/Driver$ make
"NO SKRC,we will use default KSRC"
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.6.0-kali1-amd64/build M=/home/harsh/Desktop/TL-WN823N(EU)_V2_160315_Linux/Driver  modules
/bin/sh: 1: Syntax error: "(" unexpected
Makefile:1696: recipe for target 'modules' failed
make: *** [modules] Error 2
harsh@BlueberryIT:~/Desktop/TL-WN823N(EU)_V2_160315_Linux/Driver$ make install
"NO SKRC,we will use default KSRC"
install -p -m 644 8192eu.ko  /lib/modules/4.6.0-kali1-amd64/kernel/drivers/net/wireless/
install: cannot stat '8192eu.ko': No such file or directory
Makefile:1702: recipe for target 'install' failed
make: *** [install] Error 1
so, i searched in various forums about how to fix it and install drivers, I found this

so,I downloaded this driver from github and installed it by make command.

everything went well and i did the same as the instructions in the readme file, where this version of adapter is also listed as compatible, but after rebooting there was still no sign of any wifi interface.

I went to the FAQ section of the driver download in git and found this

Some of the TL-WN823N's do not use the rtl8192cu chipset. If lsusb results show ID 2357:0107, 2357:0108, or 2357:0109 you should use https://github.com/Mange/rtl8192eu-linux-driver as these are rtl8192eu chipsets

the driver was not suitable for wn823n v2 and I should install the following driver:

so I did, frustrated at this point and finally rebooted the system only to find that the interface was still not there and allt the commands such as ifconfig and iwconfig resulted in same output!!!!!!!

absolutely no success

also I can't afford to buy another adapter at this point so please don't try to suggest that.

Please help me if you are experinced and can solve the issue, thanks in advance.