Results 1 to 22 of 22

Thread: Temporary failure resolving 'http.kali.org'

  1. #1
    Join Date
    2017-Mar
    Posts
    4

    Temporary failure resolving 'http.kali.org'

    Hi, I'm seeing the following:

    root@kali:~# apt-get update
    Err:1 http://http.kali.org/kali kali-rolling InRelease
    Temporary failure resolving 'http.kali.org'
    Reading package lists... Done
    W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/InRelease Temporary failure resolving 'http.kali.org'
    W: Some index files failed to download. They have been ignored, or old ones used instead.

    And it's the same for all mirrors. I've no problem with internet connectivity or dns, I can even wget http://http.kali.org/kali/dists/kali-rolling/InRelease.

    This started after an apt-get upgrade && apt-get dist-upgrade so I think it has something to do with apt-get. _apt user is in group 65534.

    Anyone got any ideas?

  2. #2
    Join Date
    2015-Sep
    Posts
    10
    Hi tanyaka,

    I too am experiencing this after returning from a trip. Most of the suggestions I have seen on the internet try to pin it to DNS, however I can confirm:

    1. I can ping the address listed
    2. Google's DNS server are set in my resolv.conf
    3. after waiting a few hours to see if it was a DNS propagation issue the problem persists
    4. the sources.list are consistent with those noted on the official kali blog
    5. I have tried multiple networks with no change

    Please let me know if you can think of anything else to test I'd like to understand what the problem is in this case.

  3. #3
    Join Date
    2017-Mar
    Posts
    4
    Did your problems start happening after an apt-get dist-upgrade?

  4. #4
    Join Date
    2015-Sep
    Posts
    10
    I believe that is true, I will have to look and see if there is a way I can confirm that via the logs later.

  5. #5
    Join Date
    2017-Mar
    Posts
    4

    Unhappy

    Quote Originally Posted by tanyaka View Post
    Hi, I'm seeing the following:

    root@kali:~# apt-get update
    Err:1 http://http.kali.org/kali kali-rolling InRelease
    Temporary failure resolving 'http.kali.org'
    Reading package lists... Done
    W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/InRelease Temporary failure resolving 'http.kali.org'
    W: Some index files failed to download. They have been ignored, or old ones used instead.

    And it's the same for all mirrors. I've no problem with internet connectivity or dns, I can even wget http://http.kali.org/kali/dists/kali-rolling/InRelease.

    This started after an apt-get upgrade && apt-get dist-upgrade so I think it has something to do with apt-get. _apt user is in group 65534.

    Anyone got any ideas?
    I am having the same issue after a completely fresh install. All I did was install the release on Nexus 7 2013, then update the Nethunter app to the latest version and reinstall chroot. Now I can't apt-get update / upgrade / dist-upgrade.

    Anyone figure this out yet?

  6. #6
    Join Date
    2017-Mar
    Posts
    4
    I was able to get apt working by messing with my /etc/hosts file to bypass DNS resolution issues - in the end my file looked like this:
    192.99.200.113 http.kali.org
    209.126.116.149 archive-7.kali.org
    209.126.116.149 archive-9.kali.org
    167.114.101.151 archive-11.kali.org
    Yours may need to be different, but if you follow the error messages after the first line (http.kali.org) you should be able to figure it out.

    Really weird bug...

  7. #7
    Join Date
    2017-Mar
    Posts
    4
    Yes strange I see this now:

    root@kali:~# apt-get update
    Ign:1 http://http.kali.org/kali kali-rolling InRelease
    Err:2 http://http.kali.org/kali kali-rolling Release
    Could not create a socket for 192.99.200.113 (f=2 t=1 p=6) - socket (13: Permission denied)
    Reading package lists... Done
    E: The repository 'http://http.kali.org/kali kali-rolling Release' does no longer have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

    Did you not get the permission denied error?

  8. #8
    Join Date
    2017-Mar
    Posts
    4
    Quote Originally Posted by tanyaka View Post
    Yes strange I see this now:

    root@kali:~# apt-get update
    Ign:1 http://http.kali.org/kali kali-rolling InRelease
    Err:2 http://http.kali.org/kali kali-rolling Release
    Could not create a socket for 192.99.200.113 (f=2 t=1 p=6) - socket (13: Permission denied)
    Reading package lists... Done
    E: The repository 'http://http.kali.org/kali kali-rolling Release' does no longer have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

    Did you not get the permission denied error?
    I did not get a permissions error. Note that after getting the initial install working you have to also spend time getting the kernel updated. I am fighting that fight now and getting very frustrated...

  9. #9
    Join Date
    2015-Sep
    Posts
    10
    Just a note to anyone that stumbles across this thread. I was able to fix this by removing chroot and re-adding. This defaulted to kali-rolling instead of the previous repo's and it now works flawlessly without requiring any tweaking.

    **NOTE you must back up any data you have stored in the chroot as you will lose it**

  10. #10
    Join Date
    2017-Mar
    Posts
    4
    Yep, did the trick for me, thanks for sharing.

  11. #11
    Join Date
    2017-Apr
    Posts
    2
    One thing to check pointed out by mrkumar on this thread:
    https://forums.kali.org/showthread.p...ling-InRelease

    You don't need to use putty or ssh, regular vi or nano will do from a terminal session but the groupid's were wrong on my ootb nethunter install if anyone else is experiencing the same issue:

    Using putty connect to Nethunter and Run
    vi /etc/passwd,
    Change the line
    _apt:x:104:3004::/nonexistent:/bin/false to _apt:x:0:65534::/nonexistent:/bin/false
    Save and Run apt-get update ,It Works Check it ,
    Explanation: Changing GID 3004 to 65534 ,What is GID 3004 on your system?
    The fact that the _apt user is part of "nogroup" is actually the problem.

  12. #12
    Join Date
    2017-Sep
    Posts
    1
    Quote Originally Posted by tanyaka View Post
    Yes strange I see this now:

    root@kali:~# apt-get update
    Ign:1 http://http.kali.org/kali kali-rolling InRelease
    Err:2 http://http.kali.org/kali kali-rolling Release
    Could not create a socket for 192.99.200.113 (f=2 t=1 p=6) - socket (13: Permission denied)
    Reading package lists... Done
    E: The repository 'http://http.kali.org/kali kali-rolling Release' does no longer have a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

    Did you not get the permission denied error?

    Quote Originally Posted by Outis View Post
    Just a note to anyone that stumbles across this thread. I was able to fix this by removing chroot and re-adding. This defaulted to kali-rolling instead of the previous repo's and it now works flawlessly without requiring any tweaking.

    **NOTE you must back up any data you have stored in the chroot as you will lose it**
    How exactly would I fix this error?

  13. #13
    Join Date
    2017-Aug
    Posts
    6
    I just got the error as well. I think Kali has to updated the repositories and it should be fixed hopefully soon. My laptop running Kali is updating fine but my RPi2B is receiving the error.

  14. #14
    Join Date
    2020-Apr
    Posts
    1

    Having trouble fixing the problem.

    Quote Originally Posted by jafoca View Post
    I was able to get apt working by messing with my /etc/hosts file to bypass DNS resolution issues - in the end my file looked like this:

    Yours may need to be different, but if you follow the error messages after the first line (http.kali.org) you should be able to figure it out.

    Really weird bug...
    Can you please walk me through how you fixed yours? I can't seem to get through with this.

  15. #15
    Join Date
    2020-Apr
    Posts
    9
    its seems to be a dbus issue I just run "sudo service dbus start or restart" and it the error goes away hope this helps?

  16. #16
    Join Date
    2020-Aug
    Posts
    1
    I experienced this also. I had already made adjustments to /etc/apt/sources.list to point to the
    required repositories. Updating/upgrading failed. Other than the repositories being added to the
    sources.list file? I changed nothing within the OS! Post reboot & re-run of update/upgrade?
    Still failed. Re-checked sources.list file? All ok.
    So... I shut the Kali VM down & checked VB settings.

    I changed the Ethernet adapter in Virtualbox from NAT to 'bridged' to
    local Ethernet adapter.


    Re-Booted & successfully ran update, upgrade & dist-upgrade with
    no issues.
    Given that Kali is a pentest tool? I suspect it doesn't like 'double NAT'

    Hope this helps. It worked flawlessly for me

    Tks

    Wes

  17. #17
    Join Date
    2020-Nov
    Location
    Russia
    Posts
    1

    Temporary failure resolving http kali org

    That doesnt say you cant though....Compare page 14:A player can resolve dice with different values during the same action, provided they share a symbol.I realize this is under the Resolve Dice action, but Im not sure when reading this what is prohibiting me from resolving more than one die.As a side note, something tells me you are right that you only resolve the one. I just cant find it in the rules.

  18. #18
    Join Date
    2021-Mar
    Posts
    1
    To resolve the error you must check /etc/resolv.conf
    This file is the resolver configuration file in Linux systems.
    It contains the DNS entries that help your Linux system to resolve domain names into IP addresses.
    If this file is not present or is there but you are still having the name resolution error, create one and append the Google public DNS server as shown
    nameserver 8.8.8.8

  19. #19
    Join Date
    2020-Jul
    Posts
    1
    If you are useing nethunter,edit /etc/passwd.and add _apt: x :0:65534::/nonexistent:/bin/false

  20. #20
    Join Date
    2022-Jan
    Posts
    1

    This solution worked. Thanks

    Quote Originally Posted by FirtusCahi View Post
    To resolve the error you must check /etc/resolv.conf
    This file is the resolver configuration file in Linux systems.
    It contains the DNS entries that help your Linux system to resolve domain names into IP addresses.
    If this file is not present or is there but you are still having the name resolution error, create one and append the Google public DNS server as shown
    nameserver 8.8.8.8

  21. #21
    Join Date
    2022-Apr
    Posts
    1
    Quote Originally Posted by FirtusCahi View Post
    To resolve the error you must check /etc/resolv.conf
    This file is the resolver configuration file in Linux systems.
    It contains the DNS entries that help your Linux system to resolve domain names into IP addresses.
    If this file is not present or is there but you are still having the name resolution error, create one and append the Google public DNS server as shown
    nameserver 8.8.8.8

    If anyone is coming here using WSL and getting the error, doing what this dude suggested worked.

  22. #22

    I also followed your method and worked fine.

    :d:d:d:d:d
    Quote Originally Posted by wes2859 View Post
    i experienced this also. I had already made adjustments to /etc/apt/sources.list to point to the
    required repositories. Updating/upgrading failed. Other than the repositories being added to the
    sources.list file? i changed nothing within the os! Post reboot & re-run of update/upgrade?
    Still failed. Re-checked sources.list file? All ok.
    So... I shut the kali vm down & checked vb settings.

    i changed the ethernet adapter in virtualbox from nat to 'bridged' to
    local ethernet adapter.


    re-booted & successfully ran update, upgrade & dist-upgrade with
    no issues.
    Given that kali is a pentest tool? I suspect it doesn't like 'double nat'

    hope this helps. It worked flawlessly for me

    tks

    wes

Similar Threads

  1. Replies: 26
    Last Post: 2022-01-08, 20:33
  2. Cannot install metapackages (temporary failure resolving)
    By redbeardtheweird in forum NetHunter General Questions
    Replies: 10
    Last Post: 2017-04-05, 13:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •