Results 1 to 4 of 4

Thread: Help! Need to Disable Touchscreen

  1. #1
    Junior Member
    Join Date
    Mar 2017
    Posts
    11

    Help! Need to Disable Touchscreen

    I'm fairly new to Linux, only having used Ubuntu for the last couple of months, so please, forgive my inexperience in advance.

    I just dual-booted Kali alongside my Windows 8 OS. Aside from me not being able to get Windows to appear on the GRUB screen (another problem for another thread) my mouse has been going haywire near the top right hand side of my screen. This is due to the fact that my touchscreen was damaged during shipment. In Windows, I was easily able to navigate to the drivers and disable the touchscreen. In Kali Linux this seems like a slightly more difficult task.

    When booting into Kali I struggle to log in. Once I do, the mouse pointer moves rapidly across the top right of the screen select and deselecting options located there. It constantly opens and closes windows which kicks me out of the terminal I'm trying to work in. I'm scarcely able to type in the terminal by quickly tapping the screen and punching a key on the keyboard. It's highly frustrating.

    I've seen that xinput is often used to help locate and disable touchscreen drivers in linux, but alas it looks like Kali doesn't allow that to be installed...that, or I'm doing something wrong.

    Have mercy on me and give me a hand at your earliest convenience if you will. Any help is appreciated.

    Thanks.

  2. #2
    Senior Member
    Join Date
    Oct 2016
    Location
    Please see my biography how you can contact me
    Posts
    366
    Copy-paste the following command into the Terminal and then press ENTER:

    gksudo gedit /etc/modprobe.d/blacklist.conf

    ADD the following configuration line into the file /etc/modprobe.d/blacklist.conf:

    blacklist hid_multitouch

    SAVE the change to the /etc/modprobe.d/blacklist.conf file.

    Then REBOOT.

  3. #3
    Junior Member
    Join Date
    Mar 2017
    Posts
    11
    Thanks! I'll try it later when I get home. Very thankful for the quick reply. Much appreciated.

  4. #4
    Junior Member
    Join Date
    Mar 2017
    Posts
    11
    You are the man! I am responding to you from my Kali OS which is now completely void of a maniacally chaotic touchscreen. A million thanks, my friend.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •